Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum Replies Created

Viewing 25 replies - 1 through 25 (of 88 total)
  • Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Hi @seamile,

    As I have just answered to your post at ja.forums.wordpress.org, try putting back buddypress-ja.mo to the old one that you claimed worked properly before. Then you can see if the problem lies in 1.2.9 or not.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Umm…
    It seems to be hard to read, doesn’t it?

    If you need my fix, I can send it via Email to you. Please do not hesitate to contact me, @slaFFik.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    @slaFFik

    I, as Chestnut, wrote the comment at http://cosydale.com/plugin-cd-avatar-bubble.html.
    Please send me your email and I will send the zip file as a reply.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    @ds123
    Sorry, I have little time to log on here recently as I am living in Japan. I think you can guest the reason…

    Well, I am using the default theme (bp-default) for blog in the buddypress site, and the “Like” is, yes, shown but not in a manner of “button” but “words” it self just under the avatar shown left top of the post.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Thanks for your comment, @modemlooper
    At present, I answered to the Japanese user to comment out the css definition in BP Mobile plugin, in order to show the “Upload pictures” link.

    Well, another option is just like:
    `
    <?php
    $agent = $_SERVER;
    if(ereg(“iPhone”, $agent) || ereg(“iPod”, $agent) || ereg(“iPad”, $agent)) {
    $agentresult = 2;} elseif (ereg(“Android”, $agent)) {
    $agentresult = 1; } else { $agentresult = 0; }
    ?>
    `
    Use the above to identify which device is accessing, and then decide to show/hide upload dialog.
    This can be useful not only for BP Mobile but also BP Album+, @foxly.

    As a member of BP Media project for Asian users, I will consider the better solution when I have time.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Glad to hear that.
    Thank you, @DJPaul

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Sorry, everyone.
    It seems hard for me to participate this discussion regularly, for the time being, due to continued earthquakes, a partial power cut, accidents in nuclear power plants, and so on.

    However, I “will” write when I can.

    @foxly
    That sounds great.
    Though it is a little bit old plugin, we can learn the way of uploading photos though email by “Ktai Entry” plugin that still can be used with WP3.1.

    The plugin can downloaded at:
    https://sourceforge.jp/projects/wppluginsj/downloads/44535/ktai_entry0811.tar.bz2/

    The plugin’s site is written in Japanese at:
    http://wppluginsj.sourceforge.jp/ktai_entry/

    Since the plugin is made befreo WordPress 3.0, it is needed to be altered to use with multi-site feature enabled.

    I have written how to fix it at http://staff.blog.bng.net/administrator/2010/09/28/784.html, which is written on in Japanese, and Japanese people use the plugin adopting my alternation. The plugin author also comments to my post that she will introduce the alternation, but the plugin has not yet been updated.

    If you should know the way of fix the plugin to use with multi-user feature enabled, I will write here in English.

    @modemlooper
    Could you please let me know why you decided to hide the “Upload pictures” link in BP Album +, while “Change Avatar” link is still displayed that is the same feature as “Upload pictures”?

    I am very glad to hear that you are adding BP media support to http://buddiphone.com.
    At the moment, is it possible for you to add to BP Mobile plugin’s readme or faq that the css definition of “display:none” can be deleted if the user wants to use “Upload pictures” link? Otherwise, users could continue to ask about the matter to us, BP Media, including BP Album+.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    @hnla

    I have confirmed that the latest version works properly, thanks!

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Hi @foxly and @modemlooper

    FIrst of all, I really would like to say “Thank you” to modemlooper to participate this discussion.

    While I was away from this thread, the discussion seemed to get the point.

    I have been looking at the script of BP Mobile plugin and I, for myself, found the way how the link of “Upload pictures” is hidden bu the plugin.

    Around the line 2590 of /wp-content/plugins/buddypress-mobile/themes/default/style.css, which is part of css definitions for BP Album+ made by modemlooper, which I really appreciate because he defines css for BP Album+ plugin exclusively!

    I answered to the user in “ja.forums.wordpress.org” as following:
    [ Original ]
    `a#upload {
    display: none;
    }
    `
    [ Changed to ]
    `/*
    a#upload {
    display: none;
    }
    */
    `

    Yes, I agree with modemlooper that not all android can upload photos properly.
    For instance, I and the user who reported this issue first in “ja.forums.wordpress.org” can upload pictures if we use the default browser via our android. However, using other browsers, such as Dolphin Browser and Opera mini, disables the upload feature.

    Nevertheless, BP Mobile plugin still shows “Change Avatar” link, which is disabled by devices such as iPhone that cannot upload photos.

    So, just my opinion is that “Upload pictures” link should not be hidden by BP Mobile plugin, but, if needed, it should be done by BP Album+ plugin. For this point, as foxly said, I also think BP Album+ and BP Mobile plugins can keep in touch with each other.

    Sorry, but I do not have enough time right now. Thus, I will continue to discuss on this matter on Monday.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Big earthquake in Japan
    I am OK, but won’t write awhile

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Thank you @foxly

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    @foxly
    Thank you for your suggestion. I will try that way, and I will ask the BP Mobile plugin author.

    @finni3
    Thank you for your information.
    So, you cannot see the link of “Upload pictures” nor of “Change Avatar” via BP Mobile plugin?

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    @foxly

    I forgot to define what is “mobile phone” for this case.
    Well, bp mobile plugin is for smartphones such as iphone and android, so mobile phones in this case are limited to iphone and android.

    I do not have iphone but android, and when I access to my buddypress site using android via BP Mobile plugin, “Change Avatar” link is correctly shown.

    Clicking “Change Avatar” obviously takes me to the page that I can upload a photo for my avatar and properly upload a photo stored in my android, as if I were using personal computer.

    I did not know this bug because I have not used BP Mobile plugin before.

    Usually, I access to my site without any mobile-related plugin via android. The site look is just the same as when you see it with your PC. Thus, “Upload pictures” link is properly shown and android can upload a picture.

    Unfortunately, I cannot see the page source in my android browser. It could be easy for me to fix this problem for myself if android showed me the page source.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    After changing admin_menu to network_admin_menu, admin panel appeared.
    However, saving options failed.

    I found that options.php in <form action=”options.php”> should be changed to somthing else.

    Does anybody know what to change?

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Thank you for your advice, @dwenaus.

    Timezone issue is yes due to WordPress features. Because I started using WordPress from version 3.0, I do not know the process but WordPress fixes date_default_timezone_set to UTC since version 2.9 or so.

    The simple solution is just comment out the setting starting from the line 30 of wp-settings.php, and WordPress will never changes the user’s date_default_timezone_set to UTC. But, I think this solution will affect BuddyPress features.

    For this reason, some plugins sensitive to date and time, declares date_default_timezone in themselves.

    As WordPress decides to fix date_default_timezone to UTC, I currently do not think it is a bug but its design. So, I think each plugin, if it needs to handle date and time, must decides the way to timezone handling.

    This is just my own individual opinion, I hope you will understand.

    Well, I already customized 2.8.1 just in the same way, but do not put the link here because I do not want to disgust you. It is publicly open in my site and I think it will be still helpful for people, especially Japanese, facing timezone issue.

    Regarding activitysub_textdomain(), people who use English will not see the problem, because sentences never need to be translated. I think you will see what is wrong when you set the language to other than English.

    Anyway, I will continue to think about the better way for the timezone matter.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Hi @boonebgorges and @dwenaus,

    Thank you for releasing 2.8.1, and for your comments.

    To begin with, please understand that I am not trying to disturbing the plugin development. I just want to make it more easy to use, tryin to help on my own way. As I have not yet tried svn and git, it currently is hard for me to make a patch.

    As for timezone, I have been saying that it is obviously an issue. As Dwenaus himeself said, however, that he has never experienced the issue, my customization regardin timezone has not yet been introduced.

    I have customized the plugin due mainly to the timezone issue.

    Please look at the following picture:
    http://photos.yahoo.co.jp/ph/cookie_tkjp/vwp2?.tok=bcPemMgBUkWH8.A5&.dir=/e49d&.dnm=5500.jpg&.src=ph&.view=t&.hires=t

    This is a screen shot taken after upgrading to 2.8.1, the latest version.
    As you can see, it says that the server timezone is UTC (UTC), though I set the timezone as Tokyo in the General Setting, which should be “JST (Asia/Tokyo)”.

    Well, you may think that this is because of my PHP setting. The answer is No.
    My php setting is surely “date_default_timezone_set(‘Asia/Tokyo’);”, which as you know is ignored by WordPress features. WordPress ignores date_default_timezone_set setting and changes it to UTC.

    Looking at line 30 of wp-settings.php, it reads:
    `
    // Set default timezone in PHP 5.
    if ( function_exists( ‘date_default_timezone_set’ ) )
    date_default_timezone_set( ‘UTC’ );
    `

    As a result, my local timezone of Tokyo is ignored and the plugin says that the server timezone is UTC.

    Subsequently, the plugin says that “the current server time is 1:18pm (13:18); and the day is Thursday, which is 9 hours behind the real local time because Tokyo/Asia timezone is UTC+9.

    In these environments, I have to calculate the time for digest delivery which is very much irritating.

    At the same time, declaration of date_default_timezone_set in the plugin also affects the buddypress site overall. Because buddypress sometimes utilize time calculation based on UTC, not on the local timezone.

    For this reason, some plugins, such as WP Events Calendar and Visitor Maps and Who’s Online, are imcompatible with buddypress, because these plugins declare date_default_timezone_set in themselves and this affects buddypress’ features, especially activities time display.

    As a result, I decided to set global setting, and it is called within each function, which does not affects other plugins neighter buddypress overall.

    Looking at bp-activity-subscription.php, you can see:
    `
    /**
    * Added by chestnut_jp starts
    */
    global $localzone;
    if (get_option(‘timezone_string’)) {
    $localzone = get_option(‘timezone_string’);
    } else {
    $localzone = ‘NO/SETTING’;
    }
    /**
    * Added by chestnut_jp ends
    */
    `
    And a function handling the time calls “global $localzone”.

    Secondly, this is also regarding time. It sometimes comfusing people on the usage of date() and time(). Since WordPress fixess timezone to UTC, date() and time() is exclusively based on UTC, not localtime zone. If wanting to calculate time and date on the basis of the user’s local timezone, date_i18n() should be used instead.

    Thus, I changed line 18 or so of bp-activity-subscription-digest.php as following:
    [ Original ]
    `
    $until = ( (int)$sched – time() ) / ( 60 * 60 );
    `
    [ Changed to ]
    `
    if ($localzone != ‘NO/SETTING’) { $lcd = date_i18n(‘U’); }
    else if ($localzone == ‘NO/SETTING’) { $lcd = time(); }
    $until = date(‘H’, (int)$sched – $lcd ).__(‘ hour(s)’,’bp-ass’).’ ‘.da
    te(‘i’, (int)$sched – $lcd ).__(‘ minute(s)’,’bp-ass’).’ ‘.date(‘s’, (int)$sch
    ed – $lcd ).__(‘ second(s)’,’bp-ass’);
    `
    Note that the my change is a little bit complicated because I wanted to show xx hours xx minues xx seconds format. Anyway, time() or date_i18n() should be chosen case by case.

    Third, some parts are not translated.

    For instance, an email is sent right after posting an update, as the group forum option is set to “All Email”. The content of email is written in Japanese, except for the part of “To view or reply, log in and got to:”.

    I am not perfectly sure, but I think this is due to the setting of the function handling this case.

    Look at the line 207 in bp-activity-subscription-functions.php. The function calls global $bp, which consequently tries to read translation from buddypress language files.

    In order to make correct translation, I add “activitysub_textdomain();” right after the line of “global $bp”.

    So, I add “activitysub_textdomain();” after each line of “global $bp”. This is very much helpful.

    Speaking of translation, the line of 434 in bp-activity-subscription-functions.php should be changed to as following, otherwise the sentence cannot be translated properly:

    `
    [ Original ]
    bp_core_add_message( __( $security.’Your email notific
    ations are set to ‘ . ass_subscribe_translate( $action ) . ‘ for this group.’,
    ‘bp-ass’ ) );

    [ Changed to ]
    bp_core_add_message( __( $security.’Your email notific
    ations are set to ‘, ‘bp-ass’ ) . ass_subscribe_translate( $action ) . __(‘ fo
    r this group.’, ‘bp-ass’ ) );
    `
    This change is also included in my customization.

    I will take some time to see the latest version, and will once again customize according to the above issues.

    I do not hope all my customization is included into the original plugin, but I hope the way of timezone setting is.

    Note: if a user set its timezone according to Manual Offsets, my customization will not work for the user. This is because timezone setting from Manual Offsets are not granted as date_default_timezone_set, so the timezone cannot be changed from UTC. For this reason, my cusomization includes “hint” for the case. But, I do not think it should be included into the original plugin.

    Thank you for readin this long sentence written in POOR english.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    No one has no news?

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Thanks for you comment,@hnla

    Yes, I have tried a various ways, and have found that <div> and <ul> collapse the layout of post.
    Try and you will see what I mean.

    Anyway, the point is that single.php uses a wrong function.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Same thing happens here.
    Also, I cannot choose or input tag into a new or editing post.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Thank you very much, @boonebgorges.
    Without your comment, I would not have noticed my mistake.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    I found the reason.

    At line 826 of bp-core/bp-core-templatetags.php:
    $date = date( ‘F j, Y ‘, $time_offset );

    It was my mistake, as I made a typo of “offest” when I change the above time format to Japanese one.
    Fixing “offest” to “offset” let the problem disappear.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Thank you for your comment, @boonebgorges

    Yes, I use several bp-related plugins, but all of them were already used with BP 1.2.6.
    Since the proplem began surfacing right after BP was upgraded to 1.2.7, I thought it would be a bug in 1.2.7.

    I will once again test 1.2.7 with bp-related plugins deactivated.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Because I know the field name or id for datebox, and I use onlye one datebox for birthday, I changed as following just for myself:

    At around line 40 of profile-loop.php located in /wp-content/plugins/buddypress/bp-themes/bp-default/members/single/profile

    [ Original ]
    <?php bp_the_profile_field_value() ?>

    [ Changed ]
    <?php
    if (bp_get_the_profile_field_name() == ‘FIELD NAME’) {
    echo date(‘DATE FORMAT’,xprofile_get_field_data(“FIELD NAME or FIELD ID”));
    }
    else {
    bp_the_profile_field_value();
    }
    ?>
    Note that DATE FORMAT, FIELD NAME and FIELD ID are to be replaced with the true value.

    Once again, this is just only temporary fix, and I still wait until someone comments to this post. Currently, I am wandering if I post to http://trac.buddypress.org.

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    Though I tried both “http://trac.buddypress.org/ticket/2947″ and “http://trac.buddypress.org/ticket/2240″, the problem prolongs.

    The reason why 1970 January 1st is always displayed is that bp_the_profile_field_value and/or related functions always return “0″ ignorring the true value.

    I need to use date(‘Y/m/d’) instead of bp_the_profile_field_value for “datebox” for the time being…

    Anybody has any idea?

    Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    I changed the version from 1.2.6 to 1.3, as it is still awaiting review.

Viewing 25 replies - 1 through 25 (of 88 total)