Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum Replies Created

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of icepin
    icepin
    Participant

    @icepin

    Avatar of icepin
    icepin
    Participant

    @icepin

    an alternative is to change few lines on the login form’s code as posted here: http://buddypress.trac.wordpress.org/changeset/7485

    Cheers

    Avatar of icepin
    icepin
    Participant

    @icepin

    Hello Cam,
    Thanks for your reply, but unfortunately, didn’t worked.
    From wp-login.php I can log in from the first try.
    The scenario is like this: http://s11.postimg.org/t8t4umamb/cookie.png
    I have the login form with the exact code from bp-default’s theme sidebar on my index page, I type the user and PW there, press Login, redirects me to wp-login.php, press again it will log me in. Same scenario on a fresh WP + BP install with BP-Default Theme.

    If I try to log in using directly wp-login.php, I can log in with no problem. But when I try using a login form like the bp-default’s theme:

    <form name="login-form" id="" class="standard-form" action="<?php echo site_url( 'wp-login.php', 'login_post' ) ?>" method="post">
    		<input type="text" name="log" id="" class="input" placeholder="Email sau nume utilizator" value="<?php if ( isset( $user_login) ) echo esc_attr(stripslashes($user_login)); ?>" tabindex="97" />
    	<br />
    		<input type="password" name="pwd" id="" placeholder="Parola" class="input" value="" tabindex="98" />
    	<br />
    
    		<label class="parola"><?php do_action( 'bp_sidebar_login_form' ) ?>
    		<input type="submit" name="wp-submit" id="" value="<?php _e( 'Simply, be awesome!', 'buddypress' ); ?>" tabindex="100" />
    		</label>
    		<label class="parola">Ai uitat parola?</label>
    		<input type="hidden" name="testcookie" value="1" />
    	</form>

    I get cookie error.

    Avatar of icepin
    icepin
    Participant

    @icepin

    Yea, I’m also curious about this one. Starting to get hundreds of comments already on my BP install and it’s pretty annoying to scroll down so much just to read the comment no. 104 from 110 :)

    Avatar of icepin
    icepin
    Participant

    @icepin

    the easiest way would be to create a folder called “languages” in your wp-content folder and put a copy of buddypress.pot from wp-content\plugins\buddypress\bp-languages.

    – Rename the new buddypress.pot from “languages” to “buddypress-en_US.pot”
    – Download Poedit – http://www.poedit.net/download.php – and install it
    – Open “buddypress-en_US.pot” with Poedit
    – Press Ctrl + F and search for “Registering for this site”. The string should appear.
    – In Translation field put any text you want. It will simply replace the original text.

    This is pretty much the best way to use your own words in your BP installation rather then modifying the core files. It might sound complicated but it’s actually pretty easy once you get the hang of it.

    Cheers

    Avatar of icepin
    icepin
    Participant

    @icepin

    wohooo this thread is awesome! @boonebgorges you are also my hero!
    Any idea on how to tweak the code to work for groups too? To show only the updates.

    Avatar of icepin
    icepin
    Participant

    @icepin

    Anyone managed to get what @snark said? Getting the count inline — [Favorite (23)]
    This would be a really nice feature for BP users.

    Cheers

    Avatar of icepin
    icepin
    Participant

    @icepin

    both options working like a charm!
    you guys are awesome, herzlichen dank!

    Avatar of icepin
    icepin
    Participant

    @icepin

    Tried, didn’t worked.
    If anyone will ever need this, the trick is done via .htaccess file.

    RewriteCond %{HTTP_HOST} !^www\..* [NC]
    RewriteRule ^ http://www.domain.com%{REQUEST_URI} [R=301,L]

    So, explained, if your blog/BP network has old links without www. and you recently changed the website URL to http://www.domain.com because you started using a CDN, this will help you to get you’re whole network back with no dead links. Tested on all sides, no errors.

    my .htaccess file looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /

    RewriteCond %{HTTP_HOST} !^www\..* [NC]
    RewriteRule ^ http://www.domain.com%{REQUEST_URI} [R=301,L]

    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Credits:
    http://www.456bereastreet.com/archive/200601/search_engines_and_canonical_urls/
    – the most awesome hosting company support for tweaking the code (KnownHost)

    Cheers! :)

    Avatar of icepin
    icepin
    Participant

    @icepin

    nevermind…

    Avatar of icepin
    icepin
    Participant

    @icepin

    Based on David Carson’s snippet for making the website available only for users, came up with this and it does the job for me so…. maybe others will find it useful:

    // Declare Ban Users by Role function
    function ban_user(){
    global $bp, $bp_unfiltered_uri;

    // If user is logged in and
    if (is_user_logged_in() &&
    (
    // The current user role is banned
    current_user_can('banned')
    )

    ) {
    // Display the error message
    wp_die('You are banned.');
    }
    }

    add_action( 'wp', 'ban_user', 3 );

Viewing 11 replies - 1 through 11 (of 11 total)