Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum Replies Created

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of kristarella
    kristarella
    Participant

    @kristarella

    I’m having this same problem; I don’t know how it started, but threads are getting assigned IDs for deleted threads where the recipients are still in the database (same problem that was found in this trac entry http://buddypress.trac.wordpress.org/ticket/3971)

    I don’t really want to hack the core to fix it, I’d rather just do a SQL query to delete any recipients for threads that don’t exist. Are there any caveats in doing this?

    Ooh, I just discovered that all the old messages don’t have a thread assigned, but they should! This happened during an upgrade from a much older version… I wasn’t involved in that process, so I don’t know quite what happened. I think I can reassign the messages their thread number by looping through the thread message_ids… Is it possible to do that with a SQL query or do I have to use PHP to get the IDs out of the array?

    This must be why the new messages started assigning low value thread numbers. Does the new thread take it’s ID from the thread table or the messages table?

    Avatar of kristarella
    kristarella
    Participant

    @kristarella

    Yeah, I found that the search box on this site is broken too. Also the sidebar login widget redirects you to the home page instead of the page you were on, which is super annoying.

    Anyway, I’m pretty sure you can use Google to search this site. use “your search term site:buddypress.org”

    Avatar of kristarella
    kristarella
    Participant

    @kristarella

    I found my previous email to my client. It turns out that I did do the deactivating plugins thing over a month ago and it was the Wishlist Member plugin causing the problem.

    I think the code for that plugin is encrypted, so there’s probably no other way to fix it than get their support :(

    Sorry to waste your time on this! But at least this thread might help others if they have the same issue.

    Avatar of kristarella
    kristarella
    Participant

    @kristarella

    Does anyone else see my forum posts as being by “Deleted User”? That is weird!

    Avatar of kristarella
    kristarella
    Participant

    @kristarella

    The site is currently up to date, but yes, it’s been around for quite a while.

    Now that you mention it, I seem to remember thinking it was Wishlist Member (part of the network has paid memberships) that was breaking the delete feature… I’m going to have to check my old emails on the topic and see.

    Thanks for your reply.

    Avatar of kristarella
    kristarella
    Participant

    @kristarella

    I’m moving this discussion to the original DIYthemes forum thread for this child theme in order to keep all the bug reports and updates in one place. However, if there are folks on the BuddyPress forum who’d like to help with development of the Thesis BuddyPress child theme and would rather discuss it here, let me know and we can… heaven knows I need help to keep it going (because of time constraints and because I don’t use BuddyPress on any sites except the test site for this theme).

Viewing 6 replies - 1 through 6 (of 6 total)