Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum Replies Created

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of mt78
    mt78
    Participant

    @mt78

    Hi @djpaul,

    Does uses 1.7-beta1 bp-custom.php for slug translation?

    - My bp-custom.php working correctly in 1.6.4 BP but not working correctly in 1.7-beta1.

    These slugs are translated just for user profile, not group profile. It is OK?

    define ( ‘BP_MEMBERS_SLUG’, ‘clenove’ );

    define ( ‘BP_FORUMS_SLUG’, ‘klubovna’ );

    Thanks for idea, help.

    Avatar of mt78
    mt78
    Participant

    @mt78

    thank you for your answer, I noticed too late that the hint for bbpress is in the file index.php in wp-content/plugins/bbpress/languages/ folder:

    /**

    * Do not put custom translations here. They will be deleted on bbPress updates.

    * Keep custom bbPress translations in /wp-content/languages/bbpress/

    */

    Avatar of mt78
    mt78
    Participant

    @mt78

    Hi @Chouf1

    Could You please provide me full information how to completely translate BuddyPress 1.7 to my czech language? It is the same guide as for 1.6.4 version? I’m using  BP 1.7-beta1 and Group forum with bbPress plugin 2.2.4, no Group Forums component.

    Many Thanks, Milan

    Avatar of mt78
    mt78
    Participant

    @mt78

    @HorrorUK

    How did you do the database cleanup? You used phpAdmin or another tool? And what table? Thanks a lot!

    Avatar of mt78
    mt78
    Participant

    @mt78

    OK, I’m sure that BuddyPress has a big issue! When you have a group and allowed the group forum, so everything runs well, until the group forums to disable and then enable it.

    Appears this error (see below) and group forum topic “falls” into the sitewide forum as private. When clicked on it, takes you back to a group forum topic with the same error!! BuddyPress is mad and my project is stopped and I’m screwed. I am sorry, I have a lot of work the last few days, and all work is useless.

     

    Warning: substr() expects parameter 1 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 776 Warning: strpos() expects parameter 1 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 783 Warning: explode() expects parameter 2 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789 Warning: Invalid argument supplied for foreach() in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789 Warning: substr() expects parameter 1 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 776 Warning: strpos() expects parameter 1 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 783 Warning: explode() expects parameter 2 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789 Warning: Invalid argument supplied for foreach() in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789

    Avatar of mt78
    mt78
    Participant

    @mt78

    I made a several installations and tests and I am convinced it is the fault of BuddyPress! Please read:

    1. First, I created as admin new Group1 and created a new topic.
    2. Then I created a new User.
    3. I logged in to BuddyPress as Admin and I invite the User to friendship.
    4. I logged in as User and received friendship.
    5. I logged in as Admin and I invited the User to the Group1 and as User accepted the invitation.
    6. Admin created three different group forum topic in the Group1.
    7. As a User I saw them all, everything is great!
    8. Then I created as User a new group Group2.
    9. I created new group forum Topic. – And now beware! -
    10. I logged in as Admin and I saw a group forum on all topics. Three topics of my Group1, and one topic of the second Group2, which was created by the User and before I became a member. Everything is great!
    11. But then I logged in as User and in the group forum have not seen any topic!!! Wat is wrong? Bad day? No, may be BuddyPress fault!
    12. So I signed up as Admin, and now I’ve seen topics only my Group1!
    13. Then I went into the WordPress administration and what I see: In bbPress Forum administration (sidewide forums) is my Group1 that I created as Admin! This is absolutely crazy and a big problem!!!
    14. Then I did again test of disabling group forums of Group1 in group adminitrsation.
    15. Then I enabled the group forums and clicked on the forums link as I described above. I got exactly the same error as described above and haven’t nothing functional group forum topics.

    It makes me unhappy because I do not know how to properly install BuddyPress Group Forums and SiteWide Forums. And I do not know if the latest version of the components are compatible together.

    There are many guides to install everything to be smooth, but the instructions are different than BuddyPress documentation or Salutation template. For example http://www.youtube.com/watch?v=-0jSsra_n0c or http://youtu.be/M8mh3f6Vzbo

     

    Avatar of mt78
    mt78
    Participant

    @mt78

    Hi there,

    I have partialy the same problem. I have installed BuddyPress group forums with site wide forum. When I doing this steps:

    1. Go to any Group -> Group Admin -> Forum – and turn off – Group forums.2. Go to any Group -> Group Admin -> Forum – and turn on – Group forums.
    3. Got to Group -> Forums and what I get? I have got error!

    Error like this:
    Warning: substr() expects parameter 1 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 776 Warning: strpos() expects parameter 1 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 783 Warning: explode() expects parameter 2 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789 Warning: Invalid argument supplied for foreach() in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789 Warning: substr() expects parameter 1 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 776 Warning: strpos() expects parameter 1 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 783 Warning: explode() expects parameter 2 to be string, array given in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789 Warning: Invalid argument supplied for foreach() in /data/www/www_cyklodenik_cz/cyklodenik_cz/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789

    Info: WP3.5 , BP 1.6.3 , http://www.cyklodenik.cz

    Could you please take a look on it? It will happen to you?

    Thanks a lot.

Viewing 7 replies - 1 through 7 (of 7 total)