Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum Replies Created

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of pantone
    pantone
    Participant

    @pantone

    @djpaul Thank you for the information, Paul!

    Some follow up questions I have:

    1. How do I go about adding my own custom email template?

    2. Instead of adding my own custom email template, would it be possible to simply edit the “simplicity.php” file? I was looking at the file and noticed there is a style tag.

    Avatar of pantone
    pantone
    Participant

    @pantone

    To give an update:

    When I uncheck the option in the Components tab, “Allow your users to modify their account and notification settings directly from within their profiles,” the account settings page “domain.com/members/user” returns a 404 error page. Therefore, no users at all are able to have access to the Account Settings page. Solves the issue, but not really the most ideal solution.

    I’d prefer for users to be able to have access to their own Account Settings page, therefore I’d like to keep this option on.

    How is everyone else setting up their Account Settings page? and is anyone else running into the same dilemma?

    Avatar of pantone
    pantone
    Participant

    @pantone

    I have not yet launched my buddypress site, but this is definitely one of my concerns.

    If I required new users to verify their account with an e-mail activation link, would this help prevent spammers?

    Avatar of pantone
    pantone
    Participant

    @pantone

    @r-a-y, thank you for your help! By removing that define line from functions, account settings profile pages are now linked to: “domain.com/members/username”.

    Thank you, really appreciate your help.

    Another inquiry while we’re on the subject — I currently have Extended Profiles disabled, but I have Account Settings enabled. I’ve been testing different WordPress roles on my site and discovered that if a subscriber types in their browser: “domain.com/members/anothersubscriber” (where “anothersubscriber” = another member on the site that is also a subscriber), they receive an error (404) page. Obviously this happens because non-admins are not allowed to have this type of access. However, instead of throwing a 404 page, how can I have their (note: “their” meaning non-admins. in my case, subscribers) request redirect to the homepage or to their own profile page?

    Thank you!

    Avatar of pantone
    pantone
    Participant

    @pantone

    Update: so I’ve also added the code in functions.php:
    `define ( ‘BP_MEMBERS_SLUG’, ‘members’ );`

    I then updated this on header.php:
    `<a href="”>Profile`

    but all it returns is:
    “domain.com/username/members”.

    How do I change the function so it goes to: “domain.com/members/username”.

    Avatar of pantone
    pantone
    Participant

    @pantone

    I have not yet launched my BP site, but I too am concerned about this happening. If I use things like CAPTCHA on the registration page or http://wordpress.org/extend/plugins/wangguard/, will it be sufficient enough to prevent spammers?

Viewing 6 replies - 1 through 6 (of 6 total)