Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum Replies Created

Viewing 25 replies - 1 through 25 (of 39 total)
  • Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @mercime thank you for the suggestion. I will check it out.

    As long as it doesn’t delete all users (i.e. actual members), it should work.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @stwc

    Thank you for the update.

    I will soon install and test.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    Fix the following error:

    Invalid Activation Key

    Or

    at least some kind of workaround it

    in the admin section where admin can manually activate the user and send the email that user account has been activated.

    Thank you.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @justsayno1

    Any progress in finding solution to this issue?

    Thanks.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    I do have the google captcha implemented on the registration form so that will help at least to make sure it is humans registering.

    Thank you.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @espellcaste I agree that we should not disable it.

    But since it is holding us moving ahead since people can’t use site, so I think at least an option to disable sending the activation email (i.e. bypassing activation) will be good while people are trying to resolve this issue.

    Also it will help let people use the site. Currently people just give up after seeing the “Invalid Activation Key” message and don’t return back to the site.

    Thank for your suggestions. Really appreciated.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @johnjamesjacoby

    Thank you for taking time to answer my question. I know you are very busy with steering ahead BP 2.0.

    Q: Can we have the option to ‘disable’ sending activation email in BP 2.0 ?

    It will be so helpful to just disable sending activation email if the “Invalid Activation Key” problem still persists.

    Thank you again.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    Any suggestions please?

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    Thank you for your response @barney92

    Now I am finding that:

    * Sometimes the user is able to login using id/pw selected during account registration even if the activation message (after clicking the link in the email) is : Invalid Activation Key

    AND

    ** Other-times the message is still “Invalid Activation Key” and the user is NOT able to login using username/pw created during account registration.

    What a mess! It is now 2 weeks and can’t figure out what is going on.

    Really need some help here please.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    Here is now another phenomenon happening:

    1. New user clicks on the account activation email link
    2. The activation page displays error: “Invalid Activation Key”
    3. User can still login using the username and password selected during account registration

    Q: So what is going on here? Does it mean that the account activation email was never needed in the first place?
    Or
    Does it mean that somehow the account is activated even though the the page displays the error “Invalid Activation Key”?

    So how do I fix this issue? Is it possible to disable the activation email?
    Is it possible to chnage the “Invalid Activation Key” message to something like the following:
    —————————————————————————————-
    Now you can login using the username and password you selected during account creation.
    —————————————————————————————-

    Thank you!

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    Please advise about the following:

    Q1: How do I access the database that stores the account “activation key”?
    Q2: How do I verify or search for a particular account “activation key” in the database?

    Can I do the above in the account zip file that I downloaded from the server?

    Thank you very much.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    Please advise about the following:

    Q1: How do I access the database that stores the account “activation key”?
    Q2: How do I verify if search for a particular account “activation key” in the database?

    Can I do the above in the account zip file that I downloaded from the server?

    Thank you very much.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @mycal2

    It is an unfortunate situation.
    I have rest of the site setup but “Invalid Activation Key” has made me put everything on hold.

    It is now 2nd week that I am struggling with this issue with no end in site.
    What is more surprising is that this is an old known issue and there is no solution for it.

    I appreciate all the help from @henrywright so far.

    I am very desperate to find a solution to this so I can open the registration to the site.

    Btw, how do I access the key in the database (like your did ** DB Token = 42399c51355ac2303bfbfbd77e2b471f)?
    Can you plese give me some simple instructions?

    Thank you.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    I will think more about going that route, because I still like account activation via email link.
    I had bad experience with spammers before.

    Thank you.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    Yes, this is what it says:

    - Auto activate user account instantly on sign up
    - Stop The activation mail sent to user(there is no more activation mail required, as the accounts are automatically activated)
    - After activating the user account, This plugin logs them in automatically and redirects the user to their profile.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @henrywright
    I am not sure if I was able to do the above steps correctly but I tried my best.

    Now, I am not sure what else to do or how to do it?

    I am ready to share my admin access to the site/hosting account if you can take a look.
    Otherwise, some easy instructions what to do will be welcome.

    Also would it be a good idea to just bypass the account verification/validation (since I already have the google recaptcha on the signup form) using a plugin like this:

    http://buddydev.com/plugins/bp-auto-activate-auto-login/

    Thank you very much for all the help you provided so far.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @henrywright

    ok, I just followed the steps 1 and 2 above and saved the page.php

    But could not see the key appearing after “h1″ heading on page.php

    Thank you for your time and help.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @henrywright

    I am not a programmer/coder by any means and not sure how to do what you have suggested above.
    I do see page.php if I go to the theme editor.

    Q1: Where do I add the code? At the bottom i.e. end of the page.php file?
    Q2: Where do I get the user ID of the member to replace in the $user_id in page.php?
    Q3: Now how do I confirm this “Then make sure what appears on screen is the exact same key as the key in the email link.”? Where will this key appear on screen (I mean which page etc)?

    Thank you.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @henrywright

    I tried both your suggestions:

    1. Yes, I still get the “Invalid Activation Key” error if I copy and paste the link url directly in the browser.

    2. Ok, de-activated all plugins except buddypress and clicked the link (also pasted directly to browser) and still same error: Invalid Activation Key

    Thank you.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    Updates:
    1. I just found out that even though clicking the registration email link displays the message “Invalid Activation Key”, I was able to reset the ‘new password’ to the ‘same original’ password using “forgot password” link and login using the new password.

    2. Then I created another test user and had exact same error message upon clicking the registration email link: Invalid Activation Key
    I ignored this “Invalid Activation Key” error message and this time I was able to login using username/password.

    It is very confusing and new users will just give up when they will get the error: Invalid Activation Key

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    I am the admin, but I don’t know how to check that.

    I also just chatted with my hosting company and they told me all the databases/tables appear fine and could not help me. They told me to try here at buddypress forums :)

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @joelworsham

    I have the same issue.

    Did you find the solution to this issue?

    Please advise.

    Thanks.

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    @djpaul

    Thanks for the response.

    I have tried everything I can think of, including testing with three different new accounts on different days.

    I keep getting the same error message: Invalid Activation Key

    Q: Can it be possible that BuddyPress (in our case) never stores the code in the database that it send in the registration email link? Perhaps that’s where the mis-match/invalid message is coming from?

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

    I haven’t received any help in almost a week after posting, so I will be calling on some of the buddypress developers here for help:

    @boonebgorges @modemlooper @jjj @mercime @djpaul

    I have posted the activation link above.

    Please let me know what can I do to solve this.

    Thank you!

    Avatar of simple-man
    simple-man
    Participant

    @simple-man

Viewing 25 replies - 1 through 25 (of 39 total)