Skip to:
Content
Pages
Categories
Search
Top
Bottom

500 Error when Activating

  • Avatar of benweiner
    benweiner
    Participant

    @benweiner

    I’ve Installed WP MU, and I’ve got Buddypress in the correct directory, but when I click “Activate” I get an “Internal Server Error” or HTML Error 500.

    Please Help!

    ben.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Hey Ben.

    Who is your web host? Is it 1and1?

    Avatar of benweiner
    benweiner
    Participant

    @benweiner

    Yes, it’s 1and1.

    *hangs head*

    ben.

    (Edited for Grammar)

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    What you’re experiencing is either a PHP version issue, or an out of memory issue. Happens a lot with 1and1 hosting packages.

    Search the forums (or Google) and you should find a solution somewhere, although it might be almost a year or so old at this point…

    Avatar of chrisk2020
    chrisk2020
    Participant

    @chrisk2020

    Hi,

    I’m getting the same 500 error on activation of buddypress plugin. I’m not hosted on 1and1! I’ve checked file permissions as that was the suggestion of my host.

    I’m on WPMU 2.8.5.2 and trying BP 1.1.2 I’ve been into php.ini and allocated 64mb memory as per other instructions on the forums.

    my error log shows:

    php-script: line 8: 13003 Segmentation fault

    Premature end of script headers: php-script,

    deleting the buddypress folder means that th MU site works again.

    I’m stumped as I have installed previous versions of MU and BP on this domain/ server without problems. (it’s my development server) Any other suggestions? my host couldn’t think of anything beyond the permissions…

    Avatar of musiqcentral
    Twittrblog
    Participant

    @musiqcentral

    i am thinking the htaccess didnt write correctly…

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    not like this

    RewriteEngine On
    RewriteBase BASE/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Avatar of chrisk2020
    chrisk2020
    Participant

    @chrisk2020

    Thanks,

    I’ve tried to change the .htaccess to your suggestion, but I’m still getting the same error :(

    Avatar of chrisk2020
    chrisk2020
    Participant

    @chrisk2020

    Hi,

    still no joy.

    The error log shows:

    [Fri Nov 06 10:31:16 2009] [error] php-script: line 8: 21868 Segmentation fault /usr/bin/php-cgi

    [Fri Nov 06 10:31:16 2009] [error] Premature end of script headers: php-script

    The RewriteBase is spelled correctly in .htaccess

    I have an older version of MU and Buddypress working on a different domain on the same server and I think they are configured the same. But I don’t know enough about server config to spot what is causing this error. I’m going to try my host again…

    Avatar of chrisk2020
    chrisk2020
    Participant

    @chrisk2020

    *update*

    I discovered that clearing the cookies means that the 500 error goes way on the front-end of the site – however when I try to log in to /wp-admin the 500 error comes back and then affects the whole of the site. Clear cookies again – front end works.

    Please, any help much appreciated. I can’t figure out why the cookies might cause a server error?

    Avatar of chrisk2020
    chrisk2020
    Participant

    @chrisk2020

    Sorry, still trying to figure this out:

    Don’t know if I’m barking up the wrong tree with the cookies, but I’ve noticed something:

    Without buddypress activated on (successful) log in to the admin I get 6 cookies:

    wp-settings-time-1 (domain = mydomain)

    wp-settings (domain = mydomain)

    wordpress_logged_in_ (domain = .mydomain) NOTE THE DOT

    wordpress_ (domain = .mydomain) NOTE THE DOT

    wordpress_ (domain = .mydomain) NOTE THE DOT

    wordpress_test_cookie (domain = .mydomain) NOTE THE DOT

    Activate buddypress plugin = 500 error

    Clear cookies wpmu site comes back

    Log in to wp-admin and get 500 error, but now the cookies are only:

    wordpress_logged_in_ (domain = .mydomain) NOTE THE DOT

    wordpress_ (domain = .mydomain) NOTE THE DOT

    wordpress_ (domain = .mydomain) NOTE THE DOT

    wordpress_test_cookie (domain = .mydomain) NOTE THE DOT

    the two settings cookies without the dot before the domain are missing.

    Could this be causing/ or symptomatic of some kind of path problem?

    Avatar of chrisk2020
    chrisk2020
    Participant

    @chrisk2020

    OK – I checked my database against a functioning BP installation and there were loads of missing tables. All the ones with wp_bp prefix. I copied the structure from the functioning database and it seems to be working now.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Avatar of chrisk2020
    chrisk2020
    Participant

    @chrisk2020

    @John James Jacoby

    Thanks for the link. As I said in my case one and one are not my webhost. My server is running PHP 5 and php memory had been boosted up to a limit of 64. Previous versions of wp and buddypress had been installed on this domain without incident.

    [Fri Nov 06 10:31:16 2009] [error] php-script: line 8: 21868 Segmentation fault /usr/bin/php-cgi
    [Fri Nov 06 10:31:16 2009] [error] Premature end of script headers: php-script

    This is a server issue.

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.