Skip to:
Content
Pages
Categories
Search
Top
Bottom

A few problems found in V0.1.2.3

  • Avatar of Sandra l***
    Sandra l***
    Participant

    @sandra1010

    Hi there.

    I have been testing Evenpress’ latest release and found a couple of problems.

    To start with, please note that I am running your plugin in the following environment:
    WP 3.0.1 (with multi-site setup)
    BP 1.2.6
    EP 0.1.2.3
    Site: localhost
    User: admin

    I have found the following problems
    - Event categories and tags not available in the front end event editing form (I love the front end editing form; I am trying hard to avoid having users go in the dashboard to post stuff)
    - In the front-end editing function: Featured image upload works but you do not get notified that the upload has registered until after you hit the “update” button and display the updated event (i.e. after featured image upload and before event update, the Thumbnail area still displays “set featured image”)
    - Front end event editing works well (except for the 2 problems mentioned above) whereas event editing from my Buddypress profile nav sends me to the site main page. I am not sure if the intention was to send the user to the dashboard, I – for one – would prefer if it triggered the front-end editing.
    - Standard front-end editing form only seems to display properly with themes whose content area is 900+ pixel wide. I will probably have to remove the sidebar from my theme (content area is 640px).

    Oh! And I forgot to say how much I love this plugin. Thank you! Cheers -

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of kunalb
    kunalb
    Participant

    @kunalb

    1. I haven’t added support to BPCP for categories or tags yet— so even displaying a particular Event Category or Tag doesn’t work out of the box at the moment.

    2. Will have a look at that— http://code.google.com/p/buddypress-custom-posts/issues/detail?id=15

    3. So that is not intended behaviour, and I can’t replicate it—could anything be interfering there?

    4. Yeah, the front-end editing form needs a lot of improvement; I just made a basic one for the initial version that had just enough functionality to add widgets, etc. Have to make it much more configurable and more easily themable.

    I am having the same problem #3, clicking on Events in the profile nav sends me to the site’s main page.

    Avatar of kunalb
    kunalb
    Participant

    @kunalb

    For that, you might try copying members/single/home.php from your parent theme to the child theme. I seem to have made an error in theme file resolution that is causing this problem.

    Thank you, that worked.

    Avatar of Jean-Marc
    Jean-Marc
    Participant

    @chefouvi

    Hi kunalb,
    I installed Buddypress Custom Posts and I have the latest version of Buddypress. Eventpress installs by upon activation i get “The plugin does not have a valid header.” How do I fix this?

    Thanks,

    Avatar of kunalb
    kunalb
    Participant

    @kunalb

    This is the first time I’ve heard of this error— are there any error details apart from this? Could you try reinstalling the plugin just in case some files didn’t load properly?

    Avatar of Jean-Marc
    Jean-Marc
    Participant

    @chefouvi

    Dear Kunalb,
    I tried the manual installation and the WordPress auto install both came up with the same error. This is indeed weird. There are no other error details. Thanks a lot for taking the time to look into this.

    Avatar of sciencebox.net
    sciencebox.net
    Member

    @scienceboxoxnet

    Hello,

    I have exactly the same problem.

    Avatar of kunalb
    kunalb
    Participant

    @kunalb

    By any chance is your plugin folder in a non standard location?

    Avatar of maddiezahatter
    maddiezahatter
    Participant

    @maddiezahatter

    Hi, I also had the “does not have a valid header” problem when installing BuddyPress and then EventPress on a brand new WordPress installation – so new I had not selected a BP-compatible theme yet. I did this, then tried to install EventPress again and it worked – that’s the only thing I did.

    Avatar of kunalb
    kunalb
    Participant

    @kunalb

    I might be calling some bp-default theme files somehow; and that is what is causing this error. Atleast I have a starting point—thanks!

    Also have this problem with no valid header! I am using a custom WP child theme, but everything else works fine.

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.