Skip to:
Content
Pages
Categories
Search
Top
Bottom

Achievements 2.2

  • Will include a fix for the error when unlocking an achievement when not using any of achievements’ widgets, and also includes an up-to-date .pot file which will hopefully fix translation problems.

    Known bugs:
    1) The achievement event “the user logs in to the site” is bugged and will trigger for every log in. There is no known workaround. I suggest you do not use this event on your site until it is fixed in a future version of Achievements*.

    * This may be as far away as Achievements 3.0, which is probably a couple of months away.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of robpachasa
    robpachasa
    Member

    @robpachasa

    Thank you! Testing now.

    The bug sucks, but hey man; I shouldn’t complain. Thanks for the fix!

    Hi, Can you please tell me where I would remove the achievement from the user in the database, as I am not the best with coding etc! Also, would doing this also remove it from their ‘score’ in the leaderboard.

    Thanks,
    Ben.

    Avatar of neosin
    neosin
    Participant

    @neosin

    Cubepoints has a point award per login which works fine.
    You could copy the code from that for the per login bug.

    Also, it would be great to integrate this with cubepoints as an addon.

    Avatar of Susan Adams
    Susan Adams
    Member

    @artfirelink

    Hi, Paul! There is a bug “echo” of sorts on the user profile page. You can see it here: http://artfirelink.com/members/Susan_Adams/achievements/
    The menu is appearing twice. There are a couple of other errors that may hint at whats to blame. No points are awarded when the achievement is given from an event.

    I have systematically deactivated all the plugins with just achievements and buddypress running..and a couple of others, and still shows up double menu.

    Looking for a fix or insight. Thanks!

    You will probably need to adjust the templates in Achievements so that it works with your theme: that’s probably why you’re getting two menus. I am not aware of any bug with the points; let’s get the templates correct first :)

    Avatar of Susan Adams
    Susan Adams
    Member

    @artfirelink

    OK..Any hints how to adjust templates for that would be greatly appreciated. Not sure what I’m looking for. Give me a smidge of hint?
    The Custom Community Theme is the only one I can get all the plugins I use to work together, have tons of errors on all the others I have tried. Thanks, Paul

    Avatar of Susan Adams
    Susan Adams
    Member

    @artfirelink

    Nevermind..I figured it out..in case anyone else has the same issue with Custom Community, you have to go into your achievements.php, just remove or comment out the contect between the menu item tag just underneath this line: div id=”item-nav”

    Avatar of chibichiii
    chibichiii
    Participant

    @chibichiii

    I had Custom Community for a while as well, but than I switched to Elbee Elgee, it just plays nicer with buddypress and a lot of plugins. Quite a pitty though cause Custom Community is a good theme. Thnx for the tip though Susan!

Viewing 8 replies - 1 through 8 (of 8 total)

The forum ‘Achievements’ is closed to new topics and replies.