Skip to:
Content
Pages
Categories
Search
Top
Bottom

Activation email – second time round causes error

  • Avatar of applegateian
    applegateian
    Participant

    @applegateian

    Hi there

    The activation email for a user is working fine. Click on the unique url and the account is activated. No problem.

    However, if the user clicks on that same link in their email again (a scenario I think that can occur often enough for this to be an issue) they are taken to /activate but this time are shown a form field with the request to enter an activation key:

    The user doesn’t know their activation key (it’s not in the email) and besides they have already activated, so this is very confusing.

    Can I force that url if clicked again to go to the home page, or at least not show the activation key field on that page?

    Thanks,

    Ian

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of applegateian
    applegateian
    Participant

    @applegateian

    For now I have changed the copy on the activate.php page in my theme to make sense. It still works first time a user visits, but if they do it again, they get a page with some copy that helps them. The key field can never be used anyway.

    Is there a smarter fix?

    Avatar of Henry
    Henry
    Participant

    @henrywright-1

    Hi @applegateian

    The activation form is there mainly to give website admininstrators the ability to activate users accounts manually. So, removing the form won’t cause any problems.

    One issue with the text you’ve added to the page – keep in mind any logged out website visitor viewing the activation page will see that text – so “your account has already been activated” won’t always be true.

    Avatar of applegateian
    applegateian
    Participant

    @applegateian

    Yes fair point @henrywright-1 – will add some copy for those users too :)

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.