Skip to:
Content
Pages
Categories
Search
Top
Bottom

Activity Stream not showing up on user's profile.

  • Avatar of mreeder
    mreeder
    Participant

    @mreeder

    I’m building a site using the Frisco for Buddypress theme and I recently noticed a problem.

    When a normal user is logged in, their activity stream on their own page is blank to them, but their friends and the administrator can see it fine. The user can still post an update fine, it just doesn’t show up on the page. Basically the only thing they see is the “Load More” button and when clicked it just disappears.

    This same problem happens for every other user except for the administrators. The admins can see their stream just fine.

    I haven’t changed the activity-loop.php file in any way and I also restored the activity.php file just in case, but the problem is still there.

    Any suggestions?

    The URL I am talking about is http://site.com/members/user/activity

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of mreeder
    mreeder
    Participant

    @mreeder

    I need to add that the logged in user’s activity doesn’t show up at the following URL either: http://site.com/activity

    Avatar of mreeder
    mreeder
    Participant

    @mreeder

    I solved this problem.

    The plugin “BuddyPress Friends Only Activity Stream” claimed to only show activity from your friends and the admins only. I guess since you can’t be friends with yourself, it hides your activity as well. :/

    I may look into the plugin’s files later to see if there’s a workaround for this, but as of right now it’s staying deactivated.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.