Skip to:
Content
Pages
Categories
Search
Top
Bottom

Activity Stream – Read More/View link missing

  • Avatar of peeld
    peeld
    Participant

    @peeld

    Before upgrading to BP 1.5, I could click a link in the activity stream that said “view” and be taken directly to the full text of the post, the excerpt of which was shown in the activity stream. I depend on this heavily to keep up with my classroom. Now in 1.5, the ‘view’ link is missing in each activity stream post, and the [...] at the end of each excerpt doesn’t link to anything. I don’t think it’s a theme issue; the links are missing even in the default BP theme.

    Please advise.

    1. Which version of WordPress are you running?
    Latest
    2. Did you install WordPress as a directory or subdomain install?
    Subdomain
    3. If a directory install, is it in root or in a subdirectory?
    n/a
    4. Did you upgrade from a previous version of WordPress? If so, from which version?
    No, same version as before, BP was only upgrade.

    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.
    Yes
    6. Which version of BP are you running?
    1.5.1

    7. Did you upgraded from a previous version of BP? If so, from which version?
    1.2 something

    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?
    Yes, a lot, but none of them changed.

    9. Are you using the standard BuddyPress themes or customized themes?
    Themekraft CC Pro

    10. Have you modified the core files in any way?
    Not yet

    11. Do you have any custom functions in bp-custom.php?
    Yes, a slug change function, and a function to remove links in profiles.

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?
    Whatever came with BP 1.5

    13. Please provide a list of any errors in your server’s log files.
    n/a

    14. Which company provides your hosting?
    Bluehost

    15. Is your server running Windows, or if Linux; Apache, nginx or something else?
    Apache, I think.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of JackVD
    JackVD
    Participant

    @jackvd

    I have got similars problems. Since I updated from 1.5 to 1.5.1 i have 2 problems: 1) when creating a group its not asked to upload an group avatar, 2) its not possible to delete or edit buddypress updates in my activity stream.

    @peeld We moved the permalink to the timestamp; click it.

    Avatar of peeld
    peeld
    Participant

    @peeld

    OK Thanks.

    Avatar of peeld
    peeld
    Participant

    @peeld

    OK, reopening this – I edited the file so that the timestamp is once again followed by the text VIEW – I really did like that, who would know to click the time stamp?

    BUT, the [...] at the end of activity excerpts is not working as a permalink any more? Would like that to be a permalink still? On the main activity feed, there is a [Read More] at the end of each excerpt, and filtering for my friends still has the [Read More], but filtering activity for my groups yields just [...]at the end of each activity post. How can I get that to say [Read More] like all the other activity feeds?

    Thanks.

    My view link isn’t missing, but when you click it, it goes to a page with the user’s avatar showing and nothing else. It doesn’t actually take you to the activity, and hasn’t ever since the update.

    Avatar of peeld
    peeld
    Participant

    @peeld

    I’d like to request that the VIEW text be put back in – I hacked it for now but of course the first update that comes along and I’ll have to try and remember where I hacked it :)

    Avatar of peeld
    peeld
    Participant

    @peeld

    PLEASE HELP ME WITH THESE ACTIVITY STREAM ISSUES…..I am pulling my hair out, this is such a huge fail in BP 1.5 functionality, I am so frustrated :(

    On http://mysite.com/activity, as well as http://mysite.com/groups/anygroup home page, the [READ MORE] link at the bottom of activity replies to posts expands to reveal the full text of the response ONLY if the user has posted an update – if they are posting in reply to a forum topic, then on the activity feed the end of the excerpt just has [...] and that doesn’t link to anything but SHOULD, as it used to. How to hack/fix?

    On http://mysite.com/gropu/groupname/groupforum/groupforumtopic/topicpage

    the [READ MORE] link at the bottom of activity feed replies to posts doesn’t do ANYthing.
    I have the group forums extras plugin installed in order to show activity replies below forum posts in a threaded view.

    How can I hack/edit to get this functionality back? I am really really frustrated and am getting to the point where I’d PAY to have this fixed….

    Thanks,

    Avatar of bmk0220
    bmk0220
    Participant

    @bmk0220

    I agree, should have left it like it was. A View / Read More link in each activity update. Also the [...] should say [more] and be active.

Viewing 8 replies - 1 through 8 (of 8 total)

The topic ‘Activity Stream – Read More/View link missing’ is closed to new replies.