Skip to:
Content
Pages
Categories
Search
Top
Bottom

Add Friend – not adding

  • Avatar of Cdutoit
    cdutoit
    Participant

    @cdutoit

    Hello,

    Just installed BP RC1 on WPMU 2.7.

    Seems to work great but am experiencing a problem with the “Friends” module.

    When I log in I go to “My Account”->”Friends”. It shows a list of people I could add as friends. Next to each person is the “add friend” button. When I click it, it the icon changes to the “working” icon, but it never stops. So graphically, it looks like it is doing something but never stops, and the friend doesn’t get added (nor does the recipient get a Friend request).

    Any ideas?

    I’d provide logs – just not sure what you would need – I’m running it on a cpanel server.

    Thanks in advance,

Viewing 25 replies - 26 through 50 (of 98 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    What host do the three of you have? We’ve seen some bizarre problems with certain hosts. Any error messages in the apache or php logs? Chris says none.

    Looking at your phpinfo() Chris…

    (Thinking out loud)

    Your settings that differ

    memory_limit – 64m

    register_globals – ON

    How much memory do the three of you have available to you to execute apache/wpmu/bp on your servers?

    Avatar of Cdutoit
    cdutoit
    Participant

    @cdutoit

    I’m with hostgator if that is anything in common with the others. Though it is a reseller account and I’ve run things such as WP, WPMU, Drupal, Joomla etc so its probably unlikely its the host, but hey…

    Is there any debug code I can add to a module that will help troubleshoot this?

    Thanks

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    I’m not really sure where to put it yet Chris. I’ve got my girlfriend coming over for dinner so it’ll have to be later this eve.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    cdutoit: Do you have the firefox extension: firebug?

    If not, install it, activate it for your site, click on the add friend link. Open up firebug and under the “Console” tab, click on the POST request. It should tell you what was returned from the server.

    Please post that here.

    Avatar of Adam W. Warner
    Adam W. Warner
    Participant

    @awarner20

    Hey Burt…hope you don’t mind I’m calling you Burt…

    First, the relevant answers:

    Host: http://synhosting.com/

    memory_limit – 16m

    register_globals – OFF

    I’ve got some entries from the error log from today, can I email those to you instead of posting here?

    I’m not quite sure how to get the the Apache error log.

    Oh, and are you familiar with Grand Haven? I just moved away from there;)

    Avatar of Adam W. Warner
    Adam W. Warner
    Participant

    @awarner20

    @ Andy,

    This is what I see with Firebug when clicking on “Add As Friend”:

    nonce[1] is undefined

    nonce[1].split(‘&’);

    Avatar of Cdutoit
    cdutoit
    Participant

    @cdutoit

    Andy, I can’t seem to post such a lengthy response in this forum…it wont save my post. I will try upload it somewhere for download (for the response), but here is some info:

    The console shows a red error:

    POST http://jurnl.com/wp-content/mu-plugins/bp-core/bp-core-ajax-handler.php

    http://jurnl.com/wp-content/mu-plugins/bp-core/bp-core-ajax-handler.php

    404 Not Found

    456ms

    Although I got excited, I verified the file is there.

    The Request looks like this:

    _wpnonce

    318ee4a2ca

    action

    addremove_friend

    cookie

    PHPSESSID%3D5085d0cb2f4434771cfa8a20d63358cf%3B%20wordpress_test_cookie%3DWP%2BCookie%2Bcheck

    fid

    1

    The Response I can’t post here so will upload it and let you know.

    Will post soon.

    Thanks

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Chris use this site to post what you want: http://pastie.org

    You can choose language: ‘plain text’ then post the url in the address bar you get after you say ‘paste’

    Avatar of Cdutoit
    cdutoit
    Participant

    @cdutoit

    I put the response here (essentially a full html):

    http://solsticereview.com/response.tmp

    Many thanks all!! Sooooon I may have a ‘friends’ capability too :)

    Avatar of Cdutoit
    cdutoit
    Participant

    @cdutoit

    Cool site (pastie):

    http://pastie.org/393631

    Thanks for the tip!

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    @awarner20 Grand Haven? Ya, right down the street. Used to live in Muskegon now Grand Rapids and next week moving to Williamsburg VA. I get around. :)

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    Andy, I did what you said and as soon as I clicked the checkbox in firebug the button stopped spinning and had a check mark.

    So I am not sure what that means it never gave back any information.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    ok I guess I spoke too soon. Had this in red with 4040 not found after it:

    http://twitterfic.com/wp-content/mu-plugins/bp-core/bp-core-ajax-handler.php

    then the other code:

    Date

    Thu, 19 Feb 2009 04:16:47 GMT

    Server

    Apache

    Cache-Control

    no-store, no-cache, must-revalidate, post-check=0, pre-check=0

    Expires

    Thu, 19 Nov 1981 08:52:00 GMT

    Pragma

    no-cache

    X-Pingback

    http://twitterfic.com/xmlrpc.php

    Last-Modified

    Thu, 19 Feb 2009 04:16:47 GMT

    Keep-Alive

    timeout=15, max=99

    Connection

    Keep-Alive

    Transfer-Encoding

    chunked

    Content-Type

    text/html; charset=UTF-8

    Request Headers

    Host

    twitterfic.com

    User-Agent

    Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

    Accept

    */*

    Accept-Language

    en-us,en;q=0.5

    Accept-Encoding

    gzip,deflate

    Accept-Charset

    ISO-8859-1,utf-8;q=0.7,*;q=0.7

    Keep-Alive

    300

    Connection

    keep-alive

    Content-Type

    application/x-www-form-urlencoded; charset=UTF-8

    X-Requested-With

    XMLHttpRequest

    Referer

    http://twitterfic.com/members

    Content-Length

    888

    Cookie

    wp-settings-time-1=1234978735; wp-settings-1=m0%3Do%26m1%3Dc%26m2%3Dc%26m3%3Dc%26m4%3Dc%26m5%3Do%26m6

    %3Dc%26m7%3Do%26m8%3Dc%26m9%3Dc%26m10%3Dc%26m11%3Dc; wp-settings-time-2=1234896835; __utma=253961357

    .2322033939621672000.1234866299.1235007210.1235014438.11; __utmz=253961357.1234900041.3.2.utmcsr=trueblood

    .twitterfic.com|utmccn=(referral)|utmcmd=referral|utmcct=/groups; wp-settings-2=m0%3Dc%26m1%3Dc; wp-settings-time-5

    =1234989991; __utmb=253961357.60.10.1235014438; PHPSESSID=4bv8ld7abk3iutqqhht3jo9d06; __utmc=253961357

    ; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_=kitchenbitch%7C1235188924%7C7aa68ef091

    4f0885b507970bff70071e

    _wpnonce

    f149be8ca2

    action

    addremove_friend

    cookie

    wp-settings-time-1%3D1234978735%3B%20wp-settings-1%3Dm0%253Do%2526m1%253Dc%2526m2%253Dc%2526m3%253Dc

    %2526m4%253Dc%2526m5%253Do%2526m6%253Dc%2526m7%253Do%2526m8%253Dc%2526m9%253Dc%2526m10%253Dc%2526m11

    %253Dc%3B%20wp-settings-time-2%3D1234896835%3B%20__utma%3D253961357.2322033939621672000.1234866299.1235007210

    .1235014438.11%3B%20__utmz%3D253961357.1234900041.3.2.utmcsr%3Dtrueblood.twitterfic.com%7Cutmccn%3D(referral

    )%7Cutmcmd%3Dreferral%7Cutmcct%3D%2Fgroups%3B%20wp-settings-2%3Dm0%253Dc%2526m1%253Dc%3B%20wp-settings-time-5

    %3D1234989991%3B%20__utmb%3D253961357.60.10.1235014438%3B%20PHPSESSID%3D4bv8ld7abk3iutqqhht3jo9d06%3B

    %20__utmc%3D253961357%3B%20wordpress_test_cookie%3DWP%2BCookie%2Bcheck

    fid

    5

    Avatar of Cdutoit
    cdutoit
    Participant

    @cdutoit

    modemlooper – I guess its good that not only do we both have the same symptom, it looks like we both have the same underlying problem. Hopefully this will help Burt and Andy in their debugging efforts.

    Avatar of Adam W. Warner
    Adam W. Warner
    Participant

    @awarner20

    @ Burt,

    Not trying to derail this thread, but didn’t know how else to get your attention. I signed up for your site and haven’t received an activation email. Just wanted to give you a heads up in case something was awry…

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    That kind of thing happens if you email provider decides that the mail is spam and doesn’t even let you see it. It gets blocked before you get it. Hotmail as email provider does this alot. Look in your ‘spam’ folder.

    Just getting situated here this morning. Gotta go look at this thread again.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Looking at why your sites are generating 404s for the ajax handler code. Shouldn’t happen. Does this file exist and does it have permissions of 755?

    /wp-content/mu-plugins/bp-core/bp-core-ajax-handler.php

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    yes I have the file and gave it 755 per Andy. Is there a way to just turn it off and have these links refresh page. My users can’t even cycle through members lists.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    in the header it says this is this correct?

    <script type=”text/javascript”>var ajaxurl = “http://twitterfic.com/wp-content/mu-plugins/bp-core/bp-core-ajax-handler.php”;</script>

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    twitterific.com? no, not even close to being right. hmm. What’s the url of your site again? Can you point me to your site please?

    Avatar of Cdutoit
    cdutoit
    Participant

    @cdutoit

    My URL is the same but replace twitterfic.com with my site, jurnl.com – so I think the URL construction is ok…its the full qualified path to where the file is. I verified it does exist but cannot understand how it reports a 404.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Cris, ya I see yours in firebug and it’s getting 404. Permissions are 755 on that directory and file?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    modemlooper, can you do me a favor? Change line 29 in the file:

    /mu-plugins/bp-core/bp-core-cssjs.php

    to this:

    '<script type="text/javascript">var ajaxurl = "' . get_blog_option(1, 'siteurl') . '/' . MUPLUGINDIR . '/bp-core/bp-core-ajax-handler.php' . '";</script>';

    That should solve the 404 problem on your site.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    twitterfic.com no i its a fan fic site and i chose the name as a play on twitterific ;)

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    So changed that code and still nothing. Is there a way to just turn off the ajax and have the pages refresh old school?

Viewing 25 replies - 26 through 50 (of 98 total)

The topic ‘Add Friend – not adding’ is closed to new replies.