Skip to:
Content
Pages
Categories
Search
Top
Bottom

Add friends and private messages failing.

  • Avatar of ORyanMcentire
    ORyanMcentire
    Member

    @oryanmcentire

    So i have developed a custom theme which is a child theme of the BP default (although most has been recreated so i’m not inheriting too much from the parent) In my theme it seems that I am unable to add friends, post activity updates or submit private messages. the buttons for messaging and friending don’t even show up on user profiles. (and they are turned on in the settings) I can see the “add friend” link in the member’s directory but clicking it just disables the button. It doesn’t seem to go through. And the private messaging always fails as well.

    I am sure that in creating my theme I may have left something out. And my hunch is it’s something to do with the AJAX process behind those features.

    I was wondering if anyone knew what dependencies were tied to the ajax submission of friend requests, activity updates and or private messaging. Or some sort of documentation for those?

    I realize these may be two separate issues but they seem linked to me.

    These scripts are enqueued in my head:
    `
    /wp-includes/js/comment-reply.js
    googleapis.com/ajax/libs/jquery/1.7.0/jquery.min.js?ver=3.3.1
    /wp-content/plugins/bp-labs/beakers/js/jquery.mentions.js?ver=1.2
    /wp-content/plugins/bp-labs/beakers/js/autosuggest.js?ver=1.0
    /wp-content/themes/punchbowl/_inc/global.js?ver=20111013
    /wp-includes/js/json2.js?ver=2011-02-23
    /wp-content/plugins/bp-live-notification/bpln.js?ver=3.3.1

    var ajaxurl = “…/wp-load.php”;

    `

    And any other info I can give to help just let me know.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of ORyanMcentire
    ORyanMcentire
    Member

    @oryanmcentire

    I am also getting “response is null” errors in firebug when viewing the global activity page from the global.js file
    `
    response is null
    jq(this).html(response.contents);
    `

    Avatar of ORyanMcentire
    ORyanMcentire
    Member

    @oryanmcentire

    I have also Tried disabling the ajax features but still problems… Any help would be awesome.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.