Skip to:
Content
Pages
Categories
Search
Top
Bottom

admin bar links re-direct to homepage

  • Avatar of Damon Cook
    Damon Cook
    Participant

    @damoncook

    1. Which version of WPMU are you running? WPMU 2.8.4

    2. Did you install WPMU as a directory or subdomain install? Directory

    3. If a directory install, is it in root or in a subdirectory? Root

    4. Did you upgraded from a previous version of WPMU? If so, from which version? No

    5. Was WPMU functioning properly before installing/upgrading BuddyPress? Yes

    6. Which version of BuddyPress (BP) are you running? BP 1.1.1

    7. Did you upgraded from a previous version of BP? If so, from which version? Yes, 1.1.0

    8. Do you have any plugins other than BuddyPress installed and activated? Yes

    9. Are you using the standard BuddyPress themes or customized themes? Standard

    10. Have you modified the core files in any way? No

    11. Do you have any custom functions in bp-custom.php? No

    12. If running bbPress, which version? bbPress 1.0.2

    13. Please provide a list of any errors in your server’s log files. Nothing stands out, but is there something I should be looking for?

    I upgraded to 1.1.0 yesterday and followed all directions to the ‘t’. The only issue I’m having is that all of the links in the BP admin bar take me to the homepage. For example, from my homepage if I hover over the BP admin bar’s: “My Account >> Activity” it is pointing to the following URL: http://blogs.empire-edutools.net/members/damon-cook/activity/

    Fine and dandy, but when I click that link it takes me too: http://blogs.empire-edutools.net

    Please advise.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Works for me.

    8. Do you have any plugins other than BuddyPress installed and activated? Yes

    Try disabling all of these as a test.

    Avatar of Damon Cook
    Damon Cook
    Participant

    @damoncook

    Regarding this post: http://buddypress.org/forums/topic/when-logged-in-to-buddypressorg-some-links-do-not-work#post-13743</&gt;. Does WPMU/BP support punctuation in user name, i.e. “damon.cook”?

    Avatar of Damon Cook
    Damon Cook
    Participant

    @damoncook

    @ DJ Paul: I tried that already.

    Avatar of Damon Cook
    Damon Cook
    Participant

    @damoncook

    I’m attempting a clean BP 1.1.1 install and I’ll report back.

    Avatar of Damon Cook
    Damon Cook
    Participant

    @damoncook

    Nope. This has done nothing. Still same problem. I might try deleting all my mu-plugins and plugins and re-installing when I get another moment, but I’m open for suggestions.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Two posts above, you state that you were attempting a clean install but then immediately in the next post say that you, “might try deleting all my mu-plugins and plugins.”

    If you had any plugins installed anywhere, then you are not doing a clean install. For some, such as myself, I only consider a clean install starting from scratch–a totally wiped domain (no files), new DB table, new WPMU install, and then new BuddyPress install.

    Since in your first post in this thread you indicated that you did not upgraded from a previous version of WPMU, then I’m assuming you have no data worth saving. If that is the case, then I suggest starting from scratch and doing a real, clean install. This means deleting all your files and deleting the MySQL DB. Once you have WPMU running again, thoroughly check it out before installing anything else. Once you think it is ready to go, then install BuddyPress and only BuddyPress. Make sure that it is work fine with the default BP themes before doing anything else.

    Once you have BuddyPress working properly, you can then start adding new plugins. But only do so one at a time, fully checking to see if issues arise from activating each new plugin before adding an additional one.

    Avatar of Damon Cook
    Damon Cook
    Participant

    @colorful-tones

    Sorry for the semantic confusion. I meant ‘clean’ as just BP and not all of WPMU, but it sounds like I’ll be doing WPMU now too.

    Avatar of alexzien
    alexzien
    Participant

    @alexzien

    I got a similar problem.

    When I hover My Account > Activity it says http://mydomain.com/members/admin/activity/. But almost always when I click it I end up at http://mydomain.com. the other times I end up at http://mydomain.com/members/admin/activity/ but with this error “Error 404 – Not Found”. I’m new to this and thought that I had done something wrong. But I have tried to uninstall, remove all files, db etc and re-installed. But it’s still the same.

    Avatar of Damon Cook
    Damon Cook
    Participant

    @damoncook

    Ok, I deleted everything except my database. I re-installed WPMU. I uploaded a few WP themes to the themes directory for my users. I checked to make sure all the existing sites were all ok and they were. I uploaded BP on this “clean” install and enabled “site-wide”, and enabled BP-Default theme. Went to the home site and it is still causing the same issue. I have no plugins or mu-plugins installed except for BP. ugh!

    Avatar of Damon Cook
    Damon Cook
    Participant

    @damoncook

    I just did a fresh local install of WPMU and BP and it works fine. ugh! I’m going to get to the bottom of this.

    Avatar of Damon Cook
    Damon Cook
    Participant

    @damoncook

    Ok, one major difference I’m noticing when comparing my local install and my live site it their htaccess and wp-config.php.

    For example, my local wp-config.php reads:

    $base = '/wordpress-mu/';
    define('DOMAIN_CURRENT_SITE', 'localhost.localdomain' );
    define('PATH_CURRENT_SITE', '/wordpress-mu/' );

    while my site wp-config.php reads:

    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'blogs.empire-edutools.net' );
    define('PATH_CURRENT_SITE', '/' );

    Does this make a difference to have the $base set?

    Also line #2 of my local .htaccess reads:

    RewriteBase /wordpress-mu/

    while site .htaccess reads:

    RewriteBase /

    I think this is typical, but just want to verify?

    Avatar of Damon Cook
    Damon Cook
    Participant

    @damoncook

    ok, I figured it out. Most of my users have a period in their username (i.e. firstname.lastname). WPMU/BP does not like. I’m going to convert to hyphen instead. Wow, what a headache ;/

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.