Skip to:
Content
Pages
Categories
Search
Top
Bottom

All links related to groups redirect to home page upon upgrade

  • Avatar of beanfair
    beanfair
    Participant

    @beanfair

    When I upgraded from Buddypress 1.2 RC to BP 1.2, all of the group related links redirect to the home page. This happens no matter which BP 1.2 theme I try.

Viewing 25 replies - 1 through 25 (of 34 total)
  • Avatar of beanfair
    beanfair
    Participant

    @beanfair

    Other links are redirectling as well. For example, http://food-wine-pairing.com/members redirects to http://food-wine-pairing.com but http://food-wine-pairing.com/activity/ works. I have deleted and reinstalled BuddyPress but the problem still persists.

    This link works correctly http://food-wine-pairing.com/groups/ but the links inside groups do not,

    http://food-wine-pairing.com/blogs redirects as well. I am really scratching my head over this. It is not theme dependent. The problem persists across BP compatible themes

    All of the “group related links” where, exactly? What links are you looking at — what URLs do they have?

    Avatar of Kevin Ryman
    Kevin Ryman
    Participant

    @kevinryman

    I am having a similar issue:

    When you hover on “My Account” or “Notifications” and click on any of the links under them it will try to send me to the link but instead it quickly forwards me back to the homepage. This only happens on the “My Account” or “Notifications” links.

    I already try different web browsers: Safari, Firefox, and Chrome but still the same issue… Any tips?

    Avatar of Footballfantalk
    Footballfantalk
    Participant

    @footballfantalk

    I’m having exactly the same problem. Just upgrade to 1.2.

    Just installed (today) a fresh copy of wp 2.9.2 and bp 1.2.

    I’m having the same issue, for example the link http://clanrecruit.net/members//profile/edit/ will redirect me to http://clanrecruit.net any help with this issue?

    In fact almost all the links are not working under ‘my account’ for example http://clanrecruit.net/members//settings/general/ not working.

    Ok, I just copied the same like from http://testbp.org after creating a profile to test bp out. Here is the same link under my account toolbar http://testbp.org/members/melvenac/profile/edit/. If you will notice the is an extra ” / ” in my link that is not there at testbp.org. Could this be the problem?

    The problem is that when you first set up wp and bp you automatically set up an administrators account for wp that is not automatically ported into (used by) bp once you install the bp plugin. This simple solution is to create an account for bp that is not your original wp username and account. Create a test account and you will see everything now works. Unfortunately you cannot use your email address or username from your admin account. If there is a way around this please advise.

    The clue that gave it away was my earlier observation of the double // in the url. A members account name will appear there if all is working properly.

    Avatar of 1drummergirl
    1drummergirl
    Participant

    @1drummergirl

    I just installed BuddyPress today and encountered this. A did a little digging and found it was using the “nicename” for the url. I went in to the users db via phpmyadmin and changed the nicename to ‘admin’ and now it’s working.

    Avatar of rockyteng
    rockyteng
    Participant

    @rockyteng

    i came across the same problems as well and search a lot but could find a solution

    anybody have an idea about that?

    please

    thanks

    Avatar of cupedoll
    cupedoll
    Participant

    @cupedoll

    Could be I got the same issue here. 2.92 WordPress (single user) and latest BuddyPress installed via BuddyPress Template Pack Plugin.

    With nothing disabled in BP general settings, everything enabled in component setup.

    There is no “create group” in the “groups” tab. Only “My Groups” and “Invites”. Clicking the “groups” tab goes to http://www.ultimatecultureclash.com/members/cupedoll/groups/ which seems fine.

    But I want forums. And it seems forums are a property of groups. So I need groups. How to create groups?

    (After much confusion) I enter MANUALLY: http://ultimatecultureclash.com/groups/create/step/group-details/

    This goes to /groups/create/step/group-details/images/images/bg_body.gif which looks good. The heading says “Create a Group” and there’s input fields for “Group Name” and “Group Description”.

    But entering group name, group description and pressing “Create Group and Continue —->” button only reloads blog homepage and creates nothing.

    Here’s more examples. “Activity” tab + “Personal” tab resolves to http://www.ultimatecultureclash.com/members/cupe3903doll/activity/just-me/ which is probably right. But “Profile” tab + “Edit profile” tab redirects back to home page.

    How weird is that?

    And one more thing I noticed. When tabs resolve where they should? I get logged out. But when tabs redirect to home page? I remain logged in.

    Avatar of piphut
    piphut
    Participant

    @piphut

    This is an old thread but I didn’t see the solution that worked for me so here goes:

    Pretty simple really – when I upgraded BP I had the above issue where all BP pages (groups, activity) etc were redirecting to the homepage. I simply re-ran the BP theme compatibility plugin and now everything works peachy keen again.

    Avatar of grahamlindsey
    grahamlindsey
    Member

    @grahamlindsey

    Hi there,

    It appears I’m experiencing a variation on the common problem discussed above. I’m building a membership-driven site and people should be able to get in to view each member’s profile, including the friends, profile and activity links (left-side)… and I’ve got them all working. My main issue at the moment is the “Album” link – the plugin is bppicture-album, but when you click “album” it goes to the site root.

    This happens no matter whether you’re logged-in or not, and therefore it happens even when you’re not logged in as an admin. The link appears correct (no “//”) and I didn’t see anything in my .htaccess file that would indicate what should be done specially with the link.

    Here’s a sample profile page on my site:
    http://new.productionguide.tv/members/grahamlindsey/profile/

    …and it also happens on this page -> http://new.productionguide.tv/members/grahamlindsey/ (same link as above, minus the “profile/”)

    WP3.0
    BP 1.2.5.2
    bpPicture Album – 0.1.1

    …and there are a number more plugins but I’ve deactivated the unnecessary ones and it doesn’t fix the problem.

    Any help or thoughts would be much appreciated.

    Cheers,
    Graham

    Avatar of chouxpastry2002
    chouxpastry2002
    Participant

    @chouxpastry2002

    such a old thread but no solution yet. I am facing same problem is there anyone who faced the same prob and found solution for it?

    Avatar of rlparker81
    rlparker81
    Member

    @rlparker81

    I had a similar problem where the members profiles were just redirected to the home page so no one could access their profiles. In my case it was related to the buddypress backwards compatibility plugin. I deactivated it and everything started working again! No idea why it broke it though.

    hope this helps someone as it drove me insane.

    Avatar of javiermatosdes
    javy
    Member

    @javiermatosdes

    Has anyone experienced the same redirect when trying to go to the forums? I switched hosting this past weekend and it was working fine before the move, now after forums just redirects to the homepage.

    I’m having that problem right now. I can view forum threads at /forums, but when I click on a thread link it redirects to the home page. Still digging.

    Yep, I’m struggling with a similar issue. Just moved a dev site onto a live server for testing. Everything worked fine on my local machine but now all the forum stuff appears to be redirect straight to the homepage.

    I’m having the same issue. I thought reinstalling bbPress might help but it didn’t. I tried going back to the default permalink structure and that didn’t help.

    The other thing that makes me suspicious is that the Forums menu item doesn’t show up in my auto-generated menu (members does).

    Avatar of javiermatosdes
    javy
    Member

    @javiermatosdes

    ch8rt and mrwweb, I’ve had the same issue for about a month now and haven’t made any progress. Maybe we can put our heads together and work our way through it?

    If going to /forums goes to the homepage and not 404 it means it is a rewrite issue, correct?

    javiermatosdes

    I think that’s one possibility although the fact that the menu item is missing for me (what about you?) makes me question whether it’s a rewrite issue.

    I’m not a rewrite expert or anything, but here’s the HTTP headers associated with the problem. I’ve replaced my domain with blah.com.

    A couple strange things that I see but can’t really explain. When requesting /forums, it looks like a 302 redirect is returned to the homepage (so maybe this is a rewrite issue). Going to “members,” which does work, returns the expected 200 code.

    Also, notice the really weird request to /contact/ after all of this is done. Is that normal? It’s just a random page on my site. It had previously been a different page which I tried deleting, so it was replaced by /contact.

    Hope this is useful to someone.

    `http://blah.com/forums

    GET /forums HTTP/1.1
    Host: blah.com
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 115
    Connection: keep-alive
    Cookie: __utma=67904087.2104826472.1298240908.1299086709.1299438067.4; __utmz=67904087.1299039613.2.2.utmcsr=blah.com|utmccn=(referral)|utmcmd=referral|utmcct=/wp-admin/; _jsuid=1445640004349204205; km_ai=xZrz-rlq1-TnxIBS08C09MbmgAM; km_uq=; km_lv=x; wp-settings-time-6=1299517360; wp-settings-6=m6%3Do%26m11%3Dc%26m10%3Do%26m7%3Dc%26m1%3Do%26m5%3Do%26m2%3Dc%26hidetb%3D1%26editor%3Dtinymce%26m8%3Dc%26m9%3Dc; bp-activity-oldestpage=1; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_541ce9876c2efbba8d8e77491d2f2b82=mrwweb%7C1299690125%7C336801dfabc56c0d1140b4bafdd989aa
    If-Modified-Since: Mon, 07 Mar 2011 17:07:50 GMT

    HTTP/1.1 302 Found
    Server: nginx/0.7.65
    Date: Mon, 07 Mar 2011 17:08:59 GMT
    Content-Type: text/html; charset=UTF-8
    Connection: keep-alive
    Keep-Alive: timeout=10
    X-Pingback: http://blah.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Mon, 07 Mar 2011 17:08:59 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    X-Powered-By: W3 Total Cache/0.9.1.3
    Set-Cookie: bp-message=deleted; expires=Sun, 07-Mar-2010 17:08:58 GMT; path=/
    Set-Cookie: bp-message-type=deleted; expires=Sun, 07-Mar-2010 17:08:58 GMT; path=/
    Location: http://blah.com
    Vary: User-Agent,Accept-Encoding
    Content-Encoding: gzip
    Content-Length: 20
    X-Type: default


    http://blah.com/

    GET / HTTP/1.1
    Host: blah.com
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 115
    Connection: keep-alive
    Cookie: __utma=67904087.2104826472.1298240908.1299086709.1299438067.4; __utmz=67904087.1299039613.2.2.utmcsr=blah.com|utmccn=(referral)|utmcmd=referral|utmcct=/wp-admin/; _jsuid=1445640004349204205; km_ai=xZrz-rlq1-TnxIBS08C09MbmgAM; km_uq=; km_lv=x; wp-settings-time-6=1299517360; wp-settings-6=m6%3Do%26m11%3Dc%26m10%3Do%26m7%3Dc%26m1%3Do%26m5%3Do%26m2%3Dc%26hidetb%3D1%26editor%3Dtinymce%26m8%3Dc%26m9%3Dc; bp-activity-oldestpage=1; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_541ce9876c2efbba8d8e77491d2f2b82=mrwweb%7C1299690125%7C336801dfabc56c0d1140b4bafdd989aa
    If-Modified-Since: Mon, 07 Mar 2011 17:08:42 GMT

    HTTP/1.1 200 OK
    Server: nginx/0.7.65
    Date: Mon, 07 Mar 2011 17:08:59 GMT
    Content-Type: text/html; charset=UTF-8
    Transfer-Encoding: chunked
    Connection: keep-alive
    Keep-Alive: timeout=10
    X-Pingback: http://blah.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Mon, 07 Mar 2011 17:08:59 GMT
    Pragma: no-cache
    X-Powered-By: W3 Total Cache/0.9.1.3
    Set-Cookie: bp-message=deleted; expires=Sun, 07-Mar-2010 17:08:58 GMT; path=/
    Set-Cookie: bp-message-type=deleted; expires=Sun, 07-Mar-2010 17:08:58 GMT; path=/
    Vary: User-Agent,Accept-Encoding
    X-Cacheable: NO:Passed
    Cache-Control: max-age=0, must-revalidate
    X-Varnish: 1456974085
    Age: 0
    Via: 1.1 varnish
    X-Cache: PASS
    X-Type: varnish-short
    Content-Encoding: gzip


    http://blah.com/contact/

    GET /contact/ HTTP/1.1
    Host: blah.com
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 115
    Connection: keep-alive
    Referer: http://blah.com/
    X-Moz: prefetch
    Cookie: __utma=67904087.2104826472.1298240908.1299086709.1299438067.4; __utmz=67904087.1299039613.2.2.utmcsr=blah.com|utmccn=(referral)|utmcmd=referral|utmcct=/wp-admin/; _jsuid=1445640004349204205; km_ai=xZrz-rlq1-TnxIBS08C09MbmgAM; km_uq=; km_lv=x; wp-settings-time-6=1299517360; wp-settings-6=m6%3Do%26m11%3Dc%26m10%3Do%26m7%3Dc%26m1%3Do%26m5%3Do%26m2%3Dc%26hidetb%3D1%26editor%3Dtinymce%26m8%3Dc%26m9%3Dc; bp-activity-oldestpage=1; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_541ce9876c2efbba8d8e77491d2f2b82=mrwweb%7C1299690125%7C336801dfabc56c0d1140b4bafdd989aa

    HTTP/1.1 200 OK
    Server: nginx/0.7.65
    Date: Mon, 07 Mar 2011 17:09:00 GMT
    Content-Type: text/html; charset=UTF-8
    Connection: keep-alive
    Keep-Alive: timeout=10
    X-Pingback: http://blah.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Mon, 07 Mar 2011 17:09:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    X-Powered-By: W3 Total Cache/0.9.1.3
    Set-Cookie: bp-message=deleted; expires=Sun, 07-Mar-2010 17:08:59 GMT; path=/
    Set-Cookie: bp-message-type=deleted; expires=Sun, 07-Mar-2010 17:08:59 GMT; path=/
    Vary: User-Agent,Accept-Encoding
    Content-Encoding: gzip
    Content-Length: 3081
    X-Type: default`

    Avatar of javiermatosdes
    javy
    Member

    @javiermatosdes

    I use custom menus so I don’t have that issue.

    I also get a 302 status code when trying to go to /forums.

    I was using a custom menu but went back to the default BP theme for testing purposes and noticed that /forums wasn’t listed (as it should be)

    Avatar of javiermatosdes
    javy
    Member

    @javiermatosdes

    I spoke with my host yesterday and they said the only thing they could pinpoint that might be related is the following line in .htaccess:

    Rewritecond %{REQUEST_FILENAME} !-f

    I don’t think that is the cause but do others have the same line in their .htaccess?

    Yup. It’s in mine. I don’t really feel comfortable editing that file though.

    Avatar of Gayatriom
    Gayatriom
    Member

    @gayatriom

    Hey I’m getting the problem where only my ‘free subscribers’ are getting redirected to the homepage when they try to access their profile.
    Everything else is accessible.
    It’s bizzare.
    I’m using the latest BP and WP. and S2member.
    g

Viewing 25 replies - 1 through 25 (of 34 total)

You must be logged in to reply to this topic.