Skip to:
Content
Pages
Categories
Search
Top
Bottom

And idea why I can\'t add friends?

  • When click “add friend” the button just “spins” and nothing ever happens. The action does not complete.

    New Database. Fresh install of:

    BP 1.1.2

    WPMU 2.8.6

    No plugins.

    I have the wp-content dir owned by Apache and set to 755. I’m at a loss :-( Everything else seems to work fine.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Okay. I just started fresh. I completely deleted the entire website. All the files. I also completely deleted the database. I made a fresh database. I uploaded WPMU. Installed it. Then uploaded BuddyPress and activated it. And I followed the installation instructions to a “T”. So a complete virgin fresh install of WPMU 2.8.6 and BP 1.1.2. I made two users. And still… I cannot add friends. The busy icon on the button just spins forever and nothing happens. Completely at a loss here. Any ideas?!

    When asking for support

    1. WPMU 2.8.6

    2. Directory-based blogs

    3. Installed in a sub-directory (until such time as I’m ready to flip the DNS switch)

    4. Fresh Install of WPMU

    5. N/A

    6. BP 1.1.2

    7. Fresh Install of BP

    8. No plugins

    9. Standard BP-Default theme.

    10. No core file modifications.

    11. No custom functions

    12. Built-in install of BBPress

    13. Getting this error in the log files:

    Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace., referer: http://cl-t038-352cl.privatedns.com/public_html/satsangha.org/members/mandee/profile/

    14. Hosting company is iWeb (dedicated server)

    I’m guessing it’s a problem with my rewrite rules? But I haven’t modified them either by hand or by changing the permalink structure.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Check the second line of your .htaccess and make sure it’s pointing to the sub directory where you have WPMU installed.

    Thanks John.

    The site is living at http://cl-t038-352cl.privatedns.com/public_html/satsangha.org/ (working now on getting the DNS settings added so my virtual host will work) and the second line of my .htaccess file is RewriteBase /public_html/satsangha.org/

    Interesting. When I change the htaccess file to include this line:

    # stop looping code
    RewriteCond %{ENV:REDIRECT_STATUS} 200
    RewriteRule .* - [L]

    The error message that gets logged when I try to add a friend changes to this:

    File does not exist: /home/www/cl-t038-352cl.privatedns.com/public_html/satsangha.org/satsangha.org, referer: http://cl-t038-352cl.privatedns.com/public_html/satsangha.org/members/mandee/

    But of course… changing the rewrite base to the below breaks pretty much the entire site:

    RewriteBase /public_html/

    Something tells me this won’t be a problem once the domain name is working and the Rewrite Base is just set to the root (forward slash).

    Have others had issues with installing WPMU/BP in a directory? Wondering if this is a bug.

    Okay. I have the site setup with a real domain now. Add Friends works. Definitely broken when installed in a sub-directory however.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Running WPMU alone in a subdirectory isn’t recommended either, so adding BP on top of it could have some unexpected results too. Either way we still want BP to try and be as flexible as possible so tracking down any ways to make it play nicer with any setup is a good thing.

    Thanks John. Yes. It would be a rare case probably. I simply had it that way because my DNS and Virtual Host had not been configured yet. But I think perhaps I did find a bug maybe? Should I submit this to Trac? Low priority fix I’m sure.

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.