Skip to:
Content
Pages
Categories
Search
Top
Bottom

Announcement: BuddyPress RC-1

Viewing 25 replies - 1 through 25 (of 26 total)
  • Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    I should also note a few things here for people to be aware of when upgrading:

    – If you upgrade from a previous version and are using your own custom theme, you will need to copy over the functions.php from the latest buddypress-home theme.

    - Nonce security has been added. This means input forms now have hidden “_wpnonce” fields that ensure that the user has intent when submitting information. You will need to add these fields to the forms if you are using a custom theme. You can see where to add them by looking here. Look for <?php wp_nonce_field( … ) ?>

    - You may find some activity stream items around blog posts will take some time to re-cache and update properly. Give it a few days.

    - If you get a white screen. Check your logs, this will tell you the error. More often than not, it’s because you haven’t updated the functions.php file in your theme.

    - “News” in the home theme has changed to “Blog”. Update your permalinks if necessary.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Slightly off topic, and correct me if I’m wrong, but “Blog” is basically just a direct link to the wp_1_ blog, right?

    Is there any working way to change that URL and link?

    Avatar of BeLogical
    BeLogical
    Participant

    @belogical

    It’s tomorrow!

    Avatar of Ben (oldskoo1)
    oldskoo1
    Participant

    @oldskoo1

    21 hours since the announcement!

    ;0

    i have just setup my new debian/nginx server with php fastcgi with eAccelerator, built in memcache and have my re-write rules sorted.

    All i need now is rc1 :)

    Avatar of SamuelJames
    SamuelJames
    Member

    @samueljames

    excited!

    Avatar of BeLogical
    BeLogical
    Participant

    @belogical

    Tomorrow is almost over!

    Avatar of Ben (oldskoo1)
    oldskoo1
    Participant

    @oldskoo1

    tomorrow is over in 1 hour here in the UK.

    at least it will be available when i get up – then i begin my social networking quest.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    When will then, be now?

    Soon…

    Avatar of MartinNr5
    MartinNr5
    Participant

    @martinnr5

    Well, it’s out now: http://buddypress.org/download/

    I’m installing it as I type…

    Avatar of Nggablog
    nggablog
    Participant

    @nggablog

    Congratulations!

    Happy Valentine too!

    Avatar of MartinNr5
    MartinNr5
    Participant

    @martinnr5

    Andy wrote: “You may find some activity stream items around blog posts will take some time to re-cache and update properly. Give it a few days.”

    I’ve waited a couple of days now and no old blog posts show up in my site wide activity widget, only new blog posts and other activities.

    Should I wait longer or give an update to the latest trunk a shot?

    Avatar of Arturo
    Arturo
    Participant

    @arturo84

    Andy, about _wpnonce, the problem with “WordPress failure notice” the theme is the default home/member theme, and the problem is with the email… how i resolve this? thanks!

    edit: i’ve read in the svn the fixing in #1126. Thanks.

    Avatar of Kevin Ryman
    Kevin Ryman
    Participant

    @kevinryman

    After upgrading to 1.0 RC1 I get the following error message when trying to access my messages:

    Fatal error: Cannot use object of type stdClass as array in /home/********/public_html/beta/wp-content/member-themes/buddypress-member/functions.php on line 14

    I didn’t upload the themes but I did upload the functions.php to the buddypress-theme as directed above. Any tips?

    Avatar of Kevin Ryman
    Kevin Ryman
    Participant

    @kevinryman

    Well, sorry for the above post. I uploaded all the theme files and re-modified the necessary files and the problem was fixed. Thank you for bbPress! :D

    Avatar of Parkcityxj
    parkcityxj
    Member

    @parkcityxj

    I can’t get my group forums to work now. Whenever I try to post something I get this message “Are you sure you want to do this?” and only the option to “please try again” I’ve deleted my old groups and created new ones as well.

    Avatar of Ben (oldskoo1)
    oldskoo1
    Participant

    @oldskoo1

    parkcityxj

    Are you using a custom members theme?

    If so it won’t be RC1 compatible.

    You might be able to patch the groups module to get the forums working…

    Download RC1 – open members theme folder, copy the groups folder, paste it over your current groups folder and it might fix your problem.

    Of course, backup your current groups just in case.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    @parkcityxj read the second point of the second post in this thread.

    Avatar of Joss Winn
    Joss Winn
    Participant

    @josswinn

    I’m running the latest version of SVN trunk, using the default home and members themes. Whenever I click on a link to accept a friendship request, I get the “Are you sure you want to do this?” message. Any suggestions? Thank you.

    I might add this is also happening on my test installation, too, running the same setup, only in a sub dir.

    Avatar of Joss Winn
    Joss Winn
    Participant

    @josswinn

    “Whenever I click on a link to accept a friendship request…” should read:

    “Whenever I click on a link IN AN EMAIL to accept a friendship request…”

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Josswin: you need to upgrade the themes, or read the second post on this thread – the bit about _wpnonce.

    Avatar of Joss Winn
    Joss Winn
    Participant

    @josswinn

    Andy, I’m running the latest default themes from SVN but still having the _wpnonce error.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Where specifically, on which user actions? If it’s links in emails then this is a known issue, it’ll be fixed soon.

    Avatar of Joss Winn
    Joss Winn
    Participant

    @josswinn

    Yes, when I click on a link in an email to accept a friend, I get the “Are you sure you want to do this?” message. The link in the email looks like this:

    Accept the friendship request:

    https://blogs.example.com/members/auser/friends/requests/accept/22?_wpnonce=8b608e4a0d

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    @josswin, this is a known, recent issue with bp’s usage of a wpmu security mechanism.

    http://trac.buddypress.org/ticket/519

    Avatar of Hardcoded
    hardcoded
    Participant

    @hardcoded

    Ok So I had a blog that was doing pretty good and I wanted to get all the fantastic features of buddypress. I went ahead an migrated over, but what I am seeing is that my once very full looking blog is looking like a fresh brand new site, and rightfully so.

    What I would like to propose is maybe a group of us could get together and help each other out by taking the time to help each other make their sites look a little more flush by registering as new users, creating some groups, etc. I think it would help us get more signups if our sites don’t look like something we just put up there two days ago.

    Any thoughts on this. My site is http://www.beergogglehell.com I am not 100% done with it, but close.

Viewing 25 replies - 1 through 25 (of 26 total)

You must be logged in to reply to this topic.