Skip to:
Content
Pages
Categories
Search
Top
Bottom

Any compatibility issues between WordPress 3.2 Release Candidate and current most BP?

  • Avatar of Ronia
    ronia
    Participant

    @ronia

    Any compatibility issues between WordPress 3.2 Release Candidate and current most BP?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of LPH2005
    LPH2005
    Participant

    @lph2005

    You can see 3.2RC1 on the BP Test site:

    http://testbp.org/

    However, that’s running BuddyPress 1.3.

    BuddyPress 1.2.8, which is the current version, does have a couple of small issues that we’ve noticed so far with WordPress 3.2, mainly with javascript in the BP-Default theme. If anyone spots any more, please let us know. We plan a same-day release of 1.2.something with WordPress 3.2 to address these.

    You can get the latest in the 1.2 series from https://buddypress.trac.wordpress.org/changeset/4550/branches/1.2?old_path=%2F&format=zip (at time of writing. SVN is http://svn.buddypress.org/branches/1.2/)

    Avatar of sebastiancrumpcoi
    SebastianCrumpCOI
    Member

    @sebastiancrumpcoi

    Just installed WP3.2RC1 to play with. One thing I noticed was that it allows email addresses as usernames – could that be a problem for BP – especially if someone wants to add BP on after the WP install has lots of users and then wants to sync them…?

    I spent time a while back looking at email addresses as usernames, and other scenarios. Things should work better throughout in 1.3, but some users (dots in username, email addresses in usernames) probably need to set define( ‘BP_ENABLE_USERNAME_COMPATIBILITY_MODE’, true ).

    I’d prefer this to be smarter and automatic for BuddyPress, but I don’t think anything more work will happen in the 1.3 release, for this issue specifically.

    Avatar of thebeanieman
    thebeanieman
    Member

    @thebeanieman

    Hello,

    When I go to ‘Appearance >> Widgets’ the Widgets on the right wont open. Like the Text widget, I cant open it to edit the contents.

    It gives this error:

    f.easing[e.animatedProperties[this.prop]] is not a function
    /wp-admin/load-scripts.php?c=1&load=jquery,utils&ver=fb5c271ac01e8186b23ece33d5ce4961
    Line 18

    This only happens when ‘BuddyPress Template Pack – Version 1.1.3′ is active with 3.2-RC1.

    Thanks

    Did you upgrade BUDDYPRESS to the latest 1.2 version?

    You can get the latest in the 1.2 series from https://buddypress.trac.wordpress.org/changeset/4550/branches/1.2?old_path=%2F&format=zip (at time of writing. SVN is http://svn.buddypress.org/branches/1.2/)

    Avatar of thebeanieman
    thebeanieman
    Member

    @thebeanieman

    Yes ipstenu im using BuddyPress Version 1.2.8.

    But downloading the same version from that link you gave me has corrected the issue. Is that 1.2.9 without the version number changed?

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.