Skip to:
Content
Pages
Categories
Search
Top
Bottom

autocomplete not functioning when composing message

  • Hello,

    I am running BP 1.1.1 on different blog id other than the root, in my case blog id =3. I changed this in the bp-core for the site to function properly. Also at first I had the friends feature disabled, now I have it enabled and still the autocomplete feature does not function at all when composing to friends.

    Any thoughts?

Viewing 25 replies - 1 through 25 (of 31 total)
  • Avatar of bpisimone
    bpisimone
    Participant

    @bpisimone

    I’m having the same problem although probably not with the same background because no such core-alterations have been taking place.

    But how can I debug this? How can we find out where to look?

    Avatar of chewbaker
    chewbaker
    Participant

    @chewbaker

    I too am having this problem. Is this a javascript issue? Any help on this matter would be fantastic.

    Avatar of bpisimone
    bpisimone
    Participant

    @bpisimone

    Chewbaker, if only not-friends are not self-completing, then this is the way it is intended to be.

    If autocomplete is not working no matter what, then welcome to the club. :)

    I’d really appreciate any troubleshooting and debugging hints on this one, as messaging is practically worthless without the function.

    Avatar of chewbaker
    chewbaker
    Participant

    @chewbaker

    I agree, messaging is completely worthless without autocomplete.

    I have friends enabled. made friends with users and still no autocomplete.

    When I inspect in firebug, it says that autocomplete is off. See below code.

    <input id="send-to-input" class="send-to-input ac_input" type="text" name="send-to-input" autocomplete="off"/>

    I have searched the forums and found people have similar problems(though they were several months old), however, no solution has been posted that I could find.

    Is this a 1.1.1 bug?

    Hopefully a moderator sees this and helps us out.

    Avatar of bpisimone
    bpisimone
    Participant

    @bpisimone

    Oh, lucky you. I get only this:

    <input type="text" id="send-to-input" class="send-to-input" name="send-to-input"/>

    Avatar of bpisimone
    bpisimone
    Participant

    @bpisimone

    Any suggestions about how to debug this effectively?

    Hello all,

    So I figured out what was breaking my autocomplete.

    I have two blogs set up on mu using virtual sub-directories instead of subdomains.

    The first blog is on the root using the default theme and acts as an outside blog (blog id=1) and the buddypress theme is on another blog for a private area (blog id=2). By doing this, I can have 1 wp-admin with a public and private area.

    However, by changing the blog id in the bp-core file from 1 to 2 on line 20 for buddypress, it breaks the autocomplete ; but everything else works fine. i believe this is a bug …but if anyone has any suggestions on how to fix this please let me know.

    Avatar of bpisimone
    bpisimone
    Participant

    @bpisimone

    Unfortunately, this is not helping me. No core modifications with my install. I just don’t have anything saying autocomplete=”off” in my sourcecode.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    You must be friends with the users for autocomplete to work. No friends == no autocomplete.

    Avatar of bpisimone
    bpisimone
    Participant

    @bpisimone

    Thanks Andy. Though I know that and that’s not the problem here. I’m only trying with friends. And it was working before my update to 1.1 I believe.

    How can I troubleshoot this?

    As mentioned above, I do not have the autocomplete=”off” in my source code for the send-to-input. I guess this is related.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Actually, for me, autocomplete does not even work on BP.org. I composed a message a couple of days ago to DJPaul and JJJ–who are both friends–and the autocomplete was AWOL. I just tried again, and no dice.

    There is also an issue with messages not getting sent which is being discussed here:

    http://buddypress.org/forums/topic/buddpressorg-messages-broke

    I vote we stick JJJ on it. Nothing better than a nice easy AJAX-related bug for a weekend, eh.

    Avatar of bpisimone
    bpisimone
    Participant

    @bpisimone

    Thanks Jeff. Noticed the same thing a few minutes ago. It’s just what I have on my local install (it seems so at least).

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Paul, I agree. I’m sure jjj has nothing to do this weekend. ;)

    @Bpisimone

    I’m not sure if BP.org has been upgraded yet to 1.1.2–but I’m assuming it has since it was a critical update.

    On a related messaging note, I just tried another test message to jjj, and this time it went through without error.

    Avatar of abcde666
    abcde666
    Participant

    @erich73

    Avatar of microbia
    microbia
    Participant

    @microbia

    Hi all, I had the same problem when not using the BP standard theme, after reviewing the code I realized one thing was missing in the functions file of my theme, I included the following lines:

    require_once( TEMPLATEPATH . ‘/_inc/ajax.php’ );

    /* Load the javascript for the theme */

    wp_enqueue_script( ‘jquery-livequery-pack’, get_template_directory_uri() . ‘/_inc/js/jquery-livequery.js’, array( ‘jquery’ ) );

    wp_enqueue_script( ‘dtheme-ajax-js’, get_template_directory_uri() . ‘/_inc/js/ajax.js’, array( ‘jquery’, ‘jquery-livequery-pack’ ) );

    and now autocomplete works! Not sure if this will fix your problem, but just in case…

    Avatar of David Lewis
    David Lewis
    Participant

    @takeo

    We have a small community of only 160 people. We all know each other in real life. So the friend feature makes no sense for us. We can all see each others profiles anyway. And I’d added the invite all plugin so you can invite anyone to a group. But autocomplete when writing a message doesn’t work. I think it confusing to users that you SHOW them everyone’s profile in the member directory and yet don’t allow them to auto-complete their names when creating a message. I really don’t want to have to enable friending (and force everyone on the site to friend everyone else on the site) just so autocomplete works. This to me is broken. If you show all users, then auto-complete all users. Or at least give us the option to auto-complete all users when friending is turned off.

    Avatar of David Lewis
    David Lewis
    Participant

    @takeo

    My only fall back right now (I refuse to enable friending) is to simply hide the autocomplete box completely. So you’ll only be able to message one person at a time by going to their profile and clicking “send private message”

    Avatar of David Lewis
    David Lewis
    Participant

    @takeo

    http://trac.buddypress.org/ticket/2419

    With the “Friends” component disabled, autocomplete on the “Send To” field in “Messages > Compose” should work for all members. Otherwise there’s no way to choose a recipient. You can write a message but you can’t send it. The only way to send a message is to visit the recipient’s profile and click “Send Private Message”. If you can message anyone by visiting their profile, why not be able to message anyone by visiting “Messages > Compose”? With “Friends” turned on, autocomplete could go back to using just friends. But with “Friends” turned off, autocomplete should work for all members.

    Essentially, turning off “Friends” should be like saying that everyone is a friend… rather than like saying that no one is a friend. You can see all members in the member directory anyway.

    Did anyone ever find a fix for this? My site is experiencing the same issue. However, not only will it not autocomplete but when the user’s name is typed in manually it brings up an error. This is the case when sending through Messages>Compose but if you go to the friend’s profile and click send message the message completes.

    > “but when the user’s name is typed in manually it brings up an error”
    What is the error message?

    Avatar of CarolineElisa
    CarolineElisa
    Member

    @carolineelisa

    I am also having a problem with auto-completing or even manually completing the “Send To” field. I have WP 3.0.3 and BuddyPress 1.2.6 running a test site: http://carolineelisa.com/archcrit/

    The following happens when I have the Friends feature disabled as well as when I have the Friends feature enabled, but have no friends:

    When I start typing a name or username a buggy and/or empty list appears below the field box. e.g. When I type “c” the list shows ‘chitecture’, or when I type “e” it shows ‘el=”alternate” type=…’

    If I type a username eg “elisa” and tab out of the field it populates with ”

    If I click out of the text field I can send the message fine.

    Hope someone can help!

    Avatar of Geet Jacobs
    Geet Jacobs
    Participant

    @geetjacobs

    I have the same issue as CarolineElisa.

    Hello, I am new in the site. It took me a while but I found a solution for the autocomplete feature, but the problem is that it can only be fixed changing a Buddypress core file, and that’s not the way. Anyway here is how I did it (found the code in this forum, don’t remember where exactly, so I am not the author of the code I am sharing, sorry about that). In the file “wp-content/plugins/buddypress/bp-messages/bp-messages-cssjs.php”:

    Line 37, the original code: ( Comment it )

    `var acfb =
    jQuery(“ul.first”).autoCompletefb({urlLookup:’root_domain . str_replace( ‘index.php’, ‘wp-load.php’, $_SERVER ) ?>’});`

    Paste this code right after the previous line:

    `var acfb = jQuery(“ul.first”).autoCompletefb(
    {urlLookup:’root_domain . ‘/wp-load.php’; ?>’}
    );`

    It works for me with the latest version of Buddypress (1.2.7) and with the Friends feature enabled. My question is if it would be possible to include this in the latest Buddypress version so the autocomplete feature works out-of-the-box. I thought it didn’t work for me because I was using a custom buddy theme, but I tested it on a clean install with the default theme and it is broken when you first install it. I think that this way it would work from scratch. Probably you have been already told about this, sorry If I am being repetitive, and thank you for reading !

    Avatar of xavieremerson
    xavieremerson
    Member

    @xavieremerson

    hi, everybody,

    I’m also stuck in this….
    But I got the solution…

    actually i used the tipe from ‘wizard_clp’ that he identifies the location where the actual problem is…

    for this you have to activate friends and also u have minimum one fiend to auto complete to workout.

    then his problem is how to edit core files

    i just copied that function ie ‘messages_autocomplete_init_jsblock’ into my theme unction page renamed it.
    add it into the actions wp_head;
    then i changed the class of that variable to make different from original one
    ie var acfb =jQuery(“ul.first”).autoCompletefb({urlLookup:’root_domain . ‘/wp-load.php’ ?>’,inputClass : ‘.send-to-inputs’,});

    i think this vl help you lot…

    Thankz for the tip…
    god bess you
    xavieremerson1@gamil.com

Viewing 25 replies - 1 through 25 (of 31 total)

You must be logged in to reply to this topic.