Skip to:
Content
Pages
Categories
Search
Top
Bottom

Autoplay in oembed

  • Avatar of LPH2005
    LPH2005
    Participant

    @lph2005

    I am using phpmotion on a site and have an oembed application so that the url can be pasted into thechembook.com forums and activity stream. This works except the videos autoplay. I’ve checked the configuration on chemvideos.com and it is set to autoplay=false. Is there a setting within bp_oembed that can stop the autoplay?

    I was using 5.2 and updated to the .6 beta today .. both autoplay the videos.

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of LPH2005
    LPH2005
    Participant

    @lph2005

    For any new video being linked, I seem to have stopped the autoplay. For earlier linked, I added to the URL:

    &autoplay=false

    Now if I can just get that into the php code to be done automatically ;)

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    This isn’t a problem with the plugin, it’s to do with the oEmbed provider.

    There might be an option to toggle autoplay in PHPMotion for the oEmbed provider.

    If not, you can also write your own function and hook into WordPress’ oEmbed filter to strip the autoplay parameter as well.

    The filter name is “embed_oembed_html”.

    I guess the other main question is how are you adding support to WP oEmbed?

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.