Skip to:
Content
Pages
Categories
Search
Top
Bottom

avatar doesn´t appear

  • Avatar of wordmaster1
    wordmaster1
    Participant

    @wordmaster1

    Hello,

    My english not is the best but i hope you understand me.
    Like member in my buddypress membership site i can upload fotos to my profile and when i create a group like group foto. But later the fotos or avatars doesn´t appear.

    I have the latest versions BP: 1.7.2 and WP: 3.5.2. I searcht the last days in many forms, german forms, spanish and english forms but find nothing. Please help.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @wordmaster1 Check in your server wp-content/uploads/ folder, there should be an /avatars/ folder (for member avatar uploads) and a /group-avatars/ folder (group avatar uploads). Within the folders, you should find xxxxxxxx-bpfull.jpg and xxxxxxx-bpthumb.jpg. Are those present in your installation? If yes, what theme are you using? If you change to Twenty Twelve or the BP Default theme, do the avatars show up?

    Avatar of wordmaster1
    wordmaster1
    Participant

    @wordmaster1

    Hey thanks for your answer.

    I have the default Bp theme.
    My Hoster send me a mail but in spanish (i live in spain). He said that the problem is the pattern of my database. Wp doesn´t creat automatic the register for the avatars and i have to crear it manual. You can say me how and where i need to crear this registers. For this i need to open my Msql database and crear the registers there inside?

    Avatar of wordmaster1
    wordmaster1
    Participant

    @wordmaster1

    I have checked >> wp-content/uploads/ folder and /avatars/ folder (for member avatar uploads) and a /group-avatars/ folder (group avatar uploads), and this folders exist and inside are the fotos who i uploaded.

    Avatar of mgrmn
    mgrmn
    Participant

    @mgrmn

    Puedes darme el texto que te mando su proveedor de alojamiento ? Compruebe que la carpeta wp-content/uploads/avatars existe y que tiene los permisos 0755

    Si no existe ingresa al cpanel -> administrador de archivos, crea la carpeta avatars -> click derecha avatars -> cambiar permisos -> 7 5 5

    edit: never mind..

    Avatar of wordmaster1
    wordmaster1
    Participant

    @wordmaster1

    Hey habls español, perfe;

    Allí el mail del proveedor:

    “Hemos verificado que el problema radica en la estructura de la base de datos, seguramente no hay registros creados para los avatares.

    Esto suele suceder cuando el sistema de wordpress le crea las bases de datos automaticamente. El sistema de wordpress siempre advierte a sus

    usuarios que al optar por la opcion automatica puede que haya problemas.

    Deberá crear aquellos registros manualmente, pero deberá conocer la estructura que maneja el algoritmo de su sitio.

    Ud. puede comprobar en el código fuente de su sitio que en los contenedores de imagenes no hay asignado codigo.

    El problema radica en la forma de creación de la base de datos que ha optado. Solucione el inconveniente manualmente,

    le recomiendo que busque en foros como hacerlo; o bien busque una version de wordpress que coteje toda esta estructura faltante en el

    proceso de creación.

    Comúnmente wordpress avisa mediante mensajes en que partes del codigo existen errores, hay veces que no los muestra.”

    Avatar of wordmaster1
    wordmaster1
    Participant

    @wordmaster1

    @mgrmn

    Si carpetas >> wp-content/uploads/ folder y /avatars/ folder y /group-avatars/ folder existen y dentro estan las fotos subidos.

    Avatar of wordmaster1
    wordmaster1
    Participant

    @wordmaster1

    ps: acabo de revisarlo y tienen tambien permiso 755 los 2 archivos: “avatars” y “group avatars”

    Avatar of mgrmn
    mgrmn
    Participant

    @mgrmn

    Si deseas que te lo explica en espanol me avisa (soy europeo pero, ya vivo por mas de un decada en latinoamerica

    Have you tried debugging it locally (and the link to your site is ?)

    You can use whatever http server you like, either install it manually using apache / php / mysql or use a more simpler app like WAMP http://www.wampserver.com/en/

    1) do a fresh install
    2) install of a backup of your site. And see if it works locally.
    3) change to a default wp theme
    4) disable all plugins, then enabling each plugin 1 by 1 (see if plugin is causing conflicts)
    5) write permissions, which you seem to have

    This just helps to narrow down the problem, so you can know where to look.

    And what you hosting company says, is that the wordpress installation went wrong, that it did not populate the tables necesary for wordpress to work correctly.

    Did you try to reinstall WP?

    Avatar of wordmaster1
    wordmaster1
    Participant

    @wordmaster1

    Yo tengo una base de datos MySql en mí Host y desde allí la puede manejar a traves de PhPMyadmin y creo que no puedo manejarla desde fuera sino solo a traves de mí servidor.

    Me podrias indicar los pasos para crear registros manual? No quiero desinstalar todo. A parte mí tema es el default tema para buddypress.

    el enlace es: http://www.speed-dating.es

    Avatar of wordmaster1
    wordmaster1
    Participant

    @wordmaster1

    @mgrmn: “Have you tried debugging it locally” Como??? A traves de mí base de datos de mí Host MysQl con PhPmyadmin??

    Que tengo que hacer??

    Avatar of mgrmn
    mgrmn
    Participant

    @mgrmn

    Mira lo que dice to proveedor es que 1. La instalacion del wp no fue hecho correctamente (la generacion del base de datos), 2. el codigo img no esta siendo generado. (vea abajo las cosas que puede hacer para determinar donde esta el problema)

    Disculpa si es que no lleva tildes en el texto :) sigue siendo Europeo :)

    Ahora, lo que puede hacer es instalar tu pagina localmente en tu maquina. Asumiendo que tienes windows, baja WAMP. Esto ya viene con todo mysql, php, apache y hagas lo siguiente: para debuggear tu pagina web, y encontrar la problema.

    1) en su pagina web, desinstalar buddypress (plugin-> desactivar->borrar), borra la carpeta /wp-content/plugins/ ->buddypress por completo y instala el plugin buddypress de nuevo.
    2) Reinstalar WordPress por completo, veo que su pagina web aun no esta al aire
    3) instala un wp, installa el plugin buddypress (desde 0), vea si funcione todo ahora
    4) instala un backup de tu wp, y su buddypress, tendras que exportar tu base de datos y importarlo en tu bd localmente, ahora vea si esta funcionando.

    5) Cambiar al default Theme de wp (no del buddypress) vea si ahora si vez imagenes
    6) desactivar todos los plugins instalados, y activalos 1 por 1

    Pregunta, en cuanto creas un articulo (entrada / post ) con un imagen, si se ve el imagen en el post ?

    Avatar of wordmaster1
    wordmaster1
    Participant

    @wordmaster1

    Ok,

    He instalado todo de nuevo paso a paso y creado el archivo para los uploads manual y ahora funciona, yeah!!

    Tu sabes como podria facilitar a mis >futuros> miembros del grupo la posibilidad de crear sus propios Blogs desde su área de perfil??

    o que podrán crear paginas propias similares a las de Facebook para llenarlas con su propio contenido??

    Thanks,
    y hasta luego

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.