Skip to:
Content
Pages
Categories
Search
Top
Bottom

Avatar Upload

  • Avatar of Vito687
    vito687
    Participant

    @vito687

    I just launched my site to a live VPS, and got everything working including forum intergration. the sole problem I have is that I can not change or create avatars, I get a error :: Im also running locally on MAMP with no avatar problem

    \”Upload Failed! Error was: The uploaded file could not be moved to the upload folder.\”

    I Changed permissions to 777, that didnt work so I put an \”avatar\” folder in the root, that didnt work, I checked PHP safe mode to make sure it was off and if it was able to rewrite. Still not working, this is crucial to my site any help would be appretiated.

    I am running latest trunk of BP and latest Branch of WPMU 2.7.1

Viewing 18 replies - 1 through 18 (of 18 total)
  • Avatar of Nicola Greco
    nicolagreco
    Participant

    @nicolagreco

    chmod -R 777 wp-content/blogs.dir

    Avatar of Vito687
    vito687
    Participant

    @vito687

    thanks nicola but I tried that :(

    Avatar of Lance Willett
    Lance Willett
    Participant

    @lancewillett

    Vito687 – have you search a bit here on the forums for a possible solution? This seems to be a common problem and there are a lot of threads with helpful hints, like http://buddypress.org/forums/topic.php?id=1960.

    Some things to check:

    • GD library support on your server
    • .htaccess file is in place and doesn’t have lines commented out
    • Errors in your server logs
    • file permissions

    I know you’ve tried looking at the last two already, but it’s still good to try everything again, especially if you’ve changed a few settings but didn’t check the other items afterwards.

    Avatar of Vito687
    vito687
    Participant

    @vito687

    thanks lance, I guess the last thing I have to check if I have GD library support, Going to call up my server now

    htcaccess not commented out:

    #uploaded files

    RewriteRule ^(.*/)?files/$ index.php [L]

    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*

    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin

    RewriteCond %{REQUEST_URI} ^.*/wp-admin$

    RewriteRule ^(.+)$ $1/ [R=301,L]

    Avatar of Vito687
    vito687
    Participant

    @vito687

    I dont have the “black image” problem I just get an error moving to upload folder, I just called and I have GD support, I have been at this for the past 3 hours :( im stuck

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Vito687-

    I can not change or create avatars

    I assume you mean that you cannot create avatars at all. If that is the case, then you cannot even get the chance to change your avatar. Is this correct?

    The error you mentioned in your OP is found in only two places in BP:

    • bp_core_avatar.php –> in the function bp_core_avatar_admin
    • bp_xprofile_signup.php –> in the function xprofile_validate_signup_fields

    So, either you do not have sufficient permissions in the folder where the avatar is first uploaded, or you’re uploading an avatar that is too big. I will guess that it is the first problem based on the error message.

    But, let’s be thorough.

    You mentioned that you’re running a very recent BP trunk version and WPMU 2.7.1_beta from branch. We’ll assume that everything is correct with your upgrade and that you’ve also read the thread Lance mentioned and tried any applicable suggestions.

    Here, then, are some additional or follow-up questions:

    1. What is the size of the avatar you’re trying to upload?
    2. What is the avatar’s format?
    3. Are you using the standard buddypress-member theme or a customized theme?
    4. What version of GD is installed?
    5. What version of PHP are you using?
    6. Have you checked all the folders in blog.dir and made sure that there are indeed no files?
    7. Have you checked the permissions of each of the subfolders in blog.dir?

    Avatar of Vito687
    vito687
    Participant

    @vito687

    Okay thanks jeff for the help, let me try to answer your questions as precisely as you have laid them out.

    first off, I have pre-existing avatars in my blogs.dir, these avatars load fine, the thumbnails and everything else is there. Ive tried just using an empty blogs.dir and it still didnt work. I hit “change avatar” upload and get that error message.

    My permissions for the entire blogs.dir are set to 777 so I think that would clear up any permission issues.

    Im trying to use various formats for testing so far a png that was 800k and a jpg about the same, I have my limit set to 2500k

    I have read lance’s post but unfortunately none of the methods helped.

    I am using a customized theme, when I upgraded to the BP trunk as per andys instructions I copied only the functions and header files over for both my home and members theme. Everything is working properly. The BP_core and all plugin files were placed in the plugins/buddypress directory and are functioning fine.

    as far as version of PHP, do you mean myadmin client or actual code, which is whatever its written in to begin with, Ive done minimal php editing besides a custom loop on the home page, mainly CSS edits.

    I did not check and see if there where no files in the blogs.dir because there are files presently there, I will try again with an empy blogs.dir folder

    Is there anything in the DB that controlls where the upload script tries to send the file to? because I went from a local setup to a server set up, maybe the upload button is still using the local domain?

    I really need to get this working, any help is truly appreciated

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Does apache/php have write permission in your php or system /tmp directory?

    Avatar of Vito687
    vito687
    Participant

    @vito687

    yes I believe that was referenced in a post I read as well as php safe mode to off, which both are done

    Avatar of Vito687
    vito687
    Participant

    @vito687

    any other input? still same errors Ive tried all these thing

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Vito687-

    as far as version of PHP, do you mean myadmin client or actual code

    What version of PHP is your domain on your VPS running? Is this different than the version you’re using in MAMP?

    More steps to try:

    1. Do you have any plugins other than BuddyPress installed? If so, disable all of them and see if you still get the problem. If you do not, if it works, then activate the other plugins one at a time, each time trying the avatar change or upload until you get the problem.
    2. If that does not work, try reinstalling from scratch. This means deleting all the files from your domain and deleting the MySQL database you’re attaching to. Create a brand new database and then upload WPMU and BP per install protocol. See what happens.

    Avatar of Vito687
    vito687
    Participant

    @vito687

    thanks, I shall try that, and it is the same version of php that I am using on mamp

    Avatar of Vito687
    vito687
    Participant

    @vito687

    Well, I tried on a fresh install and it works, only problem is that I would like to migrate my plugins/plugin states over, such as adsense , where on the DB is the infor for the plugin states such as what is active and what isnt, and also where i the page they are

    Avatar of Vito687
    vito687
    Participant

    @vito687

    I have narrowed it down, I found where the widget options are stored, within wp-1-options table correct? well within the new install I uploaded this table and the crop stopped working, so my problem is within this table… so it seems that fortunately that its only something stored in this table so I shouldnt have to change my whole database and install to a new one if I can fix it… any idea what line would control this in the options?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Widget options are stored in the blog meta (options) on whatever blog they are activated on. If a widget is running on blog id XX then the options for that widget will be in the wp-XX-options table. Frankly I think you are making this more difficult than it really is. Just go into the wp back end under Appearances> Widgets and load them up, set the options and you\’ll be done.

    I’m turning off the red light.

    Avatar of Vito687
    vito687
    Participant

    @vito687

    im sorry burt, but I have over 100 different adds for adsense and other options set as well as custom widget fields , this is not as simple as we would like it to be, Ive been at this for two days everything else functions fine, and Ive narrowed it down to wp_1_options, I just need a little more help and my issue will be solved

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Vito687-

    Export wp_1_options from one database and into the other.

    Of course, make sure you’ve back up your entire database first.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    This has absolutely nothing to to with bp vito687.

Viewing 18 replies - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.