Skip to:
Content
Pages
Categories
Search
Top
Bottom

Avatars Not Working.

  • Avatar of newvisioninfotech
    newvisioninfotech
    Member

    @newvisioninfotech

    Hello To All!

    i was create website with buddypress,
    i was used default theme, wordpress 3.0.X
    Running on windows hostings.

    when user are register with all details, after registration their must to upload avatar.
    uploading process doing successfully.
    after activating acc user cant seen uploaded avatar, he/she can see default avatar.
    can anyone know me what happening and what should i do to solve it?
    Thanks in advanced.

Viewing 17 replies - 1 through 17 (of 17 total)
  • Hi,

    Try changing the permissions of your wp-content folder.

    Enjoy,
    jarbess

    Avatar of newvisioninfotech
    newvisioninfotech
    Member

    @newvisioninfotech

    i was trying to give permission of 777.
    but still its not working.
    any other solution?

    Avatar of newvisioninfotech
    newvisioninfotech
    Member

    @newvisioninfotech

    my website running on windows server
    Wordpress version : WordPress 3.0.1.
    Buddypress Version 1.2.7

    i was give permission of 777, but still it doesn’t display user avatar, its display default avatar (mystery-man)
    while user was upload their own avatar. but its doesnt seen in profile,.

    its very urgent for me.
    please give me other solution,
    i was already talk with my hosting provider but he was told me permission is 777 for wp-content.
    please guide me.

    thanks

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Ask your host whether the PHP GD extension is installed and loaded

    Avatar of newvisioninfotech
    newvisioninfotech
    Member

    @newvisioninfotech

    PHP GD extension is installed!

    Avatar of newvisioninfotech
    newvisioninfotech
    Member

    @newvisioninfotech

    can you please suggest me another solution?
    its very urgent for me.
    i dont know what should i do?

    please help me.

    thanks

    Is the uploaded avatar being saved on the server?

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    and ask your web host whether the owner/group permissions are correct to allow the server or user to write to directories. This issue is not just about chmod and the continual advice from general quarters around the web and from hosts to set directories to world writable 777 is starting to get irritating.

    P.S We understand it is urgent but you mustn’t state that in a post it’s not our problem ;) I resolved this kind of issue by sitting down with Linux guides and a test server until I had a fair grasp of things – note only fair though still get confused by much :(

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    post content of your install’s htaccess file here – and clarify whether you’re on single WP or multsite (if multisite – subdomain or subdirectory)

    Avatar of newvisioninfotech
    newvisioninfotech
    Member

    @newvisioninfotech

    Thanks for your replay.

    @paul – uploaded avatar saved in /wp-content/uploads/avatars/signups
    @mercime – wordpress working on signle site on root. (http://mysite.com)

    My .htaccess :
    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]

    # END WordPress

    @hnla : my site is host on windows server. i was check permission for read/write for IIS user.
    but i dont know whats going wrong….. :(

    waiting for your reply.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Are you using Apache on Windows or IIS on Windows? http://codex.wordpress.org/Using_Permalinks#Permalinks_without_mod_rewrite

    Avatar of newvisioninfotech
    newvisioninfotech
    Member

    @newvisioninfotech

    if i m adding bellow code i get 500 error

    any other solution?

    thnks

    Avatar of newvisioninfotech
    newvisioninfotech
    Member

    @newvisioninfotech

    i am waiting for solution…..

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    === i am waiting for solution…..===

    @newvisioninfotech It is important that your WordPress installation is working correctly before installing and activating BuddyPress http://codex.buddypress.org/getting-started/before-installing/#wp-configuration
    Instead of only waiting for solution here, I suggest that you also post your issue at WP.org forums where there are more people with Windows hosting http://wordpress.org/support/

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    This isn’t a paid support forum and as such comments like I am waiting for a solution… do not go down well!

    Also bear in mind that technically this isn’t or is unlikely a BP or WP issue but a server configuration one.

    Avatar of metaphorcreations
    metaphorcreations
    Member

    @metaphorcreations

    I have this same issue. When someone creates a new user and uploads a custom Avatar, the upload seems to work, but once logged in the default Avatar shows up.

    If the user then edits their profile and uploads an Avatar, it will show up and replace the default Avatar. So, in general the custom Avatar works, but not when a user first registers for the site.

    It seems as though the images that get stored in the ‘uploads/signups’ directory don’t work, but images stored in the other directories do.

    Any advice?

    Avatar of metaphorcreations
    metaphorcreations
    Member

    @metaphorcreations

    Ok, the issue arrises when I ‘bp_core_activation_signup_user_notification_to’ and switch the confirmation email to someone other than the user… So, it’s something with the activation not be activated by the actual user.

Viewing 17 replies - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.