Skip to:
Content
Pages
Categories
Search
Top
Bottom

avatars upload but cannot be cropped etc

  • Hi all,

    Using WPMU 2.6.3 with BP trunk-r571 on Firefox and IE7.

    After uploading an image at the change-avatar script, on the next page I see the image and below it the text “Crop Preview” with a Crop & Continue button, however none of these are hyperlinks, and I can’t actually crop the image.

    Is this a bug/known issue or am I missing prerequisite software for my server?

    Thanks

Viewing 25 replies - 1 through 25 (of 45 total)
  • I have discovered that my server assigns ownership of the blogs.dir recursively to nobody:nobody, which cannot be right. So I am assuming this is not a buddypress issue but a server configuration one

    Avatar of Gogoplata
    gogoplata
    Participant

    @gogoplata

    Every setup is probably different, but mine are owned by apache:apache.

    Ok the permissions are correct, so I’m not sure what the problem is here.

    The image uploads fine.

    The actual selector does not appear, nor does the preview image below it.

    I am thinking there is missing software on my server, does anyone know what this script requires?

    I’m able to crop avatars on testbp.org so this is not a browser issue

    any help much appreciated,

    Thanks

    Avatar of Slava UA
    Slava UA
    Participant

    @slaffik

    The same problem on my friend’s blog. Don’t know what to do.

    To me it seems like missing software on the server side.. it’s not GD though

    Here’s a demonstration of my problem

    http://tourneytime.co.uk/members/admin/profile/change-avatar/

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Make sure the js and css files on your server are set to 755. Everywhere in bp. I just went down to root and did:

    chmod -R 755 mu-plugins

    from within /wp-content

    Also, we would have to create an account on your system to view your profile. Can’t just go look at that url. :)

    Avatar of Oceandoctor
    oceandoctor
    Member

    @oceandoctor

    I’m having the same issue on a new install of beta. My permissions are correct. Was this resolved?

    Avatar of Timothy West
    trcwest
    Participant

    @trcwest

    @oceandoctor i too have the same problem.. its verry strange as i have it running on bp.spotskenya.com and just did a fresh install with new DB on spotskenya.com alls well apart from the avatar crop and resize.. i can click through but all i get is a black box..

    it seems that this may be an issue with the version we have downloaded as it was working on an instalation about a week ago and now its not.

    I have checked my permission and as far as i can see they are 755

    so basically please do let me know

    OTHERS whats do you think the problem is

    this is the lastest url http://spotskenya.com

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Are both ImageMagick and GD2 both installed on your servers? The gurus over at the mu forums say that both have to be installed.

    Avatar of Oceandoctor
    oceandoctor
    Member

    @oceandoctor

    Not sure…checking. But this problem is occurring on two fresh beta installations on two separate hosts (one on BlueHost shared server, the other on 1and1 dedicated (managed) server). Is there a short-term workaround, e.g., requiring upload of an image of specific dimensions?

    Avatar of Timothy West
    trcwest
    Participant

    @trcwest

    well as i said the strange and odd thing is on the same server i have it working at bp.spotskenya.com and NOT WORKING at spotskenya.com

    so the same shared host with lunarpages has one working and one not sure this is a code error.. please take a look at the sites..

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    @trcwest It’s not indicative of a bug to run ok on one install and then not on another install. It seems that whatever you have configured on bp.spotskenya.com is correct and the config at spotskenya.com is not.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    @oceandoctor You probably could work around this by uploading two avs for each of your users, or just going with one of the default avs like ‘identicons’. (Site Admin > BuddyPress > Default Avatars)

    I haven’t tried *turning off* a custom av though. One bp thinks you have one, you have one. If you want to run a generated av like identicon, try deleting the custom av and then configuring bp to use a stock one.

    Avs come in to flavors. small and large. 50×50 and 150×150. Named: myfavav-avatar1.jpg and myfavav-avatar2.jpg. Once again bp remembers the url to these avs once uploaded and cropped. The easiest way to hook up to bp is to name them the same as the existing goofy avs. Just replace them.

    Avatar of Timothy West
    trcwest
    Participant

    @trcwest

    @burtadsit i re installed it all again and it came alive its so cruciall to get it all right and as i have a slow conection here in kenya its a bit slow to get things updated..

    can i ask for your attention on http://buddypress.org/forums/forum.php?id=3 some feedback would be ace..

    Avatar of Oceandoctor
    oceandoctor
    Member

    @oceandoctor

    Thanks for the workaround advice.

    I’ve worked to confirm GD2 and ImageMagick:

    Running phpinfo on BlueHost shows GD2 installed(2.0.34 compatible)

    According to Tech Support, ImageMagick is installed and accessible at /usr/bin. Running version 6.0.7.

    Any other possible culprits here?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    @oceandoctor Please explain to me exactly what the problem is. I’m kinda hazy on that. All I have to go on is that somebody else is having problems cropping avs. That’s you also? What happens, where? Group avs? Member avs?

    Thanks

    Avatar of Oceandoctor
    oceandoctor
    Member

    @oceandoctor

    @burtadsit My symptoms are the same as @st9bp‘s, per above:

    The image uploads fine.

    The actual selector does not appear, nor does the preview image below it.

    The image uploads, but you can’t crop it because the selector/overlay tool simply isn’t there. The uploaded avatar will not save, so you end up with a default avatar. This applies to both Group and Member avatars. Thanks.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    View the source of the image crop page. Are there javascript libs being sent to the browser? Do you have js turned on in your browser?

    In the viewed source for the avatar crop page you should have bunches of js libs being sent to your browser. Including a line something like this:

    <script type='text/javascript' src= ...[snip]... /wp-includes/js/crop/cropper.js ...[snip]

    Avatar of Oceandoctor
    oceandoctor
    Member

    @oceandoctor

    Are there javascript libs being sent to the browser?

    In the viewed source for the avatar crop page you should have bunches of js libs being sent to your browser. Including a line something like this:

    <script type=’text/javascript’ src= …[snip]… /wp-includes/js/crop/cropper.js …[snip]

    Here’s what I see:

    <script type=’text/javascript’ src=…[snip]…/wp-includes/js/prototype.js?ver=1.6′[snip]

    <script type=’text/javascript’ src=…[snip]…/wp-includes/js/jquery/jquery.js?ver=1.2.6′[snip]

    <script type=’text/javascript’ src=…[snip]…/wp-content/mu-plugins/bp-core/js/jquery/jquery.livequery.pack.js?ver=2.6.5′[snip]

    <script type=’text/javascript’ src=…[snip]…/wp-content/mu-plugins/bp-core/js/general.js?ver=2.6.5′[snip]

    <script type=’text/javascript’ src=…[snip]…/wp-includes/js/scriptaculous/scriptaculous.js?ver=1.8.0′[snip]

    <script type=’text/javascript’ src=…[snip]…/wp-includes/js/scriptaculous/builder.js?ver=1.8.0′[snip]

    <script type=’text/javascript’ src=…[snip]…/wp-includes/js/scriptaculous/effects.js?ver=1.8.0′[snip]

    <script type=’text/javascript’ src=…[snip]…/wp-includes/js/scriptaculous/dragdrop.js?ver=1.8.0′[snip]

    <script type=’text/javascript’ src=…[snip]…/wp-includes/js/crop/cropper.js?ver=20070118′[snip]

    Do you have js turned on in your browser?

    I do, and I’m getting the same symptom in both Firefox and IE.

    One note: This now appears to be only a BlueHost issue. Cropping works fine on 1and1…guess I was mixed up yesterday.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Are you uploading avs and trying to crop from a subdomain or a subdir blog? bp had problems with getting the paths straight when changing or creating avs from subdomains. It seemed to go ok but was storing the wrong url to the cropped av. I don’t think the fix came thru svn yet.

    Your install is like: mysite.org/muinstalldir right? mu installed in a subdir under the doc root? Am I remembering correctly?

    Avatar of Oceandoctor
    oceandoctor
    Member

    @oceandoctor

    I saw earlier posts about using large images, so I’ve tried everything from 450×450 to 125×125. Largest file < 100kb.

    Avatar of Oceandoctor
    oceandoctor
    Member

    @oceandoctor

    Yes…it’s installed under a subdirectory as you specified.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    This may also be why you are having problems in the other thread with table creation. Originally mu *had* to be installed in the doc root. No other install was supported. That was way back earlier in the alpha version. I thought I saw some comments come thru svn about fixing things to work in subdir installs of mu. Not the subdirectory blog creation option, just mu installed in a subdir under the doc root.

    Gonna have to go look at the svn logs. brb.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    I’m going to send off an email to Andy and Trent about this and take a look at the code to see if it might be that subdir issue. Maybe he’s in irc. Hang in there. We’ll figure it out.

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Are the permissions correct on the upload folders? Likely the new images are returning a 404 because the permissions are incorrect. This would allow the cropper to display but the image would break.

Viewing 25 replies - 1 through 25 (of 45 total)

You must be logged in to reply to this topic.