Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbpress and buddypress forum integration plugin fatal error

  • Avatar of Ehegwer
    Ehegwer
    Participant

    @ehegwer

    Using some cutting edge stuff (currently):

    WordPress MU 2.7.1

    bbPress version 1.0-rc-1

    BuddyPress Support Plugin 1.0-RC1

    When I navigate over to http://www.mysite.com/forums/bb-admin/plugins.php and try to enable the buddypress integration plugin (installed in my-plugins) I get a fatal Error:

    Fatal error: Cannot redeclare for_buddypress_strip_tags() (previously declared in /home/demo/public_html/uberbrides.com/public/forums/bb-plugins/buddypress-enable.php:11) in /home/demo/public_html/uberbrides.com/public/forums/my-plugins/buddypress-enable.php on line 31

    Any ideas or other places to download an older version?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    BuddyPress Support Plugin 1.0-RC1

    If you are truly using BuddyPress 1.0-RC1, then that is your issue. There have been many bugs fixes and improvements since RC1. It’s time to upgrade to the 1.0 public release and try the process again.

    Since RC2, BuddyPress is a single plugin that resides in /wp-content/plugins/. Make sure you follow these revised Installation procedures very carefully.

    Avatar of Rich Spott
    Rich Spott
    Participant

    @richs0914

    From what I can see, the latest BuddyPress Support Plugin for bbpress is still version 1.0-RC1, even in BuddyPress 1.0 (or at least its marked that way).

    There is no BuddyPress Support Plugin 1.0.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    @Richs0914

    Nice catch! You’re correct. The BuddyPress Support Plugin is still versioned as 1.0-RC1.

    I’m use to thinking in terms of file names. In this particular case, buddypress-enable.php. So, I incorrectly made a wrong assumption.

    @Ehegwer-

    Make sure that you carefully read the installation-readme.txt file included in /buddypress/bp-forums/ folder.

    You state that your:

    buddypress integration plugin [is] (installed in my-plugins)

    This is not the proper location. See Step 6 of installation-readme.txt:

    In the bp-forums component there is a /bbpress-plugins/ folder. Copy the ‘buddypress-enable.php’ plugin file from that folder into your bbpress plugins folder (eg domain/bbpress/bb-plugins/)

    Avatar of Ineffabelle
    IneffaBelle
    Participant

    @ineffabelle

    So is there going to be a version that works with the current build of BP?

    Is there any way to get it to work in the meantime?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    This stuff works just fine people. Do you have that plugin in my-plugins as well as bb-plugins? It’s trying to run twice for some reason.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Once we’ve got a “stable” bbPress 1.0, I’ve got a stable step by step integration process. :)

    RC2 is looking pretty good so far so shan’t be long now!

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.