Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbPress forums not working

  • Avatar of darrylsherborne
    darrylsherborne
    Participant

    @darrylsherborne

    I have WP 3.5.1, BuddyPress 1.7.3 and bbPress 2.3.2 installed on my site (juicyjabber.com). I created some Groups after installed BuddyPress and then installed bbPress and found that the forums were not working/created (with the error message below). So, I uninstalled BBpress and then re-installed it according to the steps outlined in the codex:

    http://codex.buddypress.org/user/setting-up-a-new-installation/installing-group-and-sitewide-forums/

    The existing Group forums still do not work. So I’ve create a new Group and attempted to access the new forum I created but all I see is the same error message:
    Warning: substr() expects parameter 1 to be string, array given in /home/juicyjab/public_html/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 776

    Warning: strpos() expects parameter 1 to be string, array given in /home/juicyjab/public_html/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 783

    Warning: explode() expects parameter 2 to be string, array given in /home/juicyjab/public_html/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789

    Warning: Invalid argument supplied for foreach() in /home/juicyjab/public_html/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789

    Warning: substr() expects parameter 1 to be string, array given in /home/juicyjab/public_html/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 776

    Warning: strpos() expects parameter 1 to be string, array given in /home/juicyjab/public_html/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 783

    Warning: explode() expects parameter 2 to be string, array given in /home/juicyjab/public_html/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789

    Warning: Invalid argument supplied for foreach() in /home/juicyjab/public_html/wp-content/plugins/buddypress/bp-forums/bbpress/bb-includes/class.bb-query.php on line 789

    I’m stumped and have no idea what to do next. Any tips/suggestions/fixes would be greatly appreciated.

You must be logged in to reply to this topic.