Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbPress – There was an error posting that topic.

  • Avatar of Byronfillmore
    byronfillmore
    Member

    @byronfillmore

    I have integrated buddyPress with bbPress so that my groups can have discussions without leaving the site.

    It works perfectly when logged in as an admin. When I create a new user and try to post topics I get this error….

    “There was an error posting that topic.”

    Any ideas?

    Byron

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Byron, you made it. I thought about this. Is your new user a ‘member’ in bbpress? Also do you have this line:

    $bb->bb_xmlrpc_allow_user_switching = true;

    in bb-config.php?

    hi, I am having a similar issue. When I try to post a topic, as admin or otherwise, I get the same error – “There was an error posting that topic.”

    It posts to the forum though, I can see it there, but it just does not show up on the buddypress front-end. I do have that line ($bb->bb_xmlrpc_allow_user_switching = true;) in bb-config.php

    Any thoughts would be greatly appreciated. thanks.

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    2 things you can try here. 1. Disable discussion & then enable it again. 2. Try creating a new group & see if you still have the same problem.

    Avatar of kim_nz
    Kimberly
    Participant

    @kim_nz

    Hi, I had the same thing. I had it working on 1 site but not on another. Turns out I forgot to enable the buddypress plugin in the BBPress admin area.

    hth.

    Avatar of Larsg
    Larsg
    Participant

    @larsg

    Hi, “Turns out I forgot to enable the buddypress plugin in the BBPress admin area.”

    What is this? Where can I do this? Is there a BBpress plugin that I have to install? Pls provide URLs.

    I get the “There was an error posting that topic.” and wonder if this may be the reason (if I missed activating something in BBpress).

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    Larsg, the buddypress plugin can be found in

    wp-content>>plugins>>buddypress>>bp-forums>>bbpress-plugins

    It needs to be moved but the location depends on your version of bbpress. Assuming you renamed bbpress to forums, you have 2 options:

    forums>>my-plugins>>buddypress-enable.php

    forums>>bb-plugins>>buddypress-enable.php

    If 1 location doesn’t work & you try it in a 2nd location, remember to MOVE it. Having it in more than 1 location can make the wrong file be activated. Also, if you move it, you will have to reactivate it.

    Avatar of Larsg
    Larsg
    Participant

    @larsg

    Hi, thanks. Tried this, Still same problem. I activated plugin (tried both locations).

    The thread http://buddypress.org/forums/topic.php?id=3444 imply that no buddypress support plugin is required.

    All this a bit confusing. Isn’t there a full install/integration tutorial available for ver 1?

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    Sorry about that – You didn’t mention what version of bbPress you were using and I assumed that since you were in an old post, you were using the old version. I’m working on a tutorial (or will be the second I get this sucker to work) My suggestion at this moment would be to follow my tutorial for installing the alpha 6 version. And then upgrade it using r-a-y’s instructions at this post. I know it’s not the greatest answer but for now, it’s all I can personally offer. Hopefully someone will have a tutorial up shortly. LOL

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.