Skip to:
Content
Pages
Categories
Search
Top
Bottom

Blank wp-admin page after enabling some buddypress components

  • Avatar of welshdemon
    welshdemon
    Participant

    @welshdemon

    Please can somebody tell me how to enable/disable BP components via mysql or shell access?

    I enabled all of the components (I had most enabled, but added groups and friends) and then my admin page comes up blank! Im pretty sure those are the only changes I made so how can I disable those components in the Mysql database or a file on the server, please?

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of welshdemon
    welshdemon
    Participant

    @welshdemon

    Never mind Ive found it.

    Table wp_options in your wp database.

    option_name bp-active-components.

    I will have a play about.

    Avatar of welshdemon
    welshdemon
    Participant

    @welshdemon

    Damn, its confusing. Think Ive got it for anyone else with this issue.

    a:8:{s:8:”xprofile”;s:1:”1″;s:8:”settings”;s:1:”1″;s:7:”friends”;s:1:”1″;s:8:”messages”;s:1:”1″;s:8:”activity”;s:1:”1″;s:6:”groups”;s:1:”1″;s:5:”blogs”;s:1:”1″;s:7:”members”;s:1:”1″;}

    The a:8 at the start, needs changing to however many components are running. I disabled groups and friends, so I changed the code to read:

    a:6:{s:8:”xprofile”;s:1:”1″;s:8:”settings”;s:1:”1″;s:7:”friends”;s:1:”0″;s:8:”messages”;s:1:”1″;s:8:”activity”;s:1:”1″;s:6:”groups”;s:1:”0″;s:5:”blogs”;s:1:”1″;s:7:”members”;s:1:”1″;}

    Avatar of welshdemon
    welshdemon
    Participant

    @welshdemon

    And yes, my admin page now works. I think its the friends component, as Ive had groups running before with no issues. I might report more here if I work out the friends issue.

    Avatar of welshdemon
    welshdemon
    Participant

    @welshdemon

    oops, now most of my components are not running. That wasnt correct editing of the code.

    To remove a component, delete the whole section, eg., s:6:”groups”;s:1:”1″;

    BEFORE (BROKEN? White/Blank wp-admin)

    
    a:8:{s:8:"xprofile";s:1:"1";s:8:"settings";s:1:"1";s:7:"friends";s:1:"1";s:8:"messages";s:1:"1";s:8:"activity";s:1:"1";s:6:"groups";s:1:"1";s:5:"blogs";s:1:"1";s:7:"members";s:1:"1";}
    

    AFTER (Working wp-admin)

    
    a:6:{s:8:"xprofile";s:1:"1";s:8:"settings";s:1:"1";s:8:"messages";s:1:"1";s:8:"activity";s:1:"1";s:5:"blogs";s:1:"1";s:7:"members";s:1:"1";}

    So as you can see, to disable / remove the groups component, remove the section s:6:”groups”;s:1:”1″; and adjust the a:# at the start so it is a:# where # is the total number of components in use. Eg a:6

    Avatar of welshdemon
    welshdemon
    Participant

    @welshdemon

    The bizarre thing is that the front end of the site worked fine, even with friends and groups showing. Wierd!! You’d think it would be the other way around.

    And if the edit function worked here I wouldn’t have to reply to my own post so many times.

    Avatar of welshdemon
    welshdemon
    Participant

    @welshdemon

    This *may* have been a memory related issue.

    I have upped my settings in php.ini – memory_limit was 8M (default) – I put it to 128M and I can now have both friends and groups components active without the wp-admin breaking.

    Also avatar uploads weren’t working a lot of the time, they were timing out / connection reset. This seemed to fix that issue too. Or one of the below, which are shown below as double the default.

    max_execution_time = 60
    max_input_time = 120

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.