Skip to:
Content
Pages
Categories
Search
Top
Bottom

Blog link in top bar returns “not found”

  • Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    I feel a little fool asking this question… and I bet it has been asked before, but I can’t find it.

    The second link of the navigation bar, Blog, shows a blog page that shows a funny “Not Found” message and a search form.

    I noticed many sites has this problem (I took a look on the sites listed in the “Sites using BP” group right here (or perhaps, testbp.org, can’t remember.

    Anyway… Does anyone knows what I am doing wrong? My main blog has two testing posts so it *should* shows something.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Member theme or home theme?

    What version of bp?

    The 404 error when trying to access the blog posts on the main blog is usually due to not using the most recent functions.php file in your theme. Make sure that your theme is using the functions in functions.php distributed with the bp home theme.

    Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    I’m on the latest trunk of every piece of code I use. I mean: WPMU, BP…

    Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    By the way, the blog link is served using the home theme so I think the member theme is out of question regarding this issue (just MH opinion… I only have a few hours playing with BP)

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    If you are running the latest trunk for everything then I don’t know what the problem could be. When that options is chosen in the home theme nav bar bp detects the /blog url and simply loads the template index.php in your document root.

    Cancel all that. You are running the home theme on a subdomain right? I just got that error when I activated the home theme on a subdomain.

    Ok, now I understand. Hmmm. Be back.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    OK. Here\’s the solution. You have to update to the latest trunk again. At least rev 1286. Put this in wp-config.php:

    define(\’BP_ROOT_BLOG\’, X);

    Where X is the blog id for the blog you are running the bp home theme on. Gotta be an integer there for X. 1, 99, 207 whatever it is.

    Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    Not sure if it will solve my problem… I will update my installation tonight.. I’m not using my home computer right now.

    However, I’m running my installation in the root domain, emigrando.info. And WPMU is on subdomain mode, if that matters.

    Avatar of Dace
    Dace
    Participant

    @dace

    @Wcastillo => do u have the .htaccess at the WPMU’s root ?

    Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    @Dace: Yes… An unmodified version:

    RewriteEngine On

    RewriteBase /

    #uploaded files

    RewriteRule ^(.*/)?files/$ index.php [L]

    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*

    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin

    RewriteCond %{REQUEST_URI} ^.*/wp-admin$

    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule . – [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]

    RewriteRule . index.php [L]

    <IfModule mod_security.c>

    <Files async-upload.php>

    SecFilterEngine Off

    SecFilterScanPOST Off

    </Files>

    </IfModule>

    Is anything wrong with it?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Are you running the home theme on a subdomain? Is that the blog that is having 404 errors?

    Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    @Burtadsit: Not sure what you mean by “running the home theme on a subdomain”.

    My WPMU is on a root domain (http://emigrando.info/). I’ve not created any other blog yet… just the default one… and it should be in its usual location (http://emigrando.info/), masked by the BP Theme… making it available (in theory) at http://emigrando.info/blog.

    The problem is that http://emigrando.info/blog returns a “Not Found” blog page…

    Avatar of Hyrxx
    hyrxx
    Participant

    @hyrxx

    i have had this before and i belive it is all in one seo, so if you have that installed go to the options and uncheck rewrite titles, as it doesnt play nice with buddypress, hope that helps

    Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    @Burtadsit: I updated my installation to the latest trunk… I added the constant definition for BP_ROOT_BLOG in my wp-config.php… and it didn’t work.

    Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    @Hyrxx… THAT makes sense… I’m using Platinum All in One… the next version of the All-in-One…

    let me check

    Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    @Hyrxx: Nope… :( I deactivate the reqrite title settings and it didn\\\’t work… Next, I deactivate the plugin.. same results so I deactivate ALL my plugins: Still not working.

    Edition: A bit of light to this mystery.

    When I try to access http://emigrando.info/blog, the request is being rendered by archive.php instead of single.php, index.php and any other file that makes more sense to me.

    The main blog should be rendered by which template file? index.php, single.php, archive.php or… ?

    Avatar of Wcastillo
    Wcastillo
    Participant

    @wcastillo

    Ok… I took a look at BP sites were this blog link works… For instance: http://grungepress.com/

    The main difference I saw is that its categories looks like:

    http://grungepress.com/blog/category/tour-dates/

    http://grungepress.com/blog/category/music-news/

    …while mine looks like:

    http://emigrando.info/general

    … so my WP is asumming http://emigrando.info/$ as a category… that\’s why it rendered /blog with archive.php

    Given all these… I changed my permalink structure from /%category%/%postname%/ (my favorite!!!) to /cat/%category%/%postname%/ and I set the category base slug to cat

    Now, when I try to access http://emigrando.info/blog I finally see my testing posts… BUT the title still shows Nothing found for Blog

    Holy smokes!!!

    1) How do I keep my favorite permalink structure?

    2) Why it shows \”Nothing Found\” in the title… even when it got 2 posts?

    3) If I cannot use /cat/postname permalink structure anymore… which one should be used instead?

    Edition:

    Well…I made ANOTHER workaround… :( I would really like to know to really solve this issue:

    I changed my permalink structure to:

    /-/%category%/%postname%/ (I added an ugly dash at the beginning)

    And I changed my category base to -

    The only remaining problem with this workaround is with the title: It shows “Nothing found” even when it found 2 posts… It should be an error/bug in the bp_page_title() function.

Viewing 15 replies - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.