Skip to:
Content
Pages
Categories
Search
Top
Bottom

Blogs can't be created once BP is installed

  • Avatar of e_mcpartlin
    e_mcpartlin
    Participant

    @e_mcpartlin

    Essentially my problem is this:

    MU works fine before BP is installed.

    Once BP is installed, I can create blogs from the MU backend, but I get the message:

    “The blog you have requested is not installed properly. Please contact the system administrator.”

    …when I try to visit them. I’m sure BP is the source of the issue because WPMU works fine before the BP install. Once I remove BP, the functionality returns to normal.

    Is this an issue someone has a fix for?

    Thanks!

    I searched this topic and found this thread:

    http://buddypress.org/forums/topic/users-cant-add-additional-blogs

    But there were no real answers in there.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    http://buddypress.org/forums/topic/when-asking-for-support

    At the very least your WPMU version and BP version, VHOST=yes/no?

    Avatar of e_mcpartlin
    e_mcpartlin
    Participant

    @e_mcpartlin

    Of course – thanks :)

    1. Which version of WP/MU are you running?

    2.9.1.1

    2. Did you install WP/MU as a directory or subdomain install?

    directory

    3. If a directory install, is it in root or in a subdirectory?

    root

    4. Did you upgraded from a previous version of WP/MU? If so, from which version?

    no

    5. Was WP/MU functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.

    yes

    6. Which version of BP are you running?

    1.2

    7. Did you upgraded from a previous version of BP? If so, from which version?

    no

    8. Do you have any plugins other than BuddyPress installed and activated?

    no

    9. Are you using the standard BuddyPress themes or customized themes?

    standard

    10. Have you modified the core files in any way?

    no

    11. Do you have any custom functions in bp-custom.php?

    no

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?

    13. Please provide a list of any errors in your server’s log files.

    14. Which company provides your hosting?

    1and1 dedicated server

    Avatar of e_mcpartlin
    e_mcpartlin
    Participant

    @e_mcpartlin

    And I don’t know the answer to the vhost question….

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    “MU works fine before BP is installed.”

    Did you try creating a blog before adding BP? vhost means what kind fo blogs did you set up, subdomains or subfolders?

    Avatar of e_mcpartlin
    e_mcpartlin
    Participant

    @e_mcpartlin

    “Did you try creating a blog before adding BP? vhost means what kind fo blogs did you set up, subdomains or subfolders? “

    Yes I sure did. They worked beautifully, same story once I remove BP.

    Regarding this:

    http://trac.buddypress.org/ticket/1947

    I’m not sure my problem is exactly the same – I can create blogs by outside users that work fine. Only when I create them from the WPMU backend does the problem arise.

    It’s all here by the way:

    switchsoftware.ca

    Thanks Guys!

    Avatar of blgdra
    blgdra
    Participant

    @blogadera

    Have both, MU subdirectories and subdomains, where this is happening. Can create from user side but not from backend when BP is activated. When bp is not activated mu can create blogs just fine.

    From admin go to Blogs>> Edit >> see this in the Blog Options (wp_13_options)

    Warning: Invalid argument supplied for foreach() in …/wp-admin/wpmu-blogs.php on line 149

    Avatar of pressography
    Pressography
    Participant

    @pressography

    I’m also having this problem. I can add a new blog from the 2.9.1.1 WPMU admin area w/o BP 1.2 activated and it works. But when I try adding one from the admin area w/ BP activated site-wide, I get no errors, but it doesn’t add the DB tables, and I get the “The blog you have requested is not installed properly. Please contact the system administrator.” error.

    Any thoughts where I could start looking for the problem in the code? If I had a starting point, I could try to find the problem and post a trac ticket

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    This has been fixed in the latest branch code and will be in 1.2.1 very soon.

    Avatar of e_mcpartlin
    e_mcpartlin
    Participant

    @e_mcpartlin

    Great thanks – looking forward to it!

    Avatar of pressography
    Pressography
    Participant

    @pressography

    Fantastic – thanks Andy! You & the BP team rock!

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.