Skip to:
Content
Pages
Categories
Search
Top
Bottom

BP 1.1 Smooth Installation

  • Avatar of FirstResponderBlogs.com
    FirstResponderBlogs.com
    Participant

    @firstresponderblogsdotcom

    Alrighty… after several bumps in the road… I got it up and running…. I am going to lay it out step-by-step and hopefully this should help some others out…

    -Download the latest WPMU 2.8.4a and BP 1.1 Release

    -Upload WPMU to the root of your site

    -Check full functionality and esure proper installation of WPMU

    -Upload the buddypress folder and all it contains to /wp-content/plugins/buddypress/

    -Activate BuddyPress in the “Plugins” admin panel using the “Activate Site Wide”. NOTE: You may encounter a “fatal error” message after the page reloads. This is expected.

    -Move the following:

    /wp-content/plugins/buddypress/bp-themes/bp-sn-parent

    to

    /wp-content/themes/

    -Move the following:

    /wp-content/plugins/buddypress/bp-themes/bp-default

    to

    /wp-content/themes/

    -Login to Dashboard as admin and access the following: Site Admin > Themes

    -Activate “BuddyPress Default” site-wide. Ensure “BuddyPress Social Network Parent Theme” is not activated site-wide.

    -Goto Appearance > Themes and activate “BuddyPress Default 1.1 by BuddyPress.org” as your sites default theme.

    Once complete, you should be operational. I think I may have deactivated and reactivated once after to ensure all worked well.

    Obviously, as stated by the authors, the theme structure has been changed. As such, you will find some issues with themes.

    If you have a blog that belongs to a user, and a visitor who is not logged in visits the blog and decides to “register”, you will need to make the following changes to wp-signup.php to redirect the yourdomain.com/register :

    Find:

    if( $current_blog->domain . $current_blog->path != $current_site->domain . $current_site->path ) {

    wp_redirect( “http://” . $current_site->domain . $current_site->path . “wp-signup.php );

    die();

    }

    Replace:

    if( $current_blog->domain . $current_blog->path != $current_site->domain . $current_site->path ) {

    wp_redirect( “http://” . $current_site->domain . $current_site->path . “register” );

    die();

    }

    This should resolve the redirection issue.

    I hope this assists some of you.

    If you could do me a favor in your spare time, please visit my site http://www.FirstResponderBlogs.com and poke around. Please notify me of errors, if any, you encounter while visiting the site. – admin@firstresponderblogs.com

    Thanks in advance!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of idaho_birddog
    idaho_birddog
    Member

    @idaho_birddog

    Thanks, this seems to work so far. I had been searching for quite a few hours trying to figure out how to avoid the red text that said my current theme did not support bp. All the searches I had read before said not to move bp-themes/ to wp-content/themes and instead to place

    move bp-themes/ directly in wp-content/

    Was I just reading all those earlier posts incorrectly? Glad I finally found this post. Thanks.

    BD

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    You will not need to move any themes with 2.9 and 1.2. This should greatly simplify the installation.

    The bp-themes folder was where themes had to live in BP 1.0.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.