Skip to:
Content
Pages
Categories
Search
Top
Bottom

BP Album+ Error

  • I am currently testing plugins for a BuddyPress site I am designing and would love to use BP-Album… but I’ve already run into an error from uploading my first photo! This is the stable version that is available at wordpress.org. I am not much of a coder, but am not afraid to give it a shot to fix minor problems.

    I uploaded the photo and went to view it in my album. The image shows just fine, but I get an error message below it where I assume people may be able to comment (but there are no comment options):

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘bp_activity_make_nofollow_filter’ was given in /home/swinsea/swinsea.com/wp-test/wp-includes/plugin.php on line 166

    Edit picture Delete picture

    Fatal error: Call to undefined function bp_has_activities() in /home/swinsea/swinsea.com/wp-test/wp-content/plugins/bp-album/includes/bp-album-templatetags.php on line 443

    The link, in case you need it: http://www.swinsea.com/wp-test/members/admin/album/picture/1/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of foxly
    foxly
    Participant

    @foxly

    @swinsea

    Enable the the “Activity Stream” in the buddypress admin screen, and try again.

    If that doesn’t work, you have corrupted files somewhere in your installation and/or plugin conflicts. The easiest way to fix that is to delete your entire site and database, re-install wordpress, re-install buddypress, and re-install BP-Media but NO other plugins.

    Then test if you can get the same error again.

    Thanks!

    ^F^

    Avatar of spanakorizo
    spanakorizo
    Member

    @spanakorizo

    hello foxly i have exactly the same problem with post activity off in bp and as u said if i enable it the problem goes off. but i dont want to use bp activities at all!i have bp-album version 0.1.8.
    i tested 0.1.9 and the problem goes away, but i couldn’t change some settings (googlemap location,creative commonts and the 3rd..)
    Can u please advice me how to fix this error in 0.1.8 and keep activity stream off? (both in bp-media and bp)

    thank u for this Excellent plugin :) 0.1.9 looks good!!

    Avatar of foxly
    foxly
    Participant

    @foxly

    @spanakorizo

    Version 0.1.8 should work with the activity stream disabled. If it doesn’t, and you really don’t want the activity stream to be visible, *enable* it in BuddyPress, but then go into the various activity stream template files and put all the code between ‘/* */’ characters.

    Don’t use 0.1.9 for a site. The data model is still under development, and you could lose data when we finalize it. Did you see the warning on the admin screen? … ;)

    ^F^

    Avatar of MsShadiggy
    MsShadiggy
    Member

    @msshadiggy

    I too am having this error message come up. I don’t want to enable the activity stream on my installation, but that is the only way I can get this to work. I also went into the different activity stream php files and added the ‘/* */’ but that only kept the activity stream and gave me the message that “No activity was found.”

    Do you have any other suggestions?

    Avatar of foxly
    foxly
    Participant

    @foxly

    @MsShadiggy

    Well, in that case my suggestion would be to check back here in an hour or so, to give me a chance to go into the plugin’s source code and fix the problem. :)

    ^F^

    Avatar of foxly
    foxly
    Participant

    @foxly

    @MsShadiggy

    We’ve found the defect that was causing the problem, and we’ve fixed it.

    I need to update a few things for our translation team before I upload it to our site. It will be posted as version 0.1.8.6, download it here:

    http://code.google.com/p/buddypress-media/downloads/list

    ^F^

    Avatar of foxly
    foxly
    Participant

    @foxly

    @MsShadiggy

    Updated version has been posted.

    ^F^

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.