Skip to:
Content
Pages
Categories
Search
Top
Bottom

BP Album Menu Tabs missing

  • Avatar of wedstudio
    wedstudio
    Member

    @wedstudio

    Hello, I am testing the BP Album plugin and noticed that when you click on the album tab the rest of the menu tabs (Activity, Profile, Messages etc) disappear and there are only text links. You can see an example here: http://wedstudio.ca/Test/members/ws/album/

    Does anyone know why this is happening and how I can correct it?

    any help would be greatly appreciated

    Thank you

Viewing 14 replies - 1 through 14 (of 14 total)
  • Avatar of A Weathers
    A Weathers
    Participant

    @aweathers

    I’m having the same issue and using the same theme. Looks like the the div class for the menu should be
    class=”item-list-tabs no-ajax bp-content-tabs” but it’s missing the “bp-content-tabs” portion. I’m looking through the plugin files now to see how/where to set it, but i have not found it yet

    any help would be great

    Avatar of A Weathers
    A Weathers
    Participant

    @aweathers

    think that I found it go to
    wp-content/plugins/bp-album/includes/templates/album/single.php and add “bp-content-tabs” to class=”item-list-tabs no-ajax” on lines 11 and 21, so it should be class=”item-list-tabs no-ajax bp-content-tabs” after your changes

    Avatar of A Weathers
    A Weathers
    Participant

    @aweathers

    actually, there are more files in that dir that need changing as well

    Avatar of wedstudio
    wedstudio
    Member

    @wedstudio

    Hello A Weathers, thanks for the info. Were you able to correct it? I’m still not having any luck.

    Avatar of Karalius
    Karalius
    Participant

    @karalius

    same here
    any help from TEAM?

    Avatar of foxly
    foxly
    Participant

    @foxly

    @Karalius

    Are you getting the same problem on a different server? Are you using the current version of BP-Album, WordPress, and BuddyPress?

    ^F^

    Avatar of pmcreations
    pmcreations
    Participant

    @pmcreations

    Let me know when this plug in is ready for use. I am having the same problem with disappearing menu tabs.

    Avatar of foxly
    foxly
    Participant

    @foxly

    @pmcreations

    We need you to post a link to the site where we can *SEE* the problem happening before we can fix it. This problem doesn’t happen on any of our team’s test systems.

    ^F^

    Avatar of BradleyCapitol
    BradleyCapitol
    Member

    @bradleycapitol

    http://rideagogo.com/site/members-3/Tanner/album/ does the same thing. It appears to only be happening with the Salutation theme from ThemeForest. @foxly, what do you suspect we should to fix the problem? Everything else works flawlessly with BuddyPress when using Salutation except for BP Media!

    Avatar of foxly
    foxly
    Participant

    @foxly

    @BradleyCapitol

    We’re investigating.

    At this point: 80% odds the theme you’re using hasn’t been updated for BP 1.5 (in which case there isn’t much we can do to help. 20% odds it’s this new defect another user has found: http://buddypress.org/community/groups/bp-album/forum/topic/bp-doesnt-work-with-wordpress-3-3/?#post-121910

    ^F^

    Avatar of BradleyCapitol
    BradleyCapitol
    Member

    @bradleycapitol

    The theme says it is updated for 1.5 and all the users are reporting basically the same thing. If needed I will be glad to offer a cpanel backup of the system so you can test it on a test system!

    Avatar of BradleyCapitol
    BradleyCapitol
    Member

    @bradleycapitol

    @foxly I got it fixed! I took a look at the plugin code vs the theme code and found a slightly different syntax. For those using the same theme, here’s what you need to!

    1. Navigate to the plugin directory.
    2. Find the bp-album folder.
    3. Navigate to includes/templates/album .
    4. Go through the four PHP pages and find
    `

    `
    5. Change to `
    `
    Avatar of Karalius
    Karalius
    Participant

    @karalius

    wow, it’s not total same looking like in Activity, Groups etc., but it is working! Thank you, Bradley!

    Avatar of BradleyCapitol
    BradleyCapitol
    Member

    @bradleycapitol

    Yeah, it’s not in the exact same order but I believe that’s normal for this version of the plugin! Glad I could help!

    Cheers

Viewing 14 replies - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.