Skip to:
Content
Pages
Categories
Search
Top
Bottom

BP Avatars in bbPress

  • Avatar of Gogoplata
    gogoplata
    Participant

    @gogoplata

    Is it possible to display the avatars uploaded in BuddyPress in bbPress (integrated with WPMU, but not using bp-forums)? If so, how?

    TIA

Viewing 25 replies - 51 through 75 (of 76 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Remind me again what isn’t happening when you do bbGroups import all. I’m getting sidetracked by details.

    The *all* users option doesn’t work? You can see what the params to the xmlrpc method call by changing $client->debug = false; to true in oci_bb_xmlrpc_query(). Then in the fn oci_bp_group_forums_import() there is a debug line under the query call. Change that to just die();

    Both of those fns are in oci_bb_group_forums.php on the bbpress side.

    What you’ll see are the params to the method call: username, password and ‘1’ for all users. Underneath it will display the xml result that you get back. One long string with all the groups and user data in xml format.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Neither option imports when using 3.0. Import all nor groups. When I click on “Import Groups” the browser thinks, then just refreshes the screen with no feedback, errors, anything…

    If I do your above debug, I seem to get a good response…

    POST /xmlrpc.php HTTP/1.0

    Host: delsolownersclub.com

    Content-Type: text/xml

    User-Agent: The Incutio XML-RPC PHP Library — bbgroupforums /0.2

    Content-length: 284

    <?xml version=”1.0″?>

    <methodCall>

    <methodName>bp.ociGetAllGroups</methodName>

    <params>

    <param><value><array><data>

    <value><string>dsoc</string></value>

    <value><string>{accurate password}</string></value>

    <value><int>0</int></value>

    </data></array></value></param>

    </params></methodCall>

    <?xml version=”1.0″?><methodResponse> A WHOLE TON OF STUFF </params></methodResponse>

    What happens though is that your plugin doesn’t display any success or fail message, and for statistics, it tells me…

    Groups with forums enabled – , Forums updated – , Users updated -

    I get the feeling I need to flush all of the previous bbGroups info out of the DB and start fresh…

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Okay, so I dipped into phpMyAdmin and deleted ALL bbpress live info, all bbGroups info, and uninstalled all of the plugins completely to get back to 0.

    I installed all of the plug ins. Confirmed that BuddyPress could see the bbPress forums. Created a topic, verified on both sides that it was updating. All successful communication from both directions.

    Then, I installed 3.0 of the bbGroups plugin. All of the previous stuff that was working, still works.

    bbGroups .3 still will not import any group data.

    Reverted back to .24, clicked import. Success with no other modifications other than replacing the 3 plug in files.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Okay, if I do it with the all members checked and with your debug and die method, I get an out of memory error every time.

    POST /xmlrpc.php HTTP/1.0
    Host: delsolownersclub.com
    Content-Type: text/xml
    User-Agent: The Incutio XML-RPC PHP Library -- bbgroupforums /0.2
    Content-length: 284

    <?xml version="1.0"?>
    <methodCall>
    <methodName>bp.ociGetAllGroups</methodName>
    <params>
    <param><value><array><data>
    <value><string>dsoc</string></value>
    <value><string>{valid pw}</string></value>
    <value><int>1</int></value>
    </data></array></value></param>
    </params></methodCall>

    <b>Fatal error</b>: Out of memory (allocated 31719424) (tried to allocate 1645602 bytes) in <b>/homepages/8/d149961498/htdocs/delsolownersclub/wp-includes/class-IXR.php</b> on line <b>107</b>

    AH ha!


    oci_bp_groups_forums.php – line 340

    if I comment out…

    add_filter('oci_get_user','oci_get_xprofile_filter',10,1);

    And run the group import tool for Groups only, it works exactly like it should (without any xprofile info of course :/ )

    If I run it for all users, I no longer get an out of memory error, but it does come back and give me a parse error.

    I consider that progress. The connection is definitely good. They’re talking back and forth. I must just have some gummed up user info that’s messing with the parsing of the XML return? Does that make sense?

    I do have 3 pages of xprofile info per user for it to import, so I mean there is the potential for there to be alot of info back and forth.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    I basically started going through what changes were made to your plugin since it last worked, and started replacing code block by block. Once I could debug the XML request, it gave me some eyes in the back of my head so to speak, to watch what I couldn’t otherwise see.

    So basically, it sounds like there is something in the xprofile field, and/or something in some users meta info that the XML parser just doesn’t like, so it gets caught up and returns a crappy value? Is that a good guess? You think it’s time to just rip through the user meta and see if anything looks suspicious?

    Here’s a question. What if there are users that haven’t yet updated their profiles in BuddyPress? They were converts from a wordpress.org install, and if they haven’t returned since then, BuddyPress doesn’t have a “fullname” for them yet, and they also don’t have xprofile info. Could that break this somehow? Is there a way to watch this user by user and have it spit out an error when it finds a bad value?

    Also, just for the record. I’m using BuddyPress RC1, bbPress Alpha6, and WPMU2.7. Is it possible there was a trunk update that you’re using that I’m not that maybe gives you different results than me?


    More specifically, if I comment out line 335 in oci_bp_groups_forums.php…

    //$user['xprofile_' . $group->name . '_' . $field_obj->name] = array('group' => $group->name, 'name' => $field_obj->name, 'value' => $field_obj->data->value, 'type' => $field_obj->type);

    And run the group import, it works without error as well.

    If I put a switch on the $field_obj-> name…

    switch ($field_obj->name) {

    …and only retrieve the custom title and forum signature, the groups import also works (still not for all users though, only groups.) I think it may be tripping over a specific type of field. I’m going to guess the textarea field, but that’s totally a blind guess with no merit or motive what-so-ever. :)

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Hi John, that spot is where all the xprofile group and fields for each group get stuffed into an array for transport. If some of the data is extremely large for some reason it could give you memory problems.

    I’ve asked a couple of other people to give 0.31 a try. I don’t know what to tell ya guy. I’m using all the above when it comes to software versions you listed.

    I usually run the latest svn trunk but I don’t think that could be the cause of the problem.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Burt have you tested this with each specific type of field in the xprofile area? With quotes and what not?

    I’m going to make a clean install of BuddyPress on my test domain and see if I can duplicate this. I’d really like to know what I did that’s breaking it.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Nope. That might be the issue. I’ll look at all the different field types and see what could go wrong. Thanks John. Good idea.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    No sweat. I ask because lets say I make a “Signature” field, it’s a textarea, and it’s going to be used for their forum signature.

    If their signature is "<a href="bob" style='color: red;'>Bob</a>, is amazing!" is BuddyPress going to parse the crap out of it, and is this going to understand that?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    I think you’ll have to unhook some filter mechanisms for html fields. Maybe. While I’m looking at the field types and the import mechanism I’ll look at that too.

    Avatar of Bobman024
    bobman024
    Participant

    @bobman024

    Hey Burtadsit….I can’t seem to get this plugin to activate. Any reasons why that would happen. Everything is set up properly and I can activate all other plugins…

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    bobman024, I’m kinda lost here. What plugin are we talking about? bpGroups? Download the latest at: http://code.ourcommoninterest.org/2009/02/14/buddypress-group-forums-for-bbpress/

    I just downloaded that ver and set it up again. Activates and operates.

    Avatar of Bobman024
    bobman024
    Participant

    @bobman024

    Thanks Burtadsit!

    Yeah so I had that current version of the plugin and am still having errors. Any reason why this would not activate in BBpress? Is there something it checks for? I have been having other issues with my forums, but I still cant see a reason why it wouldn’t activate!

    Avatar of Bobman024
    bobman024
    Participant

    @bobman024

    Ok update. I finally got an error!

    Fatal error: Cannot redeclare class ixr_value in /var/www/forums/bb-includes/backpress/class.ixr.php on line 24

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    You’re using deep integration aren’t you… :)

    Avatar of Bobman024
    bobman024
    Participant

    @bobman024

    Yeah I have to for my theme…Am I not supposed to do that? :)

    Ok so I guess the next question is, can I do something to fix it?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    The bpGroups plugin doesn’t support deep integration. It wasn’t designed with that in mind. jjj has developed a work around to get things running.

    Avatar of Bobman024
    bobman024
    Participant

    @bobman024

    Ok thanks. So now I have JJJ’s workaround and I was able to activate the plugin.

    There is clearly something wrong with my xmlrpc. I am unable to bring over any data and so this goes back to the fact that my forums won’t sync. When I go to my XMLRPC page(http://phoenix.fanster.com/xmlrpc.php) I am getting this error:

    XML-RPC server accepts POST requests only.

    Any ideas? Thanks for your help!

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Bob… Man… I’ll be happy to take a better look at this with you tomorrow in more detail… This is one of difficult demons to track down, as deep integration does introduce a WHOLE lot more functions into play than either program really plans for…

    It’s possible to do, but there’s a few steps I’ll need to walk you through that I don’t have the time for at this moment. But, we should be able to get it working.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    bobman024, the xmlrpc.php file can’t be used like you are trying. Not sure why you are. It just has to be there for use by the xmlrpc function call protocol.

    Avatar of Bobman024
    bobman024
    Participant

    @bobman024

    I just wanted to confirm that it was working properly that was all…As long as that message is correct, I am fine with it…Just trying to get my xmlrpc working!

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Bob… Man… Sorry to leave you hanging, I haven’t forgotten about you, but life and work are stopping me from helping you AND playing with the new BP site…

    I’ll try and find some time this evening hopefully…

    Was there any fix to this? I went to the plugin page, and it requires an older version of BP. Is there any way to do what the title says (have BP avatars show up for the users in bbpress) without having to do a bunch of other group stuff?

    Ideally, I’d like something that simply shows the user’s BP avatar, and also changes the link to their bbpress profile to have it go to their BP profile if they have one.

    I’m having the same issue. I have BP and bbpress integrated. In bbpress, the forum poster currently displays the link to the BP profile. This is good. However, I also want to show the poster’s BP avatar as well, just as it is showing in this forum. How is this done?

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Hey guys, I’m in the same boat as tommylbc, Jrtlm and bobman024.

    John, are you currently using the latest version of Burt’s bpGroups v0.36?

    I’m also using deep integration, so I am wondering what steps you are using to make BP avatars work in bbPress.

Viewing 25 replies - 51 through 75 (of 76 total)

The topic ‘BP Avatars in bbPress’ is closed to new replies.