Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] BP default theme deleted?

  • Avatar of JLent.
    JLent.
    Participant

    @jloc14

    Hello,

    Im using the current version of BP and I’m still learning how to use Child Themes. In a video on youtube it said to go into my Filezilla and delete the BP default theme and create a new Child Theme. I deleted the BP default but I still dont know what is going on how can I get that folder back so I can start over? Thanks in advance.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Why on earth would anything say delete bp-default!!?? I would disregard that video and refer to the official docs here only.

    Download a fresh copy of BP to get back bp-default.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    and link to the video please so it can be checked for accuracy.

    Avatar of JLent.
    JLent.
    Participant

    @jloc14

    Ya thats what I was thinking, here is the link to the video: http://www.youtube.com/watch?v=HrS33H2kMso

    I just updated BP would that put the folder back in? I’ve just made a style.css and in the themes section my child theme doesnt show up it says:

    bp-child theme: The parent theme is missing. Please install the “BuddyPress Default” parent theme

    bp-default: template missing

    Avatar of JLent.
    JLent.
    Participant

    @jloc14

    Does that mean the folder still isnt there? should I deactivate BP Default theme then reactivate?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @jloc14 Delete BuddyPress plugin. Then re-install BuddyPress plugin. Upload your child theme folder in wp-content/themes/ folder.

    P.S. A child theme needs a parent theme, in this case the BuddyPress Default theme. Please do not delete it again.

    Avatar of JLent.
    JLent.
    Participant

    @jloc14

    Ok. I deleted the buddypress plugin and my site is white and my header, background, footer, and login in gone. I made a zip file backup on my desktop but I cant seem to restore it to the original state. I went into my hosting and restored it from yesterday but it didnt do anything what should I do? Thank you.

    Avatar of JLent.
    JLent.
    Participant

    @jloc14

    Correction, I deleted BP and then reuploaded it. @mercime

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @jloc14 so do you see the bp-default theme folder in server now? If so, you’re good to go

    Avatar of JLent.
    JLent.
    Participant

    @jloc14

    @mercime I see the bp-default in my server with a favicon.co and style.css folder. That is all. When viewing my site my banner, footer, background, and side bar login-registration page is gone and my site is white. I made a backup before I did this but it is not uploading to my public_html folder. Everything I had originally is gone.

    Avatar of JLent.
    JLent.
    Participant

    @jloc14

    @mercime Please excuse me as my mind was all over the place and my problem was I didnt reactivate the BP default theme haha! Thank you for your help.

    Avatar of JLent.
    JLent.
    Participant

    @jloc14

    @mercime but my footer only shows in Chrome and not other browsers?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @jloc14 just to be clear, you should have these files https://buddypress.trac.wordpress.org/browser/tags/1.8/bp-themes/bp-default inside the bp-default theme folder in your server. If you don’t see all those folders and files, then re-upload BuddyPress manually, i.e., via s/FTP.

    If you have child theme of the BP Default theme, then you should activate the child theme, not the BP Default theme.

    Avatar of JLent.
    JLent.
    Participant

    @jloc14

    Ok. My widgets arent there and I deleted them and then replaced them and saved them but I’ll figure it out. Thank you!

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.