Skip to:
Content
Pages
Categories
Search
Top
Bottom

BP MEDIA 0.1.9 IS READY FOR ALPHA TESTING

  • Avatar of francescolaffi
    francescolaffi
    Participant

    @francescolaffi

    @francescolaffi and @foxly have finished their latest code merge, bringing Audio, Video, and Embedded Media functionality to BP Media.

    You can download the latest nightly build, located here:

    https://code.google.com/p/buddypress-media/downloads/detail?name=bp-album-2010-08-08.zip

    Some of the key features include:

    - Multimedia support: Local Images and Local Audio Streaming. Video Streaming planned for future versions

    - Embedded Content Support: by default it has two photo embed modules (flickr, smugmug) and several video embed modules (YouTube, Vimeo, Blip.tv, qik, etv…. )

    - Add files by url: if you post a URL that refers to an oEmbed enabled website the media will automatically be embedded. If the URL is a direct link to a media file, the file will be downloaded by the server and locally stored for displaying

    -Media validation: support for different media type means having to recognize and validate each media file format. Unfortunately, there’s no easy way to do this in every environment. It currently uses Fileinfo extension (php >= 5.3), shell command ‘file -bi’ (only on unix, shell access needs to be permitted), or a built-in magic numbers table.

    You are welcome to test this version and give your feedback, please remember to test on a fresh install.

    How to give helpful feedback:

    1) Focus the testing on new features: can you embed youtube video? do they have a preview image in the gallery? can you upload and listen mp3? do media title and description represent mp3 tags? if mp3 had an attached image is it used as preview image in the gallery?

    2) see if something that was working in the last nightly has been broken in the code merge

    3) if you find a issue/bug about something that is supposed to working (it was working before or I described it in the intro) open an issue in the issue tracker https://code.google.com/p/buddypress-media/issues/list

    4) if you have some problems with content type detection (media recognition) tell every possible detail about your test enviroment. also look in ‘File Settings’>’Adding Media’>’Media validation’ and tell which detection method are grayed out and which you can select.

    5) known issue: depending on the your browser some features of the audio player (i.e. volume slider) could be cut out, that will be addressed in the release version

    6) known issue: some mp3s with bad headers could not be validated and are rejected, there are many mp3 tools that put random garbage in files, I’ll work on a more loose but still secure validation for mp3. Try with several mp3s and the most of them should be accepted.

    7) edit – known issue: warnings on activation, will be addressed in rewriting of plugin installation/upgrade routines

    Thanks
    Francesco & Foxly

Viewing 25 replies - 1 through 25 (of 48 total)
  • Avatar of alanchrishughes
    alanchrishughes
    Participant

    @alanchrishughes

    Warning: array_filter() expects parameter 1 to be array, null given in C:xampphtdocsphotographywp-contentpluginsbp-albumincludesmultimediaBPM_Multimedia.php on line 202

    Warning: array_keys() expects parameter 1 to be array, null given in C:xampphtdocsphotographywp-contentpluginsbp-albumincludesmultimediaBPM_Multimedia.php on line 202

    Warning: array_intersect() [function.array-intersect]: Argument #2 is not an array in C:xampphtdocsphotographywp-contentpluginsbp-albumincludesmultimediaBPM_Multimedia.php on line 97

    Warning: Invalid argument supplied for foreach() in C:xampphtdocsphotographywp-contentpluginsbp-albumincludesmultimediaBPM_Multimedia.php on line 99

    Avatar of Bowe
    Bowe
    Participant

    @bowromir

    Awesome stuff @francescolaffi! Here’s some things I stumbled upon on my 2 test installs (one local, one hosted)

    - After activating I get the same warning messages as Alan posted above.
    - When I try to upload any media with the flash or standard uploader I get the following error:

    “Fatal error: Call to undefined method BPM_MediaModule_Picture::get_content_types_extensions_map() in /Bowromir/webserver/server/wp-content/plugins/bp-album/includes/media-modules/BPM_MediaModule_Picture.php on line 32″

    I’ve checked the settings in the plugin and currently they are set on:

    > this shell command (use ‘%s’ as filepath):

    the only other option I can choose is the built in selector, but that still gives me the same error.

    On my live site I simply get a blank page after trying to upload anything..

    Media embedding through youtube works great, altough it would be nice if you could build in some kind of visual confirmation when any embedded video is found (with an AJAX call and a confirmation message: “this URL contains a video, click on “Submit” to fill in more details”.)

    I’m using the latest version of BuddyPress and WP 3.0.1 on a local XAMP (apache) server.

    Hope this helps, I’ll keep on trying stuff :)

    Avatar of francescolaffi
    francescolaffi
    Participant

    @francescolaffi

    @alanchrishughes thanks for the report, I didn’t notice the warnings in the log. btw they are harmless and will be addressed when rewriting the installation part

    @bowromir thanks you for all the details, have you tried with mp3 too?

    Avatar of Bowe
    Bowe
    Participant

    @bowromir

    I’ve tried MP3 as well and local media upload works.. I do get the following warning though:

    Warning: Division by zero in /Bowromir/webserver/server/wp-content/plugins/bp-album2/includes/media/sub-media-cache.php on line 203

    If I try to add remote media by putting in a URL I get this:

    There were problems saving picture details.

    Think the problem lies somewhere in the media detection?

    Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    Support mobypicture.com for Distributing media via Mobypicture mobile then to BP media.
    Here’s the api: postMedia
    http://developers.mobypicture.com/documentation/1-0/postmedia/

    A user on twitter mobile app can upload to mobypicture then it gets posted to BP media via mobypicture api!

    Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    Problem activating plugin error msg: Warning: array_filter() [function.array-filter]: The first argument should be an array in C:public_htmlwordpresswp-contentpluginsbp-albumincludesmultimediaBPM_Multimedia.php on line 202

    Warning: array_keys() [function.array-keys]: The first argument should be an array in C:public_htmlwordpresswp-contentpluginsbp-albumincludesmultimediaBPM_Multimedia.php on line 202

    Warning: array_intersect() [function.array-intersect]: Argument #2 is not an array in C:public_htmlwordpresswp-contentpluginsbp-…………………………………..

    Avatar of francescolaffi
    francescolaffi
    Participant

    @francescolaffi

    @bowromir could you give us the url of the fle that rise the error? thanks

    @gpo1 dosn’t look like something that will go in the plugin core, but anyway here it’s not the right place, you can open a feature request in the issue tracker.

    Avatar of thekmen
    thekmen
    Participant

    @thekmen

    @francescolaffi I get the same errors on installation.
    The fix on https://code.google.com/p/buddypress-media/source/detail?r=61 did fix not being able to upload Images but I now get
    Fatal error: Call to undefined method BP_Album_Cache::getresizeargs() in …/bp-album/includes/activity/sub-activity-class-multipost.php on line 79 on the activity stream after adding images to the new album.
    Also, after deleting the album, …user posted new photos in album…. is still displayed in activy stream.

    Avatar of Bowe
    Bowe
    Participant

    @bowromir

    Hi @francescolaffi and @foxly,

    First of all: great stuff, thanks!!

    Question: youtube embeds aren’t recorded in the member’s activity? (I’m using the 8-8 nightly)

    Also, when I try to upload an image I get this error: Fatal error: Call to undefined method BPM_MediaModule_Picture::get_content_types_extensions_map()

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    Errors galore.

    Avatar of foxly
    foxly
    Participant

    @foxly

    @modemlooper

    Twitter user? … lol

    Yes, its full of errors. But its much faster to “crowd source” finding them all and have the two developers spend their time fixing them all. That lets us get the job done a week or two faster.

    Thanks!

    ^F^

    Avatar of Builder
    Builder
    Participant

    @bpuser44

    Foxly and Francesco thank you guys the rewritten plugin is really an important addition to BP.

    I will be most happy once galleries for groups are implemented as I want to keep a group or two only for accepted payed members which involves also the galleries’ images only for these members.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    @foxly I hear you. I activated and it was a christmas tree of errors. I’ll re-check and post some.

    Avatar of thekmen
    thekmen
    Participant

    @thekmen

    anyone else getting the BP_Album_Cache::getresizeargs() errors on activity stream with bp-album-2010-08-08.zip? Just wondering if it’s due to a previous install on my part that I can fix or a plugin error?

    Avatar of francescolaffi
    francescolaffi
    Participant

    @francescolaffi

    @thekmen I haven’t verified but if I remember well I refactored that method before that release so it’s likely a plugin error (and probably my bad;))
    We’ll check it and the other errors soon, thanks all for the reports :)

    Avatar of thekmen
    thekmen
    Participant

    @thekmen

    thanks @francescolaffi, any help appreciated in fixing this. Thought I had dropped all db tables & settings but could have missed something.

    Avatar of alanchrishughes
    alanchrishughes
    Participant

    @alanchrishughes

    another random problem I’ve noticed that nobody has pointed out and is some what trivial, but the upload page generates this god awful footer.

    Avatar of Anton
    Anton
    Participant

    @antonrsa

    @francescolaffi – I’m getting this error when I try to activate the plugin – Fatal error: Call to undefined method ReflectionClass::getInterfaceNames()…..

    Avatar of thekmen
    thekmen
    Participant

    @thekmen

    @francescolaffi just checked out latest SVN and still have the same activity stream error, any idea yet if it’s my install or a known issue?

    Avatar of francescolaffi
    francescolaffi
    Participant

    @francescolaffi

    @antonrsa it could be php version, do you have php 5?

    @thekmen mh, it should be gone. Please try again the svn trunk version, deleting the old version before. If problem is still there reopen this issues https://code.google.com/p/buddypress-media/issues/detail?id=26 and we’ll follow that specific error there

    @bowromir the problem should be fixed in the svn, could you verify? if svn is not for you I think we’ll pack another nightly soon

    Avatar of LPH2005
    LPH2005
    Participant

    @lph2005

    How soon will this plugin have the ability to upgrade the 0.17 version?

    Avatar of thekmen
    thekmen
    Participant

    @thekmen

    @francescolaffi tested and confirmed fixed, thank you.
    One other issue is that photo tags still aren’t working, no values saved. presume you are aware of this?

    Avatar of foxly
    foxly
    Participant

    @foxly

    @thekmen

    No values saved to the DB table or no values displayed? Keyword tags? Member tags? or EXIF tags?

    ^F^

    Avatar of thekmen
    thekmen
    Participant

    @thekmen

    @foxly sorry, it’s the keyword tags i’m talking about with none being saved to the DB table.

Viewing 25 replies - 1 through 25 (of 48 total)

You must be logged in to reply to this topic.