Skip to:
Content
Pages
Categories
Search
Top
Bottom

BP menu and the /members/ URL

  • Avatar of bowes
    bowes
    Participant

    @bowes

    Hi,

    I can’t seem to find a answer to this. I am trying to install BP in WP multisite and all goes well except for the BP menu. All of the links are like this:

    http://mysite.com/members/activity/

    And they generate a 404 page not found. On the default BP theme menu though, the links don’t have /members/ in the URL and they work:

    http://mysite.com/activity/

    What am I doing wrong?

    Thanks for any help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    or the BP menu. All of the links are like this: http://mysite.com/members/activity/

    WP/BP versions? Theme used? Which BP menu? Please be more specific about your intallation.

    Avatar of bowes
    bowes
    Participant

    @bowes

    @mercime Latest WP and BP, Gantry WordPress Framework and the Gantry BP plugin. The menu I’m referring to is the one at the top right corner after you log in to the BP installation.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @bowes thank you for the information. As you mentioned in your original post, the menu shows correct URL when you use the BP Default theme. Have you checked whether the theme and the Gantry theme framework and BP plugin are compatible with your WP/BP versions? Have you contacted the theme/plugin authors about this issue?

    Avatar of bowes
    bowes
    Participant

    @bowes

    I’ve trashed the site now I don’t know how many times and rebuilt. It seems to happen right away *but* I think now it’s a question of the user I’m logged in as.

    Logged in as the admin, the menu doesn’t work. Create a new user and log in as that though it does. This is true of 1.7 as well.

    As admin the links look like http://example.com/members/activity and don’t work.

    As a normal user they look like http://example.com/members/username/activity and they work.

    Is this normal? Can I confidently say this is an issue but move forward and invite people to register?

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Sounds like a problem with the Gantry BP plugin.

    Try disabling that and see if that fixes things.

Viewing 5 replies - 1 through 5 (of 5 total)

The topic ‘BP menu and the /members/ URL’ is closed to new replies.