Skip to:
Content
Pages
Categories
Search
Top
Bottom

bp_forums_setup error on activation

  • Avatar of Sclough
    sclough
    Participant

    @sclough

    I’m trying to upgrade our BuddyPress install from 1.0.3 to 1.1.2. I’ve read the docs and when I did the upgrade, I now get the following error:

    Fatal error: Cannot redeclare bp_forums_setup() (previously declared in /path_to_site/web/content/wordpress-mu/wp-content/plugins/buddypress/bp-forums.php:17) in /path_to_site/web/content/wordpress-mu/wp-content/plugins/buddypress/bp-forums.php on line 30

    I’ve disabled every other plugin and even looked at the BuddyPress code and didn’t notice a problem. Does anyone have any idea what’s causing this error?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Read the first section in this thread and see if that solves your issue:

    http://codex.buddypress.org/getting-started/upgrading-from-10x/

    Avatar of Sclough
    sclough
    Participant

    @sclough

    I re-read that page, but I don’t see anything that addressed my issue. I’ve disabled all other plugins (even though they didn’t have buddypress dependencies and I’m just trying to re-activate the plugin.

    Avatar of Sclough
    sclough
    Participant

    @sclough

    I’m really confused. I even tried the previous version of the plugin and it has the same error. I also went ahead and removed the bp-themes directory in case that was an issue. I have checked every single thing I know to (even the mu plugins directory. What could possibly cause this issue?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    The first time you upgraded BP from 1.0.3 to 1.1.2, did you manually upgrade or use the automatic upgrade feature of WordPress?

    What I would recommend is trying this:

    • Make a backup copy of your DB if you have any data worth saving
    • Make a backup copy of your bb-config.php file-assuming that you had forums integrated before
    • Deactivate all non-BP plugins
    • Deactivate BP
    • Delete the old BP files located in the /buddypress/ directory
    • Temporarily remove all plugins from /plugins/–copy them to a temp folder outside your install
    • Manually upload a fresh copy of BP 1.1.2 and move the contents of /buddypress/bp-themes/ into their proper place
    • Remove your /wp-content/bp-themes/ directory–assuming that you have moved it back into place since your last post
    • Reactivate BP
    • If no error, choose and activate the new default BP theme

    Does BuddyPress version 1.1.2 now work? If so, add back your other plugins and activate them.

    Avatar of Sclough
    sclough
    Participant

    @sclough

    I got the exact same error after those steps. I noticed that if I comment out the lines causing the error, it raises the same error on the next function…

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Which version of WPMU are you running?

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.