Skip to:
Content
Pages
Categories
Search
Top
Bottom

bp_has_activities() fatal error [RESOLVED]

  • Avatar of hozyali
    hozyali
    Member

    @hozyali

    Hello,

    I am using latest version of all applications. I recently added Album+ plugin. but when I view an image of my own or another member, it throw’s this error

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘bp_activity_make_nofollow_filter’ was given in /home/stangor/myrescueteam.com/betawebsite/wp-includes/plugin.php on line 166

    Fatal error: Call to undefined function bp_has_activities() in /home/stangor/myrescueteam.com/betawebsite/wp-content/plugins/bp-album/includes/bp-album-templatetags.php on line 403

    Can someone please advise how to fix this error?

    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of foxly
    foxly
    Participant

    @foxly

    @hozyali

    Are you using the WP 3.0 beta?

    ^F^

    Avatar of francescolaffi
    francescolaffi
    Participant

    @francescolaffi

    wow a real bug of bp-album 0.1.7 !
    It seems that bp-album need bp_activity_make_nofollow_filter also when the activity component is disabled, if you don’t want to enable the activity component then copy the function bp_activity_make_nofollow_filter from buddypress/bp-activity/bp-activity-filters.php and paste it in a bp-album file.

    Avatar of foxly
    foxly
    Participant

    @foxly

    @francescolaffi

    This is fixed in the 0.1.9 beta I sent you. I added a new class to handle all the problems/missing functionality in BP activity streams.

    ^F^

    Avatar of thekmen
    thekmen
    Participant

    @thekmen

    hI @foxly, will you be releasing this beta?

    Avatar of Milton
    Milton
    Participant

    @mlopez0529

    Hello guys, I have a bit of a problem. I received this error message: Fatal error: Class ‘BB_Query’ not found in /hermes/web01/b735/moo.mlopez0529/wp-content/plugins/buddypress/bp-forums.php on line 333 <— Can anyone tell me how to fix this? I am running
    Buddypress Version 1.2.4.1
    Buddypress Album+ Version 0.1.7
    As a side note I am also using the following plugins… Buddypress Links, BuddyPress Member Profile Stats & CD BuddyPress Avatar Bubble. I am a noob when it comes to WP and BP, let me know if any of you can help. I would really appreciate it. My site is http://www.fanzconnect.com if you want to take a look. Its a sports site

    -Milton

    Avatar of foxly
    foxly
    Participant

    @foxly

    @Milton

    The problem you are reporting is not being caused by BP Album+. Please repost your question in the Troubleshooting group, located here:

    http://buddypress.org/community/groups/how-to-and-troubleshooting/

    They will be able to help you a lot faster than we can.

    Thanks!

    ^F^

    Avatar of sebastian
    sebastian
    Participant

    @sebastian1

    @foxly
    could you also make the beta available to me?

    I am experiencing the same errors as the original poster – also with activity stream turned off.

    Are there any drawbacks to using the beta vs. 0.1.7?

    Thanks!

    Avatar of foxly
    foxly
    Participant

    @foxly

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.