Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddpress Avater Error

  • Avatar of iyke20024
    iyke20024
    Participant

    @iyke20024

    Fatal error: Call to undefined function wp_get_image_editor() in /home/iyke2002/public_html/9japeople.com/wp-content/plugins/buddypress/bp-core/bp-core-avatars.php on line 521

    Am getting this error anythime I try to change my avater. I noticed this only happens when the image is too large. How do I solve this problem. do I need to adjust the size so it can allow any size upload for croping

    I am using wordpress 3.4 and buddpress 1.6.2
    Working with the Buddyboss theme.
    My site: http://www.9japeople.com

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    BuddyPress 1.6.2 requires WordPress 3.5.

    Avatar of Curt - RI
    Curt – RI
    Participant

    @curt-ri

    Hi,

    I am having this same issue after updating WordPress to 3.5.1 and Buddypress to 1.6.1 last night.

    When trying to upload an avatar, I get this error message:

    Fatal error: Call to undefined function wp_create_thumbnail() in /home/site-name/public_html/wp-content/plugins/buddypress/bp-core/bp-core-avatars.php on line 521

    But if I use a small image (150×150) it uploads with no errors. The cropping tool did seem to be a bit out of sorts, but I got it to work by playing with it a bit.

    So it seems that it is related to image dimensions, presumably related to the cropping tool??

    Please help!

    Thanks

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    1.6.1 ?!! mentioned was the fact that 3.5 must run with 1.6.2; regardless 1.7 is now released so you ought to upgrade to that, even if not then there are three further point releases on 1.6 you ought to be up to 1.6.5.

    Avatar of Curt - RI
    Curt – RI
    Participant

    @curt-ri

    Thanks. Is there a link where I can still download 1.6.5? I took a look around but everything is 1.7.

    Thanks for your help. It’s appreciated.

    Oh, and actually the above-referenced post by Paul mentioned that Buddypress 1.6.2 required WordPress 3.5, but not the reverse.

    Again, your help is appreciated. Thanks ;)

    Avatar of Curt - RI
    Curt – RI
    Participant

    @curt-ri

    Does anyone have any other feedback for me on this problem?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Thanks. Is there a link where I can still download 1.6.5?

    @curt-ri as hnla mentioned above, you should be on BP 1.7 now. But if you still want BP 1.6.5 click on this link, download to your computer and unzip the file. Upload /buddypress/ folder within

    Avatar of Curt - RI
    Curt – RI
    Participant

    @curt-ri

    Thanks for the feedback. Maybe I will just bite the bullet and try upgrading to BP 1.7.

    Avatar of cybohmoob
    cybohmoob
    Participant

    @cybohmoob

    I went to the 1.7 and that solved most my theme, bug, and other minor issues.
    1.7 will also open up your THEME WORLD because it no longer requires BuddyPress specific themes. It can revive and use old as well as new themes that was NOT BP compatible before. Now works:)

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.