Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddy Press Not Sending Activation Email – BP 1.2.7 | WP 3.0.4

  • Avatar of ethanvandal
    ethanvandal
    Member

    @ethanvandal

    I’m very frustrated that this activation email sending problem has no known “cure”. I have investigated the problem via code surfing and I am || this close to overriding the current activation mail sending function with my own based on php mail. PLEASE, tell me there is a better solution and I am just missing the obvious. Basically this bug renders buddy press a useless space taking plugin.

    I have seen multiple people say “I fixed it!” and then they never leave the solution on the forums. I don’t think bypassing the BP activation mail send function is going to be a good thing long term so I would immensely appreciate a fix that is integrated into BP.

    Thanks for reading this post!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of Virtuali
    Virtuali
    Participant

    @gunju2221

    Buddypress, as mentioned many, many, many times, is wired through the wordpress emails.

    Buddypress has absolutely nothing to do with the emails. So don’t blame it on BP, there is nothing bp can do for the activation email really.

    As through searching on forums, this issue is rising problems after problem. Bluehost seems to be big with it, so try the “Mail From” plugin.

    Avatar of ethanvandal
    ethanvandal
    Member

    @ethanvandal

    I wonder if reverting to an older WP installation will fix the Activation Email problem… I have seen many people mention previous WP versions that they have made it work for.

    I installed the BP Disable Activation plugin available here: http://crashutah.com/

    Running BP 1.2.7 on WP 3.0.4! I’ll post again once I update to the new WP 3.1 and test it with my current PB installation.

    I will also try your suggestion of installing Mail From.

    Thanks,
    The Vandal

    Avatar of Virtuali
    Virtuali
    Participant

    @gunju2221

    No, I would not recommend going to an earlier version of WP, the last few are critical security updates.

    With the mail plugin, it should work. I am not saying it will pop up immediately, it might take a few minutes, but it should be there sometime.

    This is “not” the case, I was running a complete wp 3.1 site, activation emails worked like a champ, and even saw send activation emails in the settings, now with BP that seems to have been ommitted, and the activation emails fail…. seems like we got some buck passing here….

    Avatar of Virtuali
    Virtuali
    Participant

    @gunju2221

    http://www.callum-macdonald.com/code/wp-mail-smtp/

    This one worked like a champ…with my smtp settings in place ;)

    I also had this problem and went through a deep analysis.

    The issue stems from the fact that Bluehost requires that the email be sent from an account that exists on the system. They do this as an anti-spam technique and they require this even if the mail is originating from within the system.

    Enter WordPress. PHP uses a mail function mail(). WordPress maps this to wp_mail() and pretty much everyone uses the wp_mail for the plugins within WordPress. This makes sense as it allows customization of WordPress mail at a relatively low cost of performance.

    Enter Buddypress. Buddypress places a filter upon wp_mail() such that all email originate from the user ‘noreply’ on the domain such that end users don’t reply to the notifications. Sounds cool.

    But remember that Bluehost does not allow email to be sent from non-accounts and that’s the catch.

    Using a foreign SMTP does not work for Bluehost blocks those ports. Using local SMTP will work but you need to provide the right setup and credentials. Finally, using mail-from plugin works since it filter’s the Buddyhost filter changing the email from address back to a valid Bluehost email account.

    Hopefully, this explains what is happening and you can choose which strategy you want to use to fix the problem.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.