Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyBar for bbPress

Viewing 25 replies - 1 through 25 (of 153 total)
  • Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    I must be exhausted. I don’t see the link for download.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Fixed…

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    Thank you sir =D Gonna check it out first thing in the morning.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Hey John,

    Thanks for the co-credit!

    You might want to add deep integration instructions in the readme.txt.

    Other than that, let’s see more BuddyPress sites out in the open!

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    You might want to add deep integration instructions in the readme.txt.

    It will make its way into the official readme.txt in the repo once it’s up. I tend to use a different deep integration method myself, so we’ll see how it flies in the wild. :)

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Quick note: this currently doesn’t rehook the javascript, but it will. Just need to sleep now. Haha!

    Avatar of josemv
    josemv
    Participant

    @el_terko

    Cool, have U tried it with bbP A6 ?

    Thanx to U and r-a-y for this !

    Avatar of Slava UA
    Slava UA
    Participant

    @slaffik

    It also works here:

    http://demo.cosydale.com/forum/

    It’s demo site. I’m using bbPress alpha 6, BuddyPress 1.0.1.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Quick note: this currently doesn’t rehook the javascript, but it will. Just need to sleep now. Haha!

    Since JJJ is in dreamland, for those that do want the javascript hook (even though I plan on not adding it for my own usage! Sorry IE6 users! :P ), here’s the extra code:

    Add this after line 29 of bp-buddybar.php:

    add_action( 'bb_head', 'bp_core_add_js' );
    add_action( 'bb_admin_head', 'bp_core_add_js');

    It should work, but somebody test it with IE6 and report back.

    Avatar of matthijsv
    MatthijsV
    Participant

    @matthijsv

    Thanks for the plugin! Using BudduPress 1.02 and Bbpres 1.01 I’expericiencing some problems:

    When I add the lines to my bb-config.php the only thing I get is a blank page, (error reporting seems to be not the issue).

    When I activate the plugin in the bbpress admin panel I get the following error:

    Fatal error: Call to undefined function get_site_option() in /usr/.../my-plugins/bp-buddybar.php on line 37

    Any suggestions?

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Hey matthijsv,

    What line are you adding to bb-config.php?

    You should only add this to line 2:

    require_once($_SERVER['DOCUMENT_ROOT'].'/wp-blog-header.php');

    Let us know what happens.

    Avatar of matthijsv
    MatthijsV
    Participant

    @matthijsv

    I was adding these lines (from the readme.txt)

    if ( !defined( 'ABSPATH' ) & !defined( 'XMLRPC_REQUEST' )) {
    define( 'WP_USE_THEMES', false );
    //
    // You will need to get the ABSOLUTE path to this file |
    // |/
    //include_once( '/usr/home/dragons/domains/dragonsconnect.eu/public_html/preview/wp-blog-header.php' );
    header( "HTTP/1.1 200 OK" );
    header( "Status: 200 All rosy" );
    }

    When I add the line you suggested I get the same result, no response at all from any bbpress page.

    -edit-

    Seems that wp-blog-header.php is causing the error, I’m expirimenting with commenting out some lines there atm.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Hey matthijsv,

    What happens when you switch out in bb-config.php:

    include_once( '/the/absolute/path/to/your/wp-blog-header.php' );

    for

    require_once($_SERVER['DOCUMENT_ROOT'].'/wp-blog-header.php');

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Hey matthijsv,

    You shouldn’t have to mess with wp-blog-header.php.

    Unless you made changes to it.

    Avatar of matthijsv
    MatthijsV
    Participant

    @matthijsv

    Hey ray,

    I’m using

    require_once($_SERVER['DOCUMENT_ROOT'].'/wp-blog-header.php'); right now but no different result.

    I find it strange that there is no output at all, no error messages…

    Ok, no changes to wp-blog-header.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Sorry you should use the official bb-config.php instructions that JJJ left, except replace:

    include_once( '/the/absolute/path/to/your/wp-blog-header.php' );

    for

    include_once($_SERVER['DOCUMENT_ROOT'].'/wp-blog-header.php');

    One question though, where do you have WPMU installed? in the root?

    Avatar of matthijsv
    MatthijsV
    Participant

    @matthijsv

    It’s hosted on a subdomain, but when I echo the output of $_SERVER['DOCUMENT_ROOT'], this seems to be matching with the correct path.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    So what happens when you go to your bbPress forums?

    The last thing you got to do is reactivate the BuddyBar plugin in bbPress!

    Did you do that?

    Avatar of matthijsv
    MatthijsV
    Participant

    @matthijsv

    Nothing happens, the server just sents a total blank page to the browser. So there’s no activating the plugin unfortunately.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    So you never had the chance to activate the plugin?

    I would recommend removing the deep integration code and seeing if you can access your forums first.

    Make sure your bbPress forums are in working order, then add the deep integration code, then activate the plugin.

    Avatar of matthijsv
    MatthijsV
    Participant

    @matthijsv

    No, I can only activate the plugin without adding the deep integration code.

    Conclusion: problem is with the including wp-blog-header.php in bb-config, not specifically in the plugin.

    Without the deep integration code the forum is working perfectly.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Hmm… some other people use wp-load.php to achieve deep integration, but that drives down performance quite a bit.

    If you’re having trouble including wp-blog-header.php, then I don’t know what to tell you!

    Something’s definitely up! Are you sure you have no errors in your server log or PHP log?

    Avatar of matthijsv
    MatthijsV
    Participant

    @matthijsv

    wp-load.php got the same result.

    Started off with a clean install (was planning on doing this later on) the Buddybar plug-in is working great!

    Now enabling/installing plug-in’s one by one to might figure out what caused the problem.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Cool! Glad to see you’re up and running!

    Avatar of matthijsv
    MatthijsV
    Participant

    @matthijsv

    Thanks for your support!

    Figured it out: Transposh Translation Filter was causing the blank page. http://transposh.org/

Viewing 25 replies - 1 through 25 (of 153 total)

The topic ‘BuddyBar for bbPress’ is closed to new replies.