Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddypres share it is not showing, could it be w3tc or add expire header?

  • Avatar of charlietech
    charlietech
    Participant

    @charlietech

    Well i was having an issue with the activity stream not showing up in my phone and someone told me to switch to wp super cache and the activity stream appear. they said the i clicked on box to cache login user which was wrong. in the process, my buddypress share it wasnt displaying either but it did work for a split second on my phone when i switch to the wp super cache and now its not working. My assumption is that im caching the images wrong and thats why its not displaying. Im not sure but could that be the reason? Could it be that i have my add expire header set up wrong?

    this is what i got

    ExpiresActive on
    ExpiresByType text/css “access plus 60 days”
    ExpiresByType text/javascript “access plus 60 days”
    ExpiresByType image/ico “access plus 60 days”
    ExpiresByType image/jpg “access plus 60 days”
    ExpiresByType image/jpeg “access plus 60 days”
    ExpiresByType image/gif “access plus 60 days”
    ExpiresByType image/png “access plus 60 days”
    ExpiresByType text/css “access plus 60 days”
    ExpiresByType text/html “access plus 60 days”

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    Don’t run cache on activity pages. Content is too dynamic.

    Avatar of charlietech
    charlietech
    Participant

    @charlietech

    what can i do if the homepage is my activity stream? check the set up http://xertionfitness.com

    Avatar of charlietech
    charlietech
    Participant

    @charlietech

    I didnt know you could cache individual pages. i have the slightest clue how to do that.

    Avatar of charlietech
    charlietech
    Participant

    @charlietech

    the login is being cached which is causing error for me to login which is not showing the activity stream. I didnt know you could cache the login and have it cause problems.

    How can i disable caching on activity pages when I made that my homepage?

    Avatar of charlietech
    charlietech
    Participant

    @charlietech

    @modemlooper

    i figure out that its the page caching in w3 total cache thats causing the login issue but Im still not seeing the bp share it icons.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    Not sure, could be JavaScript or a theme issue. Always activate BP default to rule out theme issues. Also deactivate plugins and go through each one.

    Avatar of charlietech
    charlietech
    Participant

    @charlietech

    thanks for the info. I went to the default and it was a theme issue. where would i look to try to fix the problem?

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    contact theme dev and see if it’s updated with current BP and have them work out problem.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.