Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddypress and IntenseDebate

  • Avatar of Mohit Kumar
    Mohit Kumar
    Participant

    @mohitkr05

    1.Have anyone tried IntenseDebate on a sitewide level.It will be quite useful to have such a smart commenting system integrated with buddypress.It syncs the profile with wordpress though.

    2.How can i enable intensedebate plugin for all the blogs sitewide.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    I activated it sitewide, but it totally removes the comment system on members blogs until members put in their information in the plugin. That is too complicated/confusing.

    So I deactivated sitewide and reactivated for the main blog only, but the comment system on the members blogs is still gone.

    Even deactivating and deleting the plugin entirely does not bring back the comment system on the members blogs -> IntenseDebate screws up your system!

    Another great Auttomatic product! ;-)

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    After completely removing IntenseDebate from the system, the default comment system is back on the main blog, but still completely gone from member blogs, even blogs created after removal of the plugin.

    Is there any way to reset the member blogs without having to reinstall the entire site? How can a plugin kill an entire component like that? Where does the plugin “turn off” the default comment system? Is there a way to force comments_template() to load?

    Installing Disqus did not fix the problem. Deactivated and deleted again.

    Is there a setting in the database that turns off comments?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    How can i enable intensedebate plugin for all the blogs sitewide.

    Looking at the WP plugin repository for this plugin, it does not indicate that it is meant for WPMU.

    Doing a quick Google I found this discussion on the IntenseDebate blog:

    http://blog.intensedebate.com/2009/08/11/new-customization-options/

    Go 7 or 8 comments down and you’ll see this reply from Beau Lebens:

    BuddyPress runs on a WPMU install, and ID is currently in use on a number of WPMU sites. There’s currently no way to “auto-activate” it for every blog created, but you can definitely activate it (and go through the install process) for each different blog you create on a WPMU install.

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    Thanks again Jeff Sayre!

    My main concern is now how to repair my installation. The comment system is totally gone from member blogs. I don’t see anything unusual in the database or template files.

    What is going on and how can I fix it? :-(

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    What I would do to find the answer is take a look at the Intense Debate plugin and see what exactly it does to turn itself on and replace comments. Then, see if you can manually remove it.

    Avatar of josemv
    josemv
    Participant

    @el_terko

    Hey, now I realize it was me who made the question regarding ID WPMU compatability !

    Glad it helped someone.

    @PeterV maybe if U make your question at ID´s website/blog you can find answer to your problem.

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    John James Jacoby, I’ve tried that, but IntenseDebate is a lot of code and I’m not that smart. Can’t find that on/off button.

    I’ve deleted all database tables from one of the member blogs (wp_2_ etc.) and imported a version from before I’d installed IntenseDebate. It had no effect.

    So whatever changes ID makes in the database, it is not in the blog tables. Perhaps in wp_bp_user_blogs_comments then? Or wp_sitemeta?

    Can’t find any likely candidates by going through the wpdb mentions in the main IntenseDebate plugin file.

    wp_1_options has several entries that look ID-related, like id_useIDComments, even after removing the plugin from the system. Is _transient_feed part of ID too?

    Deleting these entries has no effect whatsoever…

    Can a plugin make changes in php files?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    @Peter

    As IntenseDebate exports your WP comments into its own system, your issue is more than likely caused by IntenseDebate misbehaving. Your best bet is to post a question on their support forums and let them help you track down the cause. I found these two related threads:

    http://getsatisfaction.com/intensedebate/topics/intense_debate_comments_gone_missing

    http://getsatisfaction.com/intensedebate/topics/after_installing_intense_debate_no_widget_no_comments_all_gone

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    Thanks again Jeff.

    All these comments have to do with ID not functioning correctly after installation. My problem is that comments are gone from member blogs after removing ID completely.

    ID clashes with WPMU and/or BP. I remembered that Mohit Kumar had posted a question about it here. I’ve posted a question about this on the WPMU forum as well.

    I’ve searched on Google and the Intense Debate site, but what I’ve found so far is no encouraging. I’m now reinstalling my site…

    Avoid Intense Debate!

    EDIT1: Re-uploading the php files from before ID had no effect – as I kinda expected. So the problem must be in the database somewhere.

    Now deleting the database, importing an earlier version…

    EDIT2: Even reverting the database to the earlier version did not solve the problem. WTF??!! :-(

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    It was a template issue after all. Copying an earlier version of an entire template folder solved the problem, but I wasn’t able to pinpoint the cause. The comment tags looked normal and I hadn’t touched them.

    Which doesn’t solve the fundamental problems with IntenseDebate though. Next I’ll try to install it on the main blog only and hopefully the member blogs stay unaffected.

    Is there a way to offer plugins to member blogs selectively? Or is the only option all plugins on or off?

    Avatar of podictionary
    podictionary
    Participant

    @podictionary

    I am currently suffering from this problem (a) had intensedebate on a non-MU blog, (b) have removed it, (c) have installed buddypress, (d) neither wordpress admin notifications nor buddypress member notifications are being sent.

    @peterverkooijen what exactly did you do when you say “Copying an earlier version of an entire template folder solved the problem”?

    Avatar of podictionary
    podictionary
    Participant

    @podictionary

    Peterverkooijen answered me at

    http://buddypress.org/forums/topic/notifications-not-being-sent

    my question remains open there though, because (at this time) I haven’t solved the problem.

    (but thanks anyway Peter)

    Avatar of ds123
    ds123
    Participant

    @ds123

    anyone is intense debate plugin compatible with buddypress ?

    Avatar of imjscn
    imjscn
    Participant

    @imjscn

    As far as I can understand, the topic starter must be the blog ownner or authors. IntenseDebate works in the commenting system only. Is the correct? Does it provide a way to enable users or guests initiate a post?

    ok… so finally…. does the intensedebate plugin work with buddypress? if so… are there any steps to go through?

Viewing 15 replies - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.