Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddypress changing profile URLs when profile is updated

Viewing 12 replies - 1 through 12 (of 12 total)
  • did you file a trac ticket?

    nevermind – found it

    http://trac.buddypress.org/ticket/2642

    Avatar of genConnect
    genConnect
    Participant

    @genconnect

    I will check with our developer but I believe it was filed three weeks ago.

    fwiw – the wordpress backend checks if the same user_nicename AND user_login exist. if it does, it will attach a suffix (this is part of wp-includes/registration.php – wp_insert_user)

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    edit// ignore my ramblings: Previous two posts added while writing – mine null and void

    Are you sure this is a BP issue though? I can’t replicate your issue on a local test install, that you have a customised site with members listed in some manner of grouping is suggestive of a plugin at work possibly? I may be wide of the mark though on that.

    As was asked is there actually a ticket on this that we can look at or do you have a link to the post you made raising the issue.

    i think its a hybrid issue – if you update the user via wp-admin – that uses wp_insert_user (maybe the name is being changed or something to trigger the suffix increased that is used in wp instead of the buddypress front-end way)

    Avatar of genConnect
    genConnect
    Participant

    @genconnect

    Here is the trac ticket http://trac.buddypress.org/ticket/2642

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    @nuprn1
    fwiw – the wordpress backend checks if the same user_nicename AND user_login exist. if it does, it will attach a suffix (this is part of wp-includes/registration.php – wp_insert_user)

    So does that imply it’s not strictly a BP issue/ in which case the ticket really needs directing to WP if it’s to be dealt with.

    I’ve put my comments on the trac ticket.

    Avatar of Jeff Farthing
    Jeff Farthing
    Participant

    @jfarthing84

    Obviously when you edit a user in WP, it doesn’t append anything to the user_nicename.This happens when BP is active.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    I’ve added to the ticket, can’t replicate the issue.

    Avatar of Jeff Farthing
    Jeff Farthing
    Participant

    @jfarthing84

    I’ve added to the ticket, found the cause.

    Avatar of Michel Fortin
    Michel Fortin
    Participant

    @fortinmichel

    Jeff, what’s the solution then? Or how do we prevent this in the future? I read the ticket, but I’m at a loss. I’m encountering this problem right now, and I had to go into phpmyadmin to correct all the user_nicename fields to remove the -2 at the end. do we simply ask people not to put spaces in their usernames?

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.