Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress Default Widgets Styling – problem with separator |

  • Avatar of Mehmet
    Mehmet
    Participant

    @mhmtozek

    Hi,

    We are creating a new BuddyPress magazine theme but whiles styling default Groups and Members widgets we run into a problem because of | charactere that is hardcoded into widget file as

    `

    <a href="” id=”newest-groups” class=”selected”> |
    <a href="” id=”recently-active-groups” class=”selected”> |
    <a href="” id=”popular-groups” class=”selected”>

    `

    That separator is not wrapped with a span nor any other html tag, thus it is not that easy to have Active – Popular – Newest links to be customized. Is there a way to get rid of these separators without touching into core files?

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Short of making a new widget which inherits the built in widget, and overriding the method, no :/

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    There is a trac ticket to include a login widget since theme compat is killing sidebar code, I took ownership of ticket, I’ll look through other widgets and make markup better add anything missing.

    Avatar of Mehmet
    Mehmet
    Participant

    @mhmtozek

    @paul,
    Thanks for the suggestion, I just didnt want to deregister a widget and create exactly same one just because of two characters (:

    @modemlooper
    Thats great to hear (: It would make styling much easier if | would be wrapped by span for both Groups and Member widgets.

    Thanks again

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.