Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress Moderation 0.1.6

  • Avatar of voopress
    voopress
    Participant

    @voopress

    On a network site, the plugin is installed and shows in the network dashboard along with all of the other BP plugins.

    On the site where I have BP enabled, all but the Moderation plugin show up?
    Any thoughts on what is wrong?

    WP 3.5

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of voopress
    voopress
    Participant

    @voopress

    No one else has this problem?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @voopress

    1. the plugin has not been updated since WP 3.2.1

    2. it’s a weekend and it’s one that’s before a major holiday here so many forum volunteers are shopping or just taking some well-deserved rest or traveling somewhere, etc.

    3. http://plugins.svn.wordpress.org/bp-moderation/trunk/bpModLoader.php
    You can still activate the plugin network-wide even if you remove that “Network: true” from that file I linked to above in your plugins/bp-moderation/ folder so you could access it in subsite’s plugin panel. Having said that, no guarantees that the plugin would still work with WP 3.5

    Avatar of voopress
    voopress
    Participant

    @voopress

    Thank you for the reply. I have no problem waiting if that is safer. Just wasn’t sure if my post had gone lost.

    Avatar of voopress
    voopress
    Participant

    @voopress

    Changing that file from true to line removed didn’t work.
    The site burped out a php error complaining and turned off the plugin.

    Avatar of valuser
    valuser
    Participant

    @valuser

    WP 3.5 BP 1.6.2 Testing this plugin on local installs. first a single site with bp default theme. Flags show up correctly everywhere, backend settings show up —– but clicking on flags does nothing on my set-up.

    Hopefully the developer will come back to this or a bp angel will adopt it. Surely a vital component of any social network/forum ???

    Avatar of voopress
    voopress
    Participant

    @voopress

    And this is the most frustrating part about running a production site based on a community of now and then programmers.
    For so many years, we’ve been pushing open source, Linux, low cost software, etc etc but it’s always come back to hurt us one way or another unless we programmed our own stuff.

    I guess we wait or find a commercial solution.

    Avatar of valuser
    valuser
    Participant

    @valuser

    Yes, I suppose it’s always possible to commission a suitable developer to upgrade a single plugin.

    I must say that since coming on these forums (wp & bp & wpse) I have experienced nothing but hardworking, selfless givers who have slaved over and solved the sometimes absurd problems of takers (for the most part) like me. And in fairness the vast majority the stuff is up-to-date.

    Some open source bp plugins like bebop & commonsinabox have been helped along with grants from outside sources. Perhaps if there was some fund that some of us (or hopefully a lot of us) could contribute to in a small way that could be used to fund a project such as this (the updating of one buddypress plugin to be put back (working with current versions of wp & bp) in the wp repository) and then another and another.

    Avatar of billzy
    billzy
    Participant

    @billzy

    Agree’d this is must needed feature to reduce cyber bullying risks of hosting sites like these. Im going to look into finding a solution, the only other option is I have a guy who can fix this for 200-300 usd maybe less…

    Avatar of billzy
    billzy
    Participant

    @billzy

    Ok I’ve found a working solution using WP 3.5, bp 1.6.2 and bp-moderation 0.1.6 … I have my flagging and unflagging with backend reports working perfect now.

    Here is how I did it so you can fix yours:

    Step 1.
    Follow these steps to update some plugin code since the plugin is now unsupported.
    http://wordpress.org/support/topic/plugin-buddypress-moderation-not-working-with-bp-161-wp-342?replies=9#post-3267296

    Step 2.
    Step 1 only allowed me to flag and unflag content with the super admin account only. If you have the same problem then open bpModLoader.php and comment the lines 64-66.

    Change to following or delete to fix all users can flag posts.

    // if (!is_super_admin()) {
    // return;
    // }

    Hope this helps :D

    Cheers

    Avatar of valuser
    valuser
    Participant

    @valuser

    Many many thanks. This works. Absolutely thrilled! My earlier comments about these forums 100% vindicated.

    Avatar of mrjarbenne
    mrjarbenne
    Participant

    @mrjarbenne

    Those two fixes get me 90% of the way there, but on 3.5 and 1.7 when you are in the admin panel of Moderation, the link to “View” an Activity Update goes to domain.com/activity/[#] when it should go to domain.com/member/[membername]/activity/[#]

    Any thoughts?

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.