Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress Not Recording Most Site Activity

  • Avatar of Gogoplata
    gogoplata
    Participant

    @gogoplata

    Hi all! I haven’t been around much recently as things have been running smoothly and I haven’t had much spare time but I’m on spring break now and am hoping to spend a little of it on the forums absorbing all the latest information.

    Anyways, I’ve run into an issue on my site (mmafrenzy.com) where almost all of my site’s activity is not being recorded in the activity feeds. For example, over the last 30 days we’ve had over a hundred posts as well as 1,000+ comments yet there’s only 30 items in the sitewide activity feed since then. I’m really stumped on this and in looking around the forums it seems some others may also be having trouble with the activity feed recording activity properly but most don’t seem to be on this scale. The widget on community.mmafrenzy.com is supposed to show the most-recent 15 items and shouldn’t have anything more than a few hours old but is showing 5 day old items at present.

    I’m running the latest trunks of both BuddyPress and WPMU. Any ideas/suggestions?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Sounds like http://trac.buddypress.org/ticket/543. Try applying that change and seeing what happens. It won’t update “old” activity, but should apply to ongoing activity.

    Avatar of Gogoplata
    gogoplata
    Participant

    @gogoplata

    Thanks for the link, I’ll give that a try but I still think there’s a larger issue here.

    After letting it sit overnight I re-checked the activity feed this morning and though it has a few new items in now goes back over 3 weeks. In non-technical terms, it appears to not be recording most items and leaking the items it does record, eventually causing them to disappear from the feed.

    Avatar of Gogoplata
    gogoplata
    Participant

    @gogoplata

    Any more ideas?

    I’m planning on applying the above patch, cleanly installing the trunk tonight to make sure there’s no older files lingering on the server, and am also going to analyze the database to see whether it’s a problem with the events being recorded to the DB or whether it’s with the output.

    Hopefully it’s as simple as that but I’m afraid it’s likely more serious.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    gogoplata, this is running a week old now. Is it resolved? I’m turning off the light until you switch it back on.

Viewing 4 replies - 1 through 4 (of 4 total)

The topic ‘BuddyPress Not Recording Most Site Activity’ is closed to new replies.