Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress pages not appearing

  • Avatar of Kolokial
    Kolokial
    Participant

    @kolokial

    OKay, so i’ve installed BuddyPress and associated some pages to memebers, register and activate…But when I go to view the register page, (along with others) nothing appears. I’ve disabled all my other plugins to see if they were causing the issue, but alas that is not the case.

    I’ve also reset permalinks by setting to default and then back to ‘Post Name’. Still no joy.

    Can anyone suggest what I’m missing?

    http://www.migmag.co.uk/register/

    No HTML is loaded in the source either. It’s as though BP is not outputting anything…

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    I can see that bp classes are added to markup so BP is in action, that the BP content isn’t rendered suggests that the themes page.php breaks the WP process BP relies on, you have tested by reverting to a theme that works to see if it’s a theme issue haven’t you?

    Avatar of Kolokial
    Kolokial
    Participant

    @kolokial

    Eep, I admit, I had not. Though I have just done that and the pages appear correctly (so far as I can tell). Sorry that’s such a no-brainer I should have done it to begin with! If that is the case, am I correct in guessing there’s an obvious theme compatibility issue with BP and SoundCheck(Current WP theme). I’m going to browse BPs docs regarding theme building.

    Thanks Hugo!

    Avatar of Kolokial
    Kolokial
    Participant

    @kolokial

    Off hand…Hugo, (or anyone else) can you suggest which would be better, once I’ve gotten BP display in my current WP theme…should I just write some new styles to incorporate BuddyPress into the WP theme, or create a child theme that is seperate from the WP theme?

    Thanks folks!

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.